summaryrefslogtreecommitdiff
path: root/packages/appweb/appweb_1.2.0.bb
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2005-03-09 22:02:59 +0000
committerChris Larson <clarson@kergoth.com>2005-03-09 22:02:59 +0000
commit0fe95e93e6485a819cefa0d6d5f5a4d9ac800309 (patch)
tree9e651c7c1a7dcc3e76765775d1a4355e2d4022b8 /packages/appweb/appweb_1.2.0.bb
parent1eaf0ad2c89971f15b6ab7ce2a0688ef6869163f (diff)
Merge oe-devel@oe-devel.bkbits.net:openembedded
into handhelds.org:/home/kergoth/code/openembedded 2005/03/09 17:02:43-05:00 handhelds.org!kergoth Kill off some old appweb versions, and fix the appweb build to pass 'linux' into its configure script rather than 'linux-uclibc' when targeting uclibc. BKrev: 422f7293K2OlGz2oeNO6eboXgubDVQ
Diffstat (limited to 'packages/appweb/appweb_1.2.0.bb')
-rw-r--r--packages/appweb/appweb_1.2.0.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/packages/appweb/appweb_1.2.0.bb b/packages/appweb/appweb_1.2.0.bb
index dc0ac7d0dd..8cf506af2c 100644
--- a/packages/appweb/appweb_1.2.0.bb
+++ b/packages/appweb/appweb_1.2.0.bb
@@ -6,8 +6,14 @@ SRC_URI = "http://www.mbedthis.com/software/appWeb-src-1.2.0-1.tar.gz \
file://nonrootinstall.patch;patch=1"
S = "${WORKDIR}/appWeb-1.2.0"
-APPWEB_HOST = "${HOST_SYS}"
+APPWEB_HOST = "${@get_appweb_host(d, bb)}"
APPWEB_BUILD = "${BUILD_SYS}"
+
+def get_appweb_host(d, bb):
+ host = bb.data.getVar('HOST_SYS', d, 1)
+ return host.replace('-linux-uclibc', '-linux')
+
+
# --buildNumber=NUMBER Set the build number part of the version (1.0.0.X).
# --name=NAME Set the full product name (BLD_NAME define).
# --port=PORT Set the default HTTP port to use for the product.