summaryrefslogtreecommitdiff
path: root/packages/apache
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2005-08-24 16:27:50 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-24 16:27:50 +0000
commit9ab834cb933cbe887ecc45a05086aeac9bcae5af (patch)
tree8dc51bf63102b2c25b2db367863bdf51adae976f /packages/apache
parent7106374e696b7d9f7e03702950352b5191ffa556 (diff)
parent09fc038cf066498585825d2706dec7accdc20edb (diff)
merge of 67c06308e7dc7f4e91adc69fedea16ec131bb45e
and ab3bfea881e8e12863a1707268606b7f864d1dc6
Diffstat (limited to 'packages/apache')
-rw-r--r--packages/apache/apache_2.0.54.bb30
-rwxr-xr-x[-rw-r--r--]packages/apache/files/init2
2 files changed, 22 insertions, 10 deletions
diff --git a/packages/apache/apache_2.0.54.bb b/packages/apache/apache_2.0.54.bb
index 53b27e9f7b..3ab58c590f 100644
--- a/packages/apache/apache_2.0.54.bb
+++ b/packages/apache/apache_2.0.54.bb
@@ -1,21 +1,22 @@
MAINTAINER="David Karlstrom <daka@nslu2-linux.org>"
SECTION = "net"
-DEPENDS = "openssl"
+DEPENDS = "openssl expat pcre"
-PR = "r1"
+PR = "r4"
# ------------------------------------------
# NOTE: This package is currently only meant
# to be built nativly on the target device
# ------------------------------------------
-SRC_URI = "http://www.apache.org/dist/httpd/httpd-${PV}.tar.gz"
+SRC_URI = "http://www.apache.org/dist/httpd/httpd-${PV}.tar.gz \
+ "
S = "${WORKDIR}/httpd-${PV}"
inherit autotools update-rc.d
-INITSCRIPT_NAME = "httpd"
+INITSCRIPT_NAME = "apache"
INITSCRIPT_PARAMS = "defaults 91 20"
CONFFILES_${PN} = "${sysconfdir}/apache/httpd.conf \
@@ -39,9 +40,20 @@ FILES_${PN} = "${bindir} ${sbindir} ${libexecdir} ${libdir}/lib*.so.* \
CFLAGS_append = " -DPATH_MAX=4096"
CFLAGS_prepend = "-I${STAGING_INCDIR}/openssl "
-EXTRA_OECONF = "--enable-ssl --with-ssl=${STAGING_LIBDIR}/.. --enable-dav \
- --enable-dav-fs --with-dbm=sdbm --with-berkeley-db=no --localstatedir=${localstatedir}/log/apache \
- --with-gdbm=no --with-ndbm=no --datadir=${datadir}/apache --sysconfdir=${sysconfdir}/apache"
+EXTRA_OECONF = "--enable-ssl \
+ --with-ssl=${STAGING_LIBDIR}/.. \
+ --enable-dav \
+ --enable-dav-fs \
+ --with-dbm=sdbm \
+ --with-berkeley-db=no \
+ --localstatedir=${localstatedir}/log/apache \
+ --with-gdbm=no \
+ --with-ndbm=no \
+ --datadir=${datadir}/apache \
+ --sysconfdir=${sysconfdir}/apache \
+ "
+
+export LD_LIBRARY_PATH=${STAGING_LIBDIR}
do_configure () {
# Looks like rebuilding configure doesn't work, so we are skipping
@@ -62,8 +74,8 @@ do_install_append () {
-e 's,/usr/bin/,${bindir}/,g' \
-e 's,/usr/lib,${libdir}/,g' \
-e 's,/etc/,${sysconfdir}/,g' \
- -e 's,/usr/,${prefix}/,g' > ${D}/${sysconfdir}/init.d/httpd
- chmod 755 ${D}/${sysconfdir}/init.d/httpd
+ -e 's,/usr/,${prefix}/,g' > ${D}/${sysconfdir}/init.d/apache
+ chmod 755 ${D}/${sysconfdir}/init.d/apache
install -m 0644 ${FILESDIR}/httpd.conf ${D}/${sysconfdir}/apache/httpd.conf
diff --git a/packages/apache/files/init b/packages/apache/files/init
index 46dae0395f..6c8ff0a6ec 100644..100755
--- a/packages/apache/files/init
+++ b/packages/apache/files/init
@@ -64,7 +64,7 @@ case "$1" in
;;
esac
-if [ $? == 0 ]; then
+if [ $? = 0 ]; then
echo .
exit 0
else