summaryrefslogtreecommitdiff
path: root/packages/antlr/antlr_2.7.7.bb
diff options
context:
space:
mode:
authorRobert Schuster <thebohemian@gmx.net>2008-11-25 14:49:51 +0100
committerRobert Schuster <thebohemian@gmx.net>2008-11-25 14:49:51 +0100
commite25498c0506d39145725647b3d7397bccd2e207d (patch)
treeed85ff9da88decf7361536a2a97280f0891e2c30 /packages/antlr/antlr_2.7.7.bb
parent6b6df778d84f2c2fb0f271b13d81502edfaf3afb (diff)
Replace non-working antlr recipe with working ones from Jalimo repo.
antlr 2.7.7: New recipe. antlr-native 2.7.7: New recipe.
Diffstat (limited to 'packages/antlr/antlr_2.7.7.bb')
-rw-r--r--packages/antlr/antlr_2.7.7.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/packages/antlr/antlr_2.7.7.bb b/packages/antlr/antlr_2.7.7.bb
new file mode 100644
index 0000000000..431b7b5b4f
--- /dev/null
+++ b/packages/antlr/antlr_2.7.7.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Framework for constructing recognizers, interpreters, compilers, and translators"
+# see http://www.antlr2.org/license.html
+LICENSE = "Public Domain"
+HOMEPAGE = "http://www.antlr2.org"
+
+SRC_URI = "http://www.antlr2.org/download/${BP}.tar.gz"
+
+inherit java-library
+
+do_compile() {
+ mkdir -p build
+
+ javac -sourcepath . -d build `find antlr -name "*.java"`
+
+ fastjar -C build -c -f ${JARFILENAME} .
+}