summaryrefslogtreecommitdiff
path: root/packages/anthy/anthy-native/native-helpers.patch
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-05-08 13:42:59 +0000
committerPhilipp Zabel <philipp.zabel@gmail.com>2008-05-08 13:42:59 +0000
commit32a21b6f84b24bae3c86be043449d1576bb955c7 (patch)
treee64f669d695c2b7ad302b0f51283d46b15522875 /packages/anthy/anthy-native/native-helpers.patch
parent3f43becc93a1407d517da1864987f9fca67e709e (diff)
anthy: update to 9100e
Diffstat (limited to 'packages/anthy/anthy-native/native-helpers.patch')
-rw-r--r--packages/anthy/anthy-native/native-helpers.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/packages/anthy/anthy-native/native-helpers.patch b/packages/anthy/anthy-native/native-helpers.patch
new file mode 100644
index 0000000000..5746ac18c8
--- /dev/null
+++ b/packages/anthy/anthy-native/native-helpers.patch
@@ -0,0 +1,48 @@
+Stage the native anthy helpers mkfiledic, mkdepgraph, mkworddic,
+calctrans and proccorpus.
+
+--- anthy-7811/mkanthydic/Makefile.am~ 2006-05-13 18:28:35.000000000 +0900
++++ anthy-7811/mkanthydic/Makefile.am 2006-06-18 10:56:25.770000000 +0900
+@@ -3,7 +3,7 @@
+ CLEANFILES = anthy.dic
+ INCLUDES = -I$(top_srcdir)/include -DSRCDIR=\"$(srcdir)\"
+
+-noinst_PROGRAMS = mkfiledic
++bin_PROGRAMS = mkfiledic
+ mkfiledic_SOURCES = mkfiledic.c
+ mkfiledic_LDADD = ../src-diclib/libdiclib.la
+
+--- anthy-7811/depgraph/Makefile.am~ 2006-06-02 00:20:54.000000000 +0900
++++ anthy-7811/depgraph/Makefile.am 2006-06-18 10:57:19.420000000 +0900
+@@ -9,7 +9,7 @@
+ EXTRA_DIST = indepword.txt $(DEPWORDS)
+
+ # Generate the dictionary
+-noinst_PROGRAMS = mkdepgraph
++bin_PROGRAMS = mkdepgraph
+ mkdepgraph_SOURCES = mkdepgraph.c
+ mkdepgraph_LDADD = ../src-main/libanthy.la ../src-worddic/libanthydic.la
+
+--- anthy-7811/mkworddic/Makefile.am~ 2006-05-13 18:29:07.000000000 +0900
++++ anthy-7811/mkworddic/Makefile.am 2006-06-18 11:21:56.300000000 +0900
+@@ -16,7 +16,8 @@
+ udict dict.args.in
+
+ # Generate the dictionary
+-noinst_PROGRAMS = mkworddic
++#noinst_PROGRAMS = mkworddic
++bin_PROGRAMS = mkworddic
+ mkworddic_SOURCES = mkdic.c writewords.c mkudic.c calcfreq.c mkdic.h
+ mkworddic_LDADD = ../src-worddic/libanthydic.la
+
+--- anthy-9100e.orig/calctrans/Makefile.am 2008-05-08 15:04:13.000000000 +0200
++++ anthy-9100e/calctrans/Makefile.am 2008-05-08 15:04:24.000000000 +0200
+@@ -3,7 +3,7 @@
+ corpus.3.txt corpus.4.txt corpus.5.txt\
+ corpus_info weak_words
+
+-noinst_PROGRAMS = calctrans proccorpus
++bin_PROGRAMS = calctrans proccorpus
+ INCLUDES = -I$(top_srcdir)/
+
+ calctrans_SOURCES = calctrans.c input_set.c input_set.h corpus.c