summaryrefslogtreecommitdiff
path: root/packages/altboot
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-05-26 12:56:04 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-26 12:56:04 +0000
commite5357d974467d9751a375d8db6d52ee98eeb180e (patch)
tree81dd474ec294c998fbef29aa7b885d2ddce1885b /packages/altboot
parentf4223494e69d4c3fb61ea068619363ed67987ef6 (diff)
parent8a06d3deaa7c6f7144d031c3b2142e5e69cff6b9 (diff)
merge of 6c892a12e5ecbf776b1486325e3502f44bfbee00
and a28eb0331581874fd47b01b78e86dc73b0c99fcd
Diffstat (limited to 'packages/altboot')
-rw-r--r--packages/altboot/altboot_1.0.7-rc3.bb93
-rw-r--r--packages/altboot/files/init.altboot10
2 files changed, 7 insertions, 96 deletions
diff --git a/packages/altboot/altboot_1.0.7-rc3.bb b/packages/altboot/altboot_1.0.7-rc3.bb
deleted file mode 100644
index 245cf2a426..0000000000
--- a/packages/altboot/altboot_1.0.7-rc3.bb
+++ /dev/null
@@ -1,93 +0,0 @@
-#! /bin/sh
-#
-# Copyright Matthias Hentges <devel@hentges.net> (c) 2006
-# License: GPL (see http://www.gnu.org/licenses/gpl.txt for a copy of the license)
-#
-# Filename: altboot_1.0.5-rc2.bb
-# Date: 21-Feb-06
-
-DESCRIPTION = "The altboot bootmanager"
-MAINTAINER = "Matthias 'CoreDump' Hentges <oe@hentges.net>"
-HOMEPAGE = "http://www.hentges.net/misc/openzaurus/index.shtml"
-LICENSE = "GPL"
-
-######################################################################################
-
-RRECOMMENDS_${PN} = "e2fsprogs-e2fsck dosfstools"
-RRECOMMENDS_${PN}_append_akita = " kexec-tools"
-RRECOMMENDS_${PN}_append_spitz = " kexec-tools"
-RRECOMMENDS_${PN}_append_c7x0 = " kexec-tools"
-
-RDEPENDS_${PN} = "${PN}-conf"
-RDEPENDS_${PN}-conf = "${PN}"
-
-######################################################################################
-
-PR = "r0"
-
-######################################################################################
-
-PACKAGES = "${PN}-conf ${PN}-doc ${PN}"
-
-PACKAGE_ARCH_${PN} = all
-PACKAGE_ARCH_${PN}-doc = all
-PACKAGE_ARCH_${PN}-conf = "${MACHINE}"
-
-TAG = "${@'v' + bb.data.getVar('PV',d,1).replace('.', '-')}"
-
-SRC_URI = "cvs://anonymous@hentges.net/hentgescvs;method=pserver;tag=${TAG};module=altboot"
-
-S = "${WORKDIR}/altboot/"
-
-######################################################################################
-
-FILES_${PN}-conf = "/etc/altboot*.cfg"
-
-######################################################################################
-
-do_install() {
- install -d ${D}/sbin
- install -d ${D}/etc/altboot-menu
- install -d ${D}/etc/altboot-menu/Advanced
- install -d ${D}/etc/altboot.rc
- install -d ${D}/usr/share/doc/altboot
- install -d ${D}/usr/share/sounds
-
- if test -d ${WORKDIR}/altboot/${MACHINE}
- then
- install -m 0644 ${WORKDIR}/altboot/${MACHINE}/altboot*.cfg ${D}/etc
- else
- install -m 0644 ${WORKDIR}/altboot/altboot*.cfg ${D}/etc
- fi
-
- install -m 0644 ${WORKDIR}/altboot/beep.raw ${D}/usr/share/sounds
- install -m 0644 ${WORKDIR}/altboot/altboot.func ${D}/etc
- install -m 0755 ${WORKDIR}/altboot/init.altboot ${D}/sbin
-
- install -m 0755 ${WORKDIR}/altboot/altboot-menu/*-* ${D}/etc/altboot-menu
-
- install -m 0755 ${WORKDIR}/altboot/altboot-menu/Advanced/*-* ${D}/etc/altboot-menu/Advanced
-
- install -m 0755 ${WORKDIR}/altboot/altboot.rc/*.sh ${D}/etc/altboot.rc
- install -m 0644 ${WORKDIR}/altboot/altboot.rc/*.txt ${D}/etc/altboot.rc
-}
-
-######################################################################################
-
-do_configure() {
- cat ${WORKDIR}/altboot/init.altboot | sed "s/^VERSION=.*/VERSION=\"${PV}\"/" > ${WORKDIR}/altboot/init.altboot_
- mv ${WORKDIR}/altboot/init.altboot_ ${WORKDIR}/altboot/init.altboot
-}
-
-######################################################################################
-
-pkg_postinst_${PN}() {
- update-alternatives --install /sbin/init init /sbin/init.altboot 55
-}
-
-######################################################################################
-
-pkg_postrm_${PN}() {
- update-alternatives --remove init /sbin/init.altboot
-}
-
diff --git a/packages/altboot/files/init.altboot b/packages/altboot/files/init.altboot
index 08ba81e962..2c106efa73 100644
--- a/packages/altboot/files/init.altboot
+++ b/packages/altboot/files/init.altboot
@@ -177,9 +177,12 @@ run_timer() {
case "`uname -r`" in
2.4*) key_ints="`cat /proc/interrupts | grep keyboard | awk '{print $2}'`";;
2.6*) key_ints="`cat /proc/interrupts | grep Spitzkbd`"
- test -z "$key_ints" && key_ints="`cat /proc/interrupts | grep -i corgikbd`";;
+ test -z "$key_ints" && key_ints="`cat /proc/interrupts | grep -i corgikbd`"
+ test -z "$key_ints" && key_ints="`cat /proc/interrupts | grep -i locomokbd`";;
esac
+ test -z "$key_ints" && debug_echo "Couldn't read keyboard ints!"
+
stty -echo <"$OUT_TTY" >"$OUT_TTY" 2>&1
echo -en "\n\nPlease press any key to launch altboot." > "$OUT_TTY"
@@ -192,7 +195,8 @@ run_timer() {
case "`uname -r`" in
2.4*) key_ints_now="`cat /proc/interrupts | grep keyboard | awk '{print $2}'`";;
2.6*) key_ints_now="`cat /proc/interrupts | grep Spitzkbd`"
- test -z "$key_ints_now" && key_ints_now="`cat /proc/interrupts | grep -i corgikbd`";;
+ test -z "$key_ints_now" && key_ints_now="`cat /proc/interrupts | grep -i corgikbd`"
+ test -z "$key_ints_now" && key_ints_now="`cat /proc/interrupts | grep -i locomokbd`";;
esac
if test "$key_ints_now" != "$key_ints" -o -z "$key_ints_now"
@@ -323,7 +327,7 @@ then
debug_shell 4 >/dev/null 2>&1 &
fi
-if test -f /proc/cmdline -a "`ps ax|wc -l|tr -d " "`" -gt 30 -a "$1" != "-force"
+if test -f /proc/cmdline -a "`ps ax|wc -l|tr -d " "`" -gt 30 -a "$1" != "-force" -a "$1" != "+force"
then
echo "altboot: Using real init [$REAL_INIT] [$*] [`ps ax|wc -l|tr -d " "`] *" >"$OUT_TTY"
exec $REAL_INIT $*