summaryrefslogtreecommitdiff
path: root/packages/altboot
diff options
context:
space:
mode:
authorMatthias Hentges <oe@hentges.net>2006-02-24 23:34:20 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-24 23:34:20 +0000
commit85af98589dc44171d216544bbcd47faeba01be28 (patch)
treede7d589c2874a9b3b6ebe795f0c961c1cf938921 /packages/altboot
parent76945f6290afc35fbb8f23ba907947396e7dd632 (diff)
altboot: update to 0.0.5-rc5. This version is known to work with kernel 2.4 an 2.6 (all plugins) on Akita
Diffstat (limited to 'packages/altboot')
-rw-r--r--packages/altboot/altboot_0.0.0.bb2
-rw-r--r--packages/altboot/altboot_0.0.5-rc5.bb (renamed from packages/altboot/altboot_0.0.5-rc4.bb)2
-rw-r--r--packages/altboot/files/altboot-menu/Advanced/40-bootNFS2
-rw-r--r--packages/altboot/files/altboot-menu/Advanced/70-install-tgz12
-rw-r--r--packages/altboot/files/altboot.func6
-rw-r--r--packages/altboot/files/init.altboot3
6 files changed, 14 insertions, 13 deletions
diff --git a/packages/altboot/altboot_0.0.0.bb b/packages/altboot/altboot_0.0.0.bb
index 18cce34a90..e52070c817 100644
--- a/packages/altboot/altboot_0.0.0.bb
+++ b/packages/altboot/altboot_0.0.0.bb
@@ -6,7 +6,7 @@ MAINTAINER = "Matthias 'CoreDump' Hentges <oe@hentges.net>"
LICENSE = "GPL"
IGNORE_STRIP_ERRORS = "1"
-PR = "r23"
+PR = "r24"
SRC_URI = "file://altboot-menu \
diff --git a/packages/altboot/altboot_0.0.5-rc4.bb b/packages/altboot/altboot_0.0.5-rc5.bb
index 20497a8a55..1cb51a3639 100644
--- a/packages/altboot/altboot_0.0.5-rc4.bb
+++ b/packages/altboot/altboot_0.0.5-rc5.bb
@@ -12,7 +12,7 @@ HOMEPAGE = "http://www.hentges.net/misc/openzaurus/index.shtml"
######################################################################################
-PR = "r2"
+PR = "r0"
######################################################################################
diff --git a/packages/altboot/files/altboot-menu/Advanced/40-bootNFS b/packages/altboot/files/altboot-menu/Advanced/40-bootNFS
index cf1d1da8e6..3a41fccf79 100644
--- a/packages/altboot/files/altboot-menu/Advanced/40-bootNFS
+++ b/packages/altboot/files/altboot-menu/Advanced/40-bootNFS
@@ -116,7 +116,7 @@ run_module() {
# Use configured resolv.conf in the pivoted rootfs
echo -n "Copying resolv.conf..."
- cp /etc/resolv.conf /media/nfsroot/etc && echo ok || echo "FAILED"
+ #cp /etc/resolv.conf /media/nfsroot/etc && echo ok || echo "FAILED"
check_target "/media/nfsroot"
diff --git a/packages/altboot/files/altboot-menu/Advanced/70-install-tgz b/packages/altboot/files/altboot-menu/Advanced/70-install-tgz
index c525b9154c..2ae44fa890 100644
--- a/packages/altboot/files/altboot-menu/Advanced/70-install-tgz
+++ b/packages/altboot/files/altboot-menu/Advanced/70-install-tgz
@@ -102,8 +102,11 @@ clear_directories(){
for d in bin dev media proc sys usr boot etc lib mnt sbin tmp var
do
- echo "Removing [$1/$d]..."
- rm -rf "$1/$d"
+ if test -d "$1/$d"
+ then
+ echo "Removing [$1/$d]..."
+ rm -rf "$1/$d"
+ fi
done
}
@@ -128,8 +131,7 @@ install_rootfs_direct(){
echo "Please press <ENTER> to begin the installation"
read junk </dev/tty0 >/dev/tty0 2>&1
-
- mount | grep -q "$1 " || die "Installation target [$1] not mounted"
+
test -d "$1" || die "Directory [$1] not found"
echo -n "Installing rootfs, please wait..."
@@ -208,7 +210,7 @@ install_rootfs_image(){
if test -n "$junk"
then
- if test "$junk" -gt 1
+ if test "$junk" -gt 30
then
echo -n "Is [${junk}Mb] correct? [Y|n] "
read junk2
diff --git a/packages/altboot/files/altboot.func b/packages/altboot/files/altboot.func
index ec3479257e..d7737ece96 100644
--- a/packages/altboot/files/altboot.func
+++ b/packages/altboot/files/altboot.func
@@ -65,7 +65,7 @@ pivot_realfs() {
test -z "$2" && RL="5" || RL="$2"
mkdir -p $1/media/ROM || die "mkdir -p $1/media/ROM failed"
- mount -o remount,ro /
+ mount -o remount,ro / >/dev/null 2>&1
do_pivot "$1" "$RL"
}
@@ -352,14 +352,14 @@ mount_cf(){
then
echo "Note: /media/cf is already mounted"
else
- /etc/init.d/pcmcia status | grep -q running || /etc/init.d/pcmcia start && echo "Note: cardmgr already active"
+ /etc/init.d/pcmcia status | grep -q running || /etc/init.d/pcmcia start && echo "Note: cardmgr is already active"
echo ""
# Give the SD and CF mounting some time. This is a must for SD
sleep 2
- mount /media/cf
+ mount | grep -q "/media/cf " || mount /media/cf
fi
}
diff --git a/packages/altboot/files/init.altboot b/packages/altboot/files/init.altboot
index 871ae82d71..850912f20c 100644
--- a/packages/altboot/files/init.altboot
+++ b/packages/altboot/files/init.altboot
@@ -255,8 +255,7 @@ wait_for_input() {
# Don't remount rw if the drive is already mounted rw
# Only helpful for testing / debugging
if test "`mount|sed -n "/\/dev\/root/s/.*(\(.*\))/\1/p"`" != "rw"
- then
-
+ then
mount -o remount,rw / >/dev/null 2>&1
echo "$junk" > /etc/altboot.conf
mount -o remount,ro / >/dev/null 2>&1