summaryrefslogtreecommitdiff
path: root/packages/altboot
diff options
context:
space:
mode:
authorMatthias Hentges <oe@hentges.net>2005-08-10 16:30:28 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-10 16:30:28 +0000
commit0d36579720e688f85f694d436035faca6f41496c (patch)
treedf42cf2d44e094f84306300ec46d6efd7c269419 /packages/altboot
parentd3b69509e02e1e22f581328be6a638c15c1a282d (diff)
altboot: Fix /etc/altboot.rc scanning and adjust the "Master Password" notice to 240x320 screens
Diffstat (limited to 'packages/altboot')
-rw-r--r--packages/altboot/altboot.bb2
-rw-r--r--packages/altboot/files/altboot.func4
-rw-r--r--packages/altboot/files/init.altboot4
3 files changed, 5 insertions, 5 deletions
diff --git a/packages/altboot/altboot.bb b/packages/altboot/altboot.bb
index 80e22d1924..882336e598 100644
--- a/packages/altboot/altboot.bb
+++ b/packages/altboot/altboot.bb
@@ -6,7 +6,7 @@ MAINTAINER = "Matthias 'CoreDump' Hentges <oe@hentges.net>"
LICENSE = "GPL"
-PR = "r5"
+PR = "r6"
SRC_URI = "file://altboot-menu \
diff --git a/packages/altboot/files/altboot.func b/packages/altboot/files/altboot.func
index 251368a577..3a6c743f0d 100644
--- a/packages/altboot/files/altboot.func
+++ b/packages/altboot/files/altboot.func
@@ -182,9 +182,9 @@ set_password() {
mount -o remount,rw /
if test -z "$MASTER_PASSWORD"
then
- echo -e "\nAltboot is a boot-manager which allows to boot from SD, CF and NFS"
+ echo -e "\nAltboot is a boot-manager which allows to boot from SD,\nCF and NFS"
echo -e "\nFor security reasons altboot requires a password\nto boot into init=/bin/sh."
- echo -e "${C_RED}This is *not* your root password! It is used by altboot alone!${C_RESET}"
+ echo -e "${C_RED}This is *not* your root password!\nIt is used by altboot alone!${C_RESET}"
echo -e "${C_BLUE}\nNote:\tThe password will be echoed to the screen\n\tand it will be asked twice for confirmation.${C_RESET}"
echo -e "\nPlease enter a new master password:\n"
diff --git a/packages/altboot/files/init.altboot b/packages/altboot/files/init.altboot
index 26b4639ccd..5c28edb5f3 100644
--- a/packages/altboot/files/init.altboot
+++ b/packages/altboot/files/init.altboot
@@ -252,11 +252,11 @@ else
# Execute scripts in /etc/altboot.rc before doing anything else.
# Required for special situations, like booting spitz
- RC_FILES=`ls /etc/altboot.rc | grep \\\\.sh$`
+ RC_FILES=`ls /etc/altboot.rc | grep \.sh$`
for file in $RC_FILES
do
- . $file >/dev/tty1 2>&1 || echo "/etc/altboot.rc/$file failed!"
+ . /etc/altboot.rc/$file >/dev/tty1 2>&1 || echo "/etc/altboot.rc/$file failed!"
done
if test "$ENABLE_ALTBOOT" != "yes"