summaryrefslogtreecommitdiff
path: root/packages/alsa/alsa-state.bb
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2007-03-10 20:18:42 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2007-03-10 20:18:42 +0000
commit7f326402389de854bf6a0fe1f6c835502d93eeca (patch)
tree88755bbee8e49c1196d8909ff467745268ad3fe5 /packages/alsa/alsa-state.bb
parent2fb45b3e70da7b793a15983c45750321091a92dc (diff)
parentba1212299e2a4b2b99c1d058660273eb92327490 (diff)
merge of '90a304fce9cf13425fbf98afbbbec3593382bdf4'
and 'd51040bef3f49c55b9af42502e1891181802e97a'
Diffstat (limited to 'packages/alsa/alsa-state.bb')
-rw-r--r--packages/alsa/alsa-state.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/packages/alsa/alsa-state.bb b/packages/alsa/alsa-state.bb
new file mode 100644
index 0000000000..53c69c5c69
--- /dev/null
+++ b/packages/alsa/alsa-state.bb
@@ -0,0 +1,50 @@
+#! /bin/sh
+#
+# Copyright Matthias Hentges <devel@hentges.net> (c) 2007
+# License: MIT (see http://www.opensource.org/licenses/mit-license.php
+# for a copy of the license)
+#
+# Filename: alsa-state.bb
+# Date: 20070308 (YMD)
+
+DESCRIPTION = "Default ALSA configuration"
+MAINTAINER = "Matthias 'CoreDump' Hentges <oe@hentges.net>"
+HOMEPAGE = "<homepage>"
+LICENSE = "GPL"
+
+######################################################################################
+
+PV = "0.0.2"
+PR = "r0"
+
+######################################################################################
+
+SRC_URI = "file://asound.state \
+ file://alsa-state"
+
+FILES_${PN} = "/etc/*"
+
+######################################################################################
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "alsa-state"
+INITSCRIPT_PARAMS = "defaults 10"
+
+######################################################################################
+
+do_install() {
+ install -d ${D}${sysconfdir}/init.d
+
+ install -m 0644 ${WORKDIR}/asound.state ${D}${sysconfdir}
+ install -m 0755 ${WORKDIR}/alsa-state ${D}${sysconfdir}/init.d
+}
+
+
+pkg_postinst_${PN}() {
+ if test -x /usr/sbin/alsactl
+ then
+ /usr/sbin/alsactl -f ${sysconfdir}/asound.state restore
+ fi
+}
+