summaryrefslogtreecommitdiff
path: root/packages/alsa/alsa-lib_1.0.11.bb
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@yahoo.com>2006-05-20 20:00:52 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-20 20:00:52 +0000
commit084c9245dd3df8371b85815abba3de6ab48a3c6c (patch)
treea4ddb9a67d74d4c8838b1005a424cc6bcc62aca7 /packages/alsa/alsa-lib_1.0.11.bb
parent6c0dddae8f2478c1bd7fc80ab05833d77eefd369 (diff)
alsa: updated to 1.0.11
Diffstat (limited to 'packages/alsa/alsa-lib_1.0.11.bb')
-rw-r--r--packages/alsa/alsa-lib_1.0.11.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/packages/alsa/alsa-lib_1.0.11.bb b/packages/alsa/alsa-lib_1.0.11.bb
new file mode 100644
index 0000000000..5075db6273
--- /dev/null
+++ b/packages/alsa/alsa-lib_1.0.11.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Alsa sound library"
+MAINTAINER = "Lorn Potter <lpotter@trolltech.com>"
+SECTION = "libs/multimedia"
+LICENSE = "GPL"
+PR = "r0"
+
+# configure.in sets -D__arm__ on the command line for any arm system
+# (not just those with the ARM instruction set), this should be removed,
+# (or replaced by a permitted #define).
+#FIXME: remove the following
+ARM_INSTRUCTION_SET = "arm"
+
+SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/alsa-lib-${PV}.tar.bz2"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--with-cards=pdaudiocf --with-oss=yes"
+
+do_stage () {
+ oe_libinstall -so -C src libasound ${STAGING_LIBDIR}/
+ install -d ${STAGING_INCDIR}/alsa/sound
+ install -m 0644 include/*.h ${STAGING_INCDIR}/alsa/
+ install -m 0644 include/sound/ainstr*.h ${STAGING_INCDIR}/alsa/sound/
+ install -d ${STAGING_DATADIR}/aclocal
+ install -m 0644 utils/alsa.m4 ${STAGING_DATADIR}/aclocal/
+}
+
+PACKAGES = "libasound alsa-server alsa-conf alsa-doc alsa-dev"
+FILES_libasound = "${libdir}/libasound.so*"
+FILES_alsa-server = "${bindir}"
+FILES_alsa-conf = "${datadir}"
+FILES_alsa-dev = "${libdir}/pkgconfig/ /usr/include/"