summaryrefslogtreecommitdiff
path: root/packages/aiostress
diff options
context:
space:
mode:
authorKristoffer Ericson <kristoffer_e1@hotmail.com>2006-10-25 23:27:19 +0000
committerKristoffer Ericson <kristoffer_e1@hotmail.com>2006-10-25 23:27:19 +0000
commite26108affb65e89fcf248a58564b9c25934a04a0 (patch)
tree3c27feb6d440ed2df41309dae277afc13427c12f /packages/aiostress
parentd7fd0e38cb60cb0ac871723c34616bf542d423cc (diff)
parent12f3d309156ac047b0826904ef729b83b997b8b5 (diff)
merge of 5d13f311dd93df73db461d6abca7480b39bbecbc
and 6bdfd4680fb56e499b8a254034efb752dead5002
Diffstat (limited to 'packages/aiostress')
-rw-r--r--packages/aiostress/.mtn2git_empty0
-rw-r--r--packages/aiostress/aiostress_0.0.bb17
2 files changed, 17 insertions, 0 deletions
diff --git a/packages/aiostress/.mtn2git_empty b/packages/aiostress/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/aiostress/.mtn2git_empty
diff --git a/packages/aiostress/aiostress_0.0.bb b/packages/aiostress/aiostress_0.0.bb
new file mode 100644
index 0000000000..8b4085ad4f
--- /dev/null
+++ b/packages/aiostress/aiostress_0.0.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Asynchronous I/O stress util"
+LICENSE = "GPLv2"
+DEPENDS = "libaio"
+
+SRC_URI = "ftp://ftp.suse.com/pub/people/mason/utils/aio-stress.c;md5sum=727e5fc3566837b3ea72f887d048769b"
+
+S = "${WORKDIR}"
+
+do_compile() {
+
+ cd ${S} && ${CC} aio-stress.c -o aio-stress -I${STAGING_INCDIR} -L${STAGING_LIBDIR} -laio -lpthread
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 aio-stress ${D}${bindir}
+}