summaryrefslogtreecommitdiff
path: root/packages/adobe-flash/flash-plugin_10.0.12.36.bb
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2009-02-13 14:12:54 -0500
committerPhilip Balister <philip@balister.org>2009-02-13 14:12:54 -0500
commit18992093169e9ebd2a61989b853986a77199be35 (patch)
treed08928e78b95ea9dcbd7a4f5a193b18e197e8a8d /packages/adobe-flash/flash-plugin_10.0.12.36.bb
parent36001a65d7eb5f4432b999d24c29501834a3b431 (diff)
parent97b340db7c7b9ee3ed53e02eaa63c9873f4e1610 (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'packages/adobe-flash/flash-plugin_10.0.12.36.bb')
-rw-r--r--packages/adobe-flash/flash-plugin_10.0.12.36.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/adobe-flash/flash-plugin_10.0.12.36.bb b/packages/adobe-flash/flash-plugin_10.0.12.36.bb
new file mode 100644
index 0000000000..d6cde60031
--- /dev/null
+++ b/packages/adobe-flash/flash-plugin_10.0.12.36.bb
@@ -0,0 +1,35 @@
+# Adobe provides two versions of flash player packages
+#
+# One "unversioned" download at :
+#
+# ${ADOBE_MIRROR}/install_flash_player_9_linux.tar.gz
+#
+# And the other, versioned, which is encapsulated in RPM.
+#
+# We use the versioned one to make sure we can keep track of the
+# version and thus do repeatable builds at the cost of future download
+# failures when adobe updates.
+DESCRIPTION = "Adobe Flash 9 plugin for Mozilla/Firefox web browsers"
+LICENSE = "AdobeFlash"
+DEPENDS = "rpm2cpio-native"
+PR = "r1"
+
+SRC_URI = "${ADOBE_MIRROR}/flash-plugin-${PV}-release.i386.rpm"
+
+do_configure() {
+ rpm=${WORKDIR}/flash-plugin-${PV}-release.i386.rpm
+ if [ -f "$rpm" ]; then
+ rpm2cpio.pl $rpm | cpio -id
+ find . -type f -exec mv -i {} "`pwd`" \;
+ fi
+}
+do_install() {
+ mkdir -p ${D}${libdir}/mozilla/plugins/
+ install -m 0755 libflashplayer.so ${D}${libdir}/mozilla/plugins/
+ # AFAIK this is not needed
+ # install -m 0644 flashplayer.xpt ${D}${libdir}/mozilla/plugins/
+}
+
+FILES_${PN} = "${libdir}/* ${libdir}/X11/*"
+
+COMPATIBLE_HOST = "i.86.*-linux"