summaryrefslogtreecommitdiff
path: root/mplayer
diff options
context:
space:
mode:
authorChris Lord <chris@openedhand.com>2004-09-24 12:50:38 +0000
committerChris Lord <chris@openedhand.com>2004-09-24 12:50:38 +0000
commit94af4cbac737ce5e035f03924bbf5f1ca4931c95 (patch)
tree82c3e75320c9289e47f439f039fa78a790216f74 /mplayer
parent4b7993d765944a2c6a0ab954079e4ac98b66dbe3 (diff)
Merge bk://openembedded@openembedded.bkbits.net/packages
into chris.(none):/home/cwiiis/oe/packages 2004/09/24 22:12:50+09:30 mithis.com!mithro Working mplayer which uses the w100 vidix driver. BKrev: 4154181exwDpZri1n7fC1jg_GwfqtA
Diffstat (limited to 'mplayer')
-rw-r--r--mplayer/mplayer-w100-1.0pre3try2/Makefile-vidix.patch11
-rw-r--r--mplayer/mplayer-w100-1.0pre3try2/Makefile.patch41
-rw-r--r--mplayer/mplayer-w100-1.0pre3try2/mplayer-w100_1.0pre3.1.modified.diff0
-rw-r--r--mplayer/mplayer-w100-1.0pre3try2/sdl.patch0
-rw-r--r--mplayer/mplayer-w100_1.0pre3try2.oe59
5 files changed, 111 insertions, 0 deletions
diff --git a/mplayer/mplayer-w100-1.0pre3try2/Makefile-vidix.patch b/mplayer/mplayer-w100-1.0pre3try2/Makefile-vidix.patch
index e69de29bb2..9c84bdd05c 100644
--- a/mplayer/mplayer-w100-1.0pre3try2/Makefile-vidix.patch
+++ b/mplayer/mplayer-w100-1.0pre3try2/Makefile-vidix.patch
@@ -0,0 +1,11 @@
+--- ./vidix/drivers/Makefile 2004-09-24 19:05:49.000000000 +0930
++++ ./vidix/drivers/Makefile~mplayer-w100_1.0pre3.1.modified.diff 2003-10-23 02:15:33.000000000 +0930
+@@ -151,7 +138,7 @@
+
+ install:
+ mkdir -p $(LIBDIR)/mplayer/vidix
+- -install -m 755 -s -p *.so $(LIBDIR)/mplayer/vidix
++ -install -m 755 -p *.so $(LIBDIR)/mplayer/vidix
+ uninstall:
+ rm -f $(LIBDIR)/mplayer/vidix/*.so
+ rmdir -p --ignore-fail-on-non-empty $(LIBDIR)/mplayer/vidix
diff --git a/mplayer/mplayer-w100-1.0pre3try2/Makefile.patch b/mplayer/mplayer-w100-1.0pre3try2/Makefile.patch
index e69de29bb2..6cd49bb1c8 100644
--- a/mplayer/mplayer-w100-1.0pre3try2/Makefile.patch
+++ b/mplayer/mplayer-w100-1.0pre3try2/Makefile.patch
@@ -0,0 +1,41 @@
+--- ./Makefile~Makefile.patch 2004-09-24 20:07:12.000000000 +0930
++++ ./Makefile 2004-09-24 20:09:38.000000000 +0930
+@@ -10,10 +10,6 @@
+ PRG_CFG = codec-cfg
+ PRG_MENCODER = mencoder
+
+-# Do not strip the binaries at installation
+-ifeq ($(STRIPBINARIES),yes)
+-INSTALLSTRIP = -s
+-endif
+
+ # These subdirectories require installation due to binaries within them.
+ ifeq ($(VIDIX),yes)
+@@ -212,7 +208,8 @@
+
+ $(PRG): $(MPLAYER_DEP)
+ ./darwinfixlib.sh $(MPLAYER_DEP)
+- $(CC) $(CFLAGS) -o $(PRG) $(OBJS_MPLAYER) libvo/libvo.a libao2/libao2.a $(MENU_LIBS) $(VIDIX_LIBS) $(GUI_LIBS) $(COMMON_LIBS) $(GTK_LIBS) $(VO_LIBS) $(AO_LIBS) $(EXTRA_LIB) $(LIRC_LIB) $(LIRCC_LIB) $(STATIC_LIB) $(ARCH_LIB) $(I18NLIBS) -lm
++ $(CC) $(CFLAGS) -o $(PRG) $(OBJS_MPLAYER) libvo/libvo.a libao2/libao2.a $(MENU_LIBS) $(VIDIX_LIBS) $(GUI_LIBS) $(COMMON_LIBS) $(GTK_LIBS) $(VO_LIBS) $(AO_LIBS) $(EXTRA_LIB) $(LIRC_LIB) $(LIRCC_LIB) $(STATIC_LIB) $(ARCH_LIB) $(I18NLIBS) -lm -ljpeg -lpng -lts
++
+
+ mplayer.exe.spec.c: libmpcodecs/libmpcodecs.a
+ winebuild -fPIC -o mplayer.exe.spec.c -exe mplayer.exe -mcui \
+@@ -246,7 +243,7 @@
+ $(MENCODER_DEP): version.h
+
+ $(PRG_CFG): version.h codec-cfg.c codec-cfg.h
+- $(CC) $(CFLAGS) -g codec-cfg.c mp_msg.c -o $(PRG_CFG) -DCODECS2HTML $(EXTRA_LIB) $(I18NLIBS)
++ $(BUILD_CC) -Ilibmpdemux -Iloader -Ilibvo -g codec-cfg.c mp_msg.c -o $(PRG_CFG) -DCODECS2HTML $(EXTRA_LIB) $(I18NLIBS)
+
+ install: $(ALL_PRG)
+ ifeq ($(VIDIX),yes)
+@@ -316,7 +313,7 @@
+ -$(MAKE) -C libavcodec distclean LIBPREF=lib LIBSUF=.a
+
+ strip:
+- strip -s $(ALL_PRG)
++
+
+ dep: depend
+
diff --git a/mplayer/mplayer-w100-1.0pre3try2/mplayer-w100_1.0pre3.1.modified.diff b/mplayer/mplayer-w100-1.0pre3try2/mplayer-w100_1.0pre3.1.modified.diff
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/mplayer/mplayer-w100-1.0pre3try2/mplayer-w100_1.0pre3.1.modified.diff
diff --git a/mplayer/mplayer-w100-1.0pre3try2/sdl.patch b/mplayer/mplayer-w100-1.0pre3try2/sdl.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/mplayer/mplayer-w100-1.0pre3try2/sdl.patch
diff --git a/mplayer/mplayer-w100_1.0pre3try2.oe b/mplayer/mplayer-w100_1.0pre3try2.oe
index e69de29bb2..4b36ba0934 100644
--- a/mplayer/mplayer-w100_1.0pre3try2.oe
+++ b/mplayer/mplayer-w100_1.0pre3try2.oe
@@ -0,0 +1,59 @@
+DESCRIPTION = "Open Source multimedia player."
+SECTION = "opie/games"
+PRIORITY = "optional"
+DEPENDS = "libsdl-qpe libmad tremor-20030325 libogg libvorbis zlib libpng jpeg"
+
+SRC_URI = "http://www1.mplayerhq.hu/MPlayer/releases/MPlayer-${PV}.tar.bz2 \
+ file://mplayer-w100_1.0pre3.1.modified.diff;patch=1 \
+ file://Makefile.patch;patch=0 \
+ file://Makefile-vidix.patch;patch=0 \
+ file://sdl.patch;patch=0 \
+ file://zlib.patch;patch=0 "
+S = "${WORKDIR}/MPlayer-${PV}"
+
+FILES_${PN} = " \
+ /usr/local/bin/mplayer \
+ /usr/local/lib/mplayer/vidix/w100_vid.so "
+
+inherit autotools
+
+EXTRA_OECONF = " \
+ --target=arm \
+ \
+ --disable-win32 \
+ --disable-macosx \
+ --disable-dvdread \
+ --disable-mpdvdkit \
+ --disable-tv \
+ --disable-tv-v4l \
+ --disable-tv-v4l2 \
+ --disable-tv-bsdbt848 \
+ --disable-mencoder \
+ \
+ --enable-dynamic-plugins \
+ --enable-fbdev \
+ --enable-vidix \
+ --enable-sdl \
+ --with-sdl-config=${STAGING_BINDIR}/sdl-config \
+ \
+ --enable-mad \
+ --enable-tremor \
+ --enable-vorbis \
+ \
+ --enable-ossaudio \
+ \
+ --with-extralibdir=${STAGING_LIBDIR} "
+
+# --enable-static \
+# --enable-live \
+# --with-livelibdir=/Projects/armbuild/live \
+# --host=${HOST} \
+# --cc=arm-linux-gcc \
+# --disable-dvdnav \
+
+# CFLAGS += " -ljpeg -lpng -lts "
+
+do_configure() {
+ ./configure ${EXTRA_OECONF}
+}
+