summaryrefslogtreecommitdiff
path: root/libxine
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-01-13 17:12:50 +0000
committerChris Larson <clarson@kergoth.com>2004-01-13 17:12:50 +0000
commitc66ca9c303bb6078b513c6b0f528667da74396ee (patch)
tree6313474cc0dc81f68d8e860834eed46dce44fe87 /libxine
parentfc22411e12ff4762ec5997d543c5637398580437 (diff)
Merge direwolf.itg.ti.com:/home/kergoth/coding/projects/user/oe-metadata/paths
into direwolf.itg.ti.com:/home/kergoth/coding/projects/user/oe-metadata/packages 2004/01/13 11:10:14-06:00 ti.com!kergoth Merge openembedded@openembedded.bkbits.net:packages into direwolf.itg.ti.com:/home/kergoth/coding/projects/user/oe-metadata/paths 2004/01/13 10:56:32-06:00 ti.com!kergoth Remove hardcoded references to target paths in a number of packages, replacing them with the use of our target path variables. 2004/01/13 17:40:06+01:00 uni-frankfurt.de!mickeyl Merge bk://openembedded@openembedded.bkbits.net/packages into gandalf.tm.informatik.uni-frankfurt.de:/usr/local/projects/oe-packages 2004/01/13 14:24:53+01:00 uni-frankfurt.de!mickeyl add pyserial and sgmlop to buildsystem BKrev: 40042712PUToOUzefh1XdY4q23VfEA
Diffstat (limited to 'libxine')
-rw-r--r--libxine/libxine_1.6.0.oe72
1 files changed, 72 insertions, 0 deletions
diff --git a/libxine/libxine_1.6.0.oe b/libxine/libxine_1.6.0.oe
index e69de29bb2..310a7a44c6 100644
--- a/libxine/libxine_1.6.0.oe
+++ b/libxine/libxine_1.6.0.oe
@@ -0,0 +1,72 @@
+DESCRIPTION = "libxine"
+SECTION="base"
+PRIORITY="optional"
+MAINTAINER="Pawel Osiczko <p.osiczko@tetrapyloctomy.org>"
+DEPENDS = virtual/libc zlib libogg tremor libmad
+RDEPENDS = libc6 zlib libogg tremor libmad
+
+inherit autotools
+
+S = ${WORKDIR}/xine-lib
+
+SRC_URI = "cvs://anonymous@cvs.xine.sf.net/cvsroot/xine;module=xine-lib;tag=xine-1-beta12-release \
+ file://${FILESDIR}/full.patch;patch=1 \
+ file://${FILESDIR}/libvorbis.patch;patch=0 \
+ file://${FILESDIR}/demux_ogg.patch;patch=0 \
+ file://${FILESDIR}/configure.ac.patch;patch=0 \
+ file://${FILESDIR}/vo_scale.patch;patch=0"
+
+do_configure() {
+ ./autogen.sh --host ${TARGET_SYS} --build ${BUILD_SYS} \
+ --enable-shared --disable-static --prefix=${prefix} \
+ --with-zlib-path=${STAGING_DIR} --with-vorbis-prefix=${STAGING_DIR} \
+ --disable-oggtest --with-ogg-prefix=${STAGING_DIR} --without-x \
+ --disable-iconv --disable-nls --without-arts --without-sdl \
+ --disable-aalib
+}
+
+do_compile() {
+ oe_runmake LIBTOOL=${STAGING_BINDIR}/arm-linux-libtool
+}
+
+# ug - we don't do elegant/purdy today
+do_install() {
+ oe_runmake -e LIBTOOL=${STAGING_BINDIR}/arm-linux-libtool \
+ -C src install-data \
+ 'prefix=${D}' 'exec_prefix=${D}' 'libdir=${D}/${libdir}' \
+ 'includedir=${D}/${includedir}'
+ oe_runmake -e LIBTOOL=${STAGING_BINDIR}/arm-linux-libtool \
+ -C include install-data \
+ 'prefix=${D}' 'exec_prefix=${D}' 'libdir=${D}/${libdir}' \
+ 'includedir=${D}/${includedir}'
+ install -m 0755 -d ${D}/${libdir}/xine/plugins/1.0.0
+ for plugin in `find ${S}/src -type f -name xineplug*.la`; do
+ dso=`dirname $plugin`/.libs/`basename $plugin .la`.so
+ install -m 0755 $dso ${D}/${libdir}/xine/plugins/1.0.0
+ done
+ install -m 0755 src/xine-engine/.libs/libxine.so.${PV} ${D}${libdir}
+ ln -fs libxine.so.$PV ${D}${libdir}/libxine.so.1
+ ln -fs libxine.so.$PV ${D}${libdir}/libxine.so
+}
+
+do_stage() {
+ oe_runmake -e LIBTOOL=${STAGING_BINDIR}/arm-linux-libtool \
+ -C src install-data \
+ 'prefix=${STAGING_DIR}' 'exec_prefix=${STAGING_DIR}' \
+ 'libdir=${STAGING_DIR}/target/lib' \
+ 'includedir=${STAGING_DIR}/target/include'
+ oe_runmake -e LIBTOOL=${STAGING_BINDIR}/arm-linux-libtool \
+ -C include install-data \
+ 'prefix=${STAGING_DIR}' 'exec_prefix=${STAGING_DIR}' \
+ 'libdir=${STAGING_DIR}/target/lib' \
+ 'includedir=${STAGING_DIR}/target/include'
+ install -m 0755 -d ${STAGING_DIR}/target/lib/xine/plugins/1.0.0
+ for plugin in `find ${S}/src -type f -name xineplug*.la`; do
+ dso=`dirname $plugin`/.libs/`basename $plugin .la`.so
+ install -m 0755 $dso ${STAGING_DIR}/target/lib/xine/plugins/1.0.0
+ done
+ install -m 0755 src/xine-engine/.libs/libxine.so.${PV} \
+ ${STAGING_DIR}/target/lib
+ ln -fs libxine.so.$PV ${STAGING_DIR}/target/lib/libxine.so.1
+ ln -fs libxine.so.$PV ${STAGING_DIR}/target/lib/libxine.so
+}