summaryrefslogtreecommitdiff
path: root/irssi
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-12-02 08:36:32 +0000
committerChris Larson <clarson@kergoth.com>2004-12-02 08:36:32 +0000
commit7ae4ddc42946f8036ee7d3ef7ece9da803b3f707 (patch)
treec72b66deb32529ea28dc02e8e0e5c086fb9eecec /irssi
parent0bd34b9efc3fe5ecd9b5b9fe9a2284815aa431f7 (diff)
Stage irssi's bits, and add xirssi from cvs.
BKrev: 41aed410NdADD9nIGs7sL7lHZLhEXw
Diffstat (limited to 'irssi')
-rw-r--r--irssi/irssi_cvs.oe58
-rw-r--r--irssi/xirssi_cvs.oe0
2 files changed, 58 insertions, 0 deletions
diff --git a/irssi/irssi_cvs.oe b/irssi/irssi_cvs.oe
index e69de29bb2..3c0fe0ef8e 100644
--- a/irssi/irssi_cvs.oe
+++ b/irssi/irssi_cvs.oe
@@ -0,0 +1,58 @@
+DESCRIPTION = "Irssi is a modular IRC client with Perl scripting."
+HOMEPAGE = "http://irssi.org/"
+SECTION = "console/network"
+LICENSE = "GPL"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+DEPENDS = "ncurses glib-2.0"
+PV = "0.8.9+cvs${CVSDATE}"
+PR = "r1"
+
+inherit autotools
+
+SRC_URI = "cvs://anonymous:@cvs.irssi.org/home/cvs;module=irssi \
+ file://autofoo.patch;patch=1"
+S = "${WORKDIR}/irssi"
+
+EXTRA_OECONF = "--enable-ipv6 \
+ --disable-ssl \
+ --disable-glibtest \
+ --without-socks \
+ --with-textui \
+ --without-bot \
+ --without-proxy \
+ --without-glib1 \
+ --with-glib2 \
+ --with-perl=no \
+ --with-glib-prefix=${STAGING_LIBDIR}/.. \
+ --with-glib-exec-prefix=${STAGING_LIBDIR}/.. \
+ --with-ncurses=${STAGING_LIBDIR}/.."
+
+do_configure () {
+ # create help files
+ echo "Creating help files..."
+ perl syntax.pl
+
+ files=`echo docs/help/in/*.in|sed -e 's,docs/help/in/Makefile.in ,,' -e 's,docs/help/in/,!,g' -e 's/\.in /.in ?/g'`
+ cat docs/help/in/Makefile.am.gen|sed "s/@HELPFILES@/$files/g"|sed 's/?/\\?/g'|tr '!?' '\t\n' > docs/help/in/Makefile.am
+
+ files=`echo $files|sed 's/\.in//g'`
+ cat docs/help/Makefile.am.gen|sed "s/@HELPFILES@/$files/g"|sed 's/?/\\?/g'|tr '!?' '\t\n' > docs/help/Makefile.am
+
+ # .html -> .txt with lynx
+ # echo "Documentation: html -> txt..."
+ # lynx -dump -nolist docs/faq.html|perl -pe 's/^ *//; if ($_ eq "\n" && $state eq "Q") { $_ = ""; } elsif (/^([QA]):/) { $state = $1 } elsif ($_ ne "\n") { $_ = " $_"; };' > docs/faq.txt
+
+ autotools_do_configure
+}
+
+do_stage () {
+ find . -name \*.h | for h in `cat`; do
+ install -d ${STAGING_LIBDIR}/../irssi/`dirname $h`
+ install -m 0644 $h ${STAGING_LIBDIR}/../irssi/$h
+ done
+ find . -name lib\*.a | for l in `cat`; do
+ install -d ${STAGING_LIBDIR}/../irssi/`dirname $l`
+ install -m 0644 $l ${STAGING_LIBDIR}/../irssi/$l
+ done
+ install -m 0644 irssi-config ${STAGING_LIBDIR}/../irssi/
+}
diff --git a/irssi/xirssi_cvs.oe b/irssi/xirssi_cvs.oe
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/irssi/xirssi_cvs.oe