summaryrefslogtreecommitdiff
path: root/e2tools/e2tools-native_0.0.16.bb
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-12-08 11:02:23 +0000
committerChris Larson <clarson@kergoth.com>2004-12-08 11:02:23 +0000
commit1016c9f974cb6cff0bb82291f3938ded9dcaaf42 (patch)
treeba736ff757051b7d6e275e2c746651ff480748e7 /e2tools/e2tools-native_0.0.16.bb
parent922acc09ac4c74272b0291a22fb1e466c1689270 (diff)
Updates per the core rename.
BKrev: 41b6df3f1WM7snr9msmSOLS9PzF8Sg
Diffstat (limited to 'e2tools/e2tools-native_0.0.16.bb')
-rw-r--r--e2tools/e2tools-native_0.0.16.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/e2tools/e2tools-native_0.0.16.bb b/e2tools/e2tools-native_0.0.16.bb
index e69de29bb2..95f4a0ae6f 100644
--- a/e2tools/e2tools-native_0.0.16.bb
+++ b/e2tools/e2tools-native_0.0.16.bb
@@ -0,0 +1,15 @@
+SECTION = "base"
+include e2tools_${PV}.bb
+inherit native
+
+DEPENDS = "e2fsprogs-libs-native e2fsprogs-native"
+FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/e2tools-${PV}', '${FILE_DIRNAME}/e2tools', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
+PACKAGES = ""
+
+e2links = "e2ln e2ls e2mkdir e2mv e2rm e2tail"
+do_stage () {
+ install -m 0755 e2cp ${STAGING_BINDIR}/
+ for i in ${e2links}; do
+ ln -sf e2cp ${STAGING_BINDIR}/$i
+ done
+}