summaryrefslogtreecommitdiff
path: root/contrib/site-conf/README
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2006-11-15 00:11:44 +0000
committerHolger Freyther <zecke@selfish.org>2006-11-15 00:11:44 +0000
commit5f4be6e3b31d552dc6d293adebf03415532592e9 (patch)
tree6751696a15d119417ef659f53815c0659c868253 /contrib/site-conf/README
parent942f721377d2a42a1f130d774858333d58ee7767 (diff)
site-conf: Include builtin.m4 through aclocal.m4 and execute the defined function
Document how to generate the configure script, document how to add a new package and do that for the builtin functions
Diffstat (limited to 'contrib/site-conf/README')
-rw-r--r--contrib/site-conf/README23
1 files changed, 23 insertions, 0 deletions
diff --git a/contrib/site-conf/README b/contrib/site-conf/README
index 08976970d7..b28e545288 100644
--- a/contrib/site-conf/README
+++ b/contrib/site-conf/README
@@ -4,4 +4,27 @@ Unified source of autoconf tests used to generate the site results
Executing this on a new platform will generate the necessary results
to write the right site-conf.
+1.) creating a configure script
+ '''use autoreconf -I m4'''
+
+
+2.) adding a test
+ '''vim m4/yourpackage.m4'''
+ '''add the functions'''
+ '''AC_DEFUN([OE_CHECK_YOURPACKAGE],
+ [
+ CALL_YOUR_FUNCTION_ONE_BY_ONE
+ ])
+ '''
+
+ Add to
+ '''vim aclocal.m4'''
+ '''m4_include(yourpackage,m4)'''
+
+ Add to
+ '''vim configure.ac'''
+ '''OE_CHECK_YOURPACKAGE
+
+
+
Copy and paste the autoconf test to an approriate file