summaryrefslogtreecommitdiff
path: root/classes/module.oeclass
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-12-07 22:05:47 +0000
committerChris Larson <clarson@kergoth.com>2004-12-07 22:05:47 +0000
commita780643c4b6aa11e1a36965a69df7116477c7b4c (patch)
tree17e81e77bde19931facf9b30fa5b5981df796071 /classes/module.oeclass
parent88cce8db7ebf88ab9da2366a2ac21a5a723340b8 (diff)
Merge oe-devel@oe-devel.bkbits.net:packages.bb
into handhelds.org:/home/kergoth/code/packages.bb 2004/12/07 04:58:25-06:00 ti.com!kergoth More updates per the core rename. 2004/12/07 04:46:51-06:00 ti.com!kergoth Update soundtracker per the core rename. 2004/12/07 04:44:14-06:00 ti.com!kergoth Merge 2004/12/07 04:42:38-06:00 ti.com!kergoth Updates per the recent rename of the oe core from 'oe' to 'bitbake'. BKrev: 41b6293b91LRHSxMOt6WnrZVAdLbFw
Diffstat (limited to 'classes/module.oeclass')
-rw-r--r--classes/module.oeclass22
1 files changed, 0 insertions, 22 deletions
diff --git a/classes/module.oeclass b/classes/module.oeclass
deleted file mode 100644
index 669e1f3d18..0000000000
--- a/classes/module.oeclass
+++ /dev/null
@@ -1,22 +0,0 @@
-RDEPENDS += "kernel (${KERNEL_VERSION})"
-DEPENDS += "virtual/kernel"
-
-inherit module-base
-
-module_do_compile() {
- unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
- oe_runmake KERNEL_PATH=${STAGING_KERNEL_DIR} \
- KERNEL_SRC=${STAGING_KERNEL_DIR} \
- KERNEL_VERSION=${KERNEL_VERSION} \
- CC="${KERNEL_CC}" LD="${KERNEL_LD}" \
- ${MAKE_TARGETS}
-}
-
-module_do_install() {
- unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
- oe_runmake DEPMOD=echo INSTALL_MOD_PATH="${D}" CC="${KERNEL_CC}" LD="${KERNEL_LD}" modules_install
-}
-
-EXPORT_FUNCTIONS do_compile do_install
-
-FILES_${PN} = "/etc /lib/modules"