summaryrefslogtreecommitdiff
path: root/classes/autotools.bbclass
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-11-10 11:06:55 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-11-10 11:06:55 +0100
commit45a8cde733e2a4b78cc431071d37f70e71ce34ef (patch)
tree985c371f65f9e42dab6ca55ad415556a761ff8c7 /classes/autotools.bbclass
parentdf42e934d34da0e6b0e9e8c9e6e2bd85bd2c2a23 (diff)
parentebf3936f96740e7c950a12e993d27de93de33a68 (diff)
Merge branch 'org.openembedded.dev' of git.openembedded.org:openembedded into org.openembedded.dev
Diffstat (limited to 'classes/autotools.bbclass')
-rw-r--r--classes/autotools.bbclass8
1 files changed, 3 insertions, 5 deletions
diff --git a/classes/autotools.bbclass b/classes/autotools.bbclass
index 8236a27c76..45b269f4fd 100644
--- a/classes/autotools.bbclass
+++ b/classes/autotools.bbclass
@@ -1,5 +1,3 @@
-inherit base
-
# use autotools_stage_all for native packages
AUTOTOOLS_NATIVE_STAGE_INSTALL = "1"
@@ -115,7 +113,7 @@ autotools_do_configure() {
else
CONFIGURE_AC=configure.ac
fi
- if grep "^AM_GLIB_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
+ if grep "^[[:space:]]*AM_GLIB_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
if grep "sed.*POTFILES" $CONFIGURE_AC >/dev/null; then
: do nothing -- we still have an old unmodified configure.ac
else
@@ -123,12 +121,12 @@ autotools_do_configure() {
echo "no" | glib-gettextize --force --copy
fi
fi
- if grep "^[AI][CT]_PROG_INTLTOOL" $CONFIGURE_AC >/dev/null; then
+ mkdir -p m4
+ if grep "^[[:space:]]*[AI][CT]_PROG_INTLTOOL" $CONFIGURE_AC >/dev/null; then
oenote Executing intltoolize --copy --force --automake
intltoolize --copy --force --automake
fi
oenote Executing autoreconf --verbose --install --force ${EXTRA_AUTORECONF} $acpaths
- mkdir -p m4
autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} $acpaths || oefatal "autoreconf execution failed."
cd $olddir
fi