summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-01-09 12:32:17 +0000
committerRod Whitby <rod@whitby.id.au>2007-01-09 12:32:17 +0000
commitfca0304f86c05d73e8586701963e36c69acb634e (patch)
tree13ee81330e8db80145570429415aedf15409c39e
parentd33d07ddf3ca35e4ee9a2a50e08d173a2f60de85 (diff)
parent76d74e58922ff6196faefb57b0b9264a738e26f5 (diff)
merge of '293e51d51d159e1203f6f75bb02b80e8adc041ab'
and '336c3826d3982a8a1f9b8569c023289204dd0092'
-rw-r--r--conf/distro/include/slugos.inc4
-rw-r--r--packages/apex/apex_1.4.11.bb53
-rw-r--r--packages/apex/nslu2/defconfig38
-rw-r--r--packages/linux/ixp4xx-kernel.inc3
-rw-r--r--packages/linux/ixp4xx-kernel_2.6.19+2.6.20-rc4.bb22
5 files changed, 109 insertions, 11 deletions
diff --git a/conf/distro/include/slugos.inc b/conf/distro/include/slugos.inc
index b255e85488..7ca663a4d6 100644
--- a/conf/distro/include/slugos.inc
+++ b/conf/distro/include/slugos.inc
@@ -36,7 +36,7 @@
#DISTRO_TYPE
# The following may be overridden to make sub-versions
-SLUGOS_VERSION = "4.1"
+SLUGOS_VERSION = "4.2"
DISTRO_REVISION ?= ""
DISTRO_VERSION ?= "${SLUGOS_VERSION}${DISTRO_REVISION}-${DISTRO_TYPE}"
# For release (only):
@@ -171,7 +171,7 @@ PREFERRED_VERSION_glibc ?= "2.3.5+cvs20050627"
# Select the correct versions of the kernel and modules (these are the
# defaults, override in the conf/distro top-level distro file).
PREFERRED_PROVIDER_virtual/kernel ?= "ixp4xx-kernel"
-PREFERRED_VERSION_ixp4xx-kernel ?= "2.6.19"
+PREFERRED_VERSION_ixp4xx-kernel ?= "2.6.19+2.6.20-rc4"
# Select the smallest provider of x11 libraries
PREFERRED_PROVIDER_virtual/libx11 ?= "diet-x11"
diff --git a/packages/apex/apex_1.4.11.bb b/packages/apex/apex_1.4.11.bb
new file mode 100644
index 0000000000..bb45a310b0
--- /dev/null
+++ b/packages/apex/apex_1.4.11.bb
@@ -0,0 +1,53 @@
+DESCRIPTION = "APEX Boot Loader"
+SECTION = ""
+PRIORITY = "optional"
+HOMEPAGE = "http://wiki.buici.com/twiki/bin/view/Main/ApexBootloader"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "ftp://ftp.buici.com/pub/apex/apex-${PV}.tar.gz \
+ file://defconfig"
+
+EXTRA_OEMAKE_append = " CROSS_COMPILE=${CROSS_DIR}/bin/${HOST_PREFIX}"
+
+oe_runmake() {
+ oenote make ${PARALLEL_MAKE} CROSS_COMPILE=${CROSS_DIR}/bin/${TARGET_PREFIX} "$@"
+ make ${PARALLEL_MAKE} LDFLAGS= CROSS_COMPILE=${CROSS_DIR}/bin/${TARGET_PREFIX} "$@" || die "oe_runmake failed"
+}
+
+# FIXME - make this the same as the distro kernel compilation
+CMDLINE="console=ttyS0,115200 rootfstype=jffs2 root=/dev/mtdblock4 rw init=/linuxrc noirqdebug"
+
+# Set the correct CONFIG_USER_xxx_ENDIAN and CONFIG_CMDLINE at the head
+# of the .config file and remove any settings in defconfig then append
+# defconfig to .config
+do_configure() {
+ rm -f ${S}/.config
+ if test '${ARCH_BYTE_SEX}' = be
+ then
+ sed -e 's/.*CONFIG_USER_BIGENDIAN.*/CONFIG_USER_BIGENDIAN=y/' \
+ -e 's/.*CONFIG_BIGENDIAN.*/CONFIG_BIGENDIAN=y/' \
+ -e 's|CONFIG_ENV_DEFAULT_CMDLINE=|CONFIG_ENV_DEFAULT_CMDLINE=\"${CMDLINE}\"|' \
+ ${WORKDIR}/defconfig > ${S}/.config
+ else
+ sed -e 's/.*CONFIG_USER_LITTLEENDIAN.*/CONFIG_USER_LITTLEENDIAN=y/' \
+ -e 's/.*CONFIG_LITTLEENDIAN.*/CONFIG_LITTLEENDIAN=y/' \
+ -e 's/.*CONFIG_ENV_REGION_KERNEL_SWAP.*/CONFIG_ENV_REGION_KERNEL_SWAP=y/' \
+ -e 's|CONFIG_ENV_DEFAULT_CMDLINE=|CONFIG_ENV_DEFAULT_CMDLINE=\"${CMDLINE}\"|' \
+ ${WORKDIR}/defconfig > ${S}/.config
+ fi
+ oe_runmake oldconfig
+}
+
+DEPENDS += "devio-native"
+
+do_populate_staging() {
+ install -d ${STAGING_LOADER_DIR}
+ # FIXME - arch-arm should not be hard-coded
+ if test '${ARCH_BYTE_SEX}' = be
+ then
+ cp src/arch-arm/rom/apex.bin ${STAGING_LOADER_DIR}/apex.bin
+ else
+ devio '<<'src/arch-arm/rom/apex.bin >${STAGING_LOADER_DIR}/apex.bin 'xp $,4'
+ fi
+}
diff --git a/packages/apex/nslu2/defconfig b/packages/apex/nslu2/defconfig
index 2d2784457a..ccec463e98 100644
--- a/packages/apex/nslu2/defconfig
+++ b/packages/apex/nslu2/defconfig
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
# Linux kernel version:
-# Fri Aug 18 09:47:40 2006
+# Tue Jan 9 22:31:18 2007
#
CONFIG_ARM=y
CONFIG_CPU_ARMV5=y
@@ -10,6 +10,7 @@ CONFIG_CPU_XSCALE=y
# CONFIG_ARCH_LH7A40X is not set
CONFIG_ARCH_IXP42X=y
# CONFIG_ARCH_S3C2410 is not set
+# CONFIG_ARCH_MX3 is not set
CONFIG_EXPERIMENTAL=y
# CONFIG_SMALL is not set
@@ -31,6 +32,7 @@ CONFIG_DISABLE_MMU_AT_BOOT=y
CONFIG_SDRAMBOOT_REPORT=y
CONFIG_STACK_SIZE=0x1000
CONFIG_STACKLIMIT=y
+# CONFIG_BOOTSTRAP_MEMTEST is not set
CONFIG_ATAG_PHYS=0x00000100
CONFIG_ARCH_NUMBER=597
CONFIG_APEX_VMA=0x00200000
@@ -45,6 +47,8 @@ CONFIG_NOR_BANK0_LENGTH=0x00800000
CONFIG_ENV_STARTUP=""
CONFIG_MACH="ixp42x"
CONFIG_MACH_NSLU2=y
+# CONFIG_MACH_NAS100D is not set
+# CONFIG_MACH_DSMG600 is not set
# CONFIG_MACH_AVILA2347 is not set
# CONFIG_USER_DEFAULTENDIAN is not set
# CONFIG_USER_BIGENDIAN is not set
@@ -73,7 +77,6 @@ CONFIG_CMD_COMPARE=y
CONFIG_CMD_DRVINFO=y
CONFIG_CMD_DUMP=y
CONFIG_CMD_ENV=y
-# CONFIG_CMD_ERASEENV is not set
CONFIG_CMD_SETENV=y
CONFIG_CMD_ERASE=y
CONFIG_CMD_FILL=y
@@ -94,32 +97,49 @@ CONFIG_DRIVER_FIS=y
CONFIG_DRIVER_FIS_BLOCKDEVICE="nor:0x7e0000+4k"
CONFIG_DRIVER_NOR_CFI=y
# CONFIG_DRIVER_NOR_CFI_NO_BUFFERED is not set
+# CONFIG_DRIVER_IXP4XX_NPE_ETH is not set
CONFIG_USES_NOR_CFI=y
CONFIG_USES_PATHNAME_PARSER=y
+CONFIG_USES_IXP4XX_NPE_ETH=y
#
# Environment
#
CONFIG_ENV=y
+CONFIG_ENV_MUTABLE=y
+CONFIG_ENV_LINK=y
+CONFIG_ENV_REGION="nor:0x7fc000+15k"
+CONFIG_ENV_CHECK_LEN=1024
+CONFIG_VARIATIONS=y
+CONFIG_VARIATION_SUFFIX="-alt"
# CONFIG_NO_BOOTSTRAP is not set
CONFIG_NOR_BOOT=y
# CONFIG_NAND_BOOT is not set
# CONFIG_COMPANION_EVT1_BOOT is not set
# CONFIG_COMPANION_EVT2_BOOT is not set
+
+#
+# Default Startup
+#
CONFIG_AUTOBOOT=y
CONFIG_AUTOBOOT_DELAY=10
-CONFIG_ENV_MUTABLE=y
-CONFIG_ENV_LINK=y
-CONFIG_ENV_REGION="nor:0x7fc000+15k"
-CONFIG_ENV_CHECK_LEN=1024
CONFIG_ENV_STARTUP_KERNEL_COPY=y
-CONFIG_ENV_REGION_KERNEL="fis://kernel"
# CONFIG_ENV_REGION_KERNEL_SWAP is not set
-# CONFIG_ENV_STARTUP_RAMDISK_COPY is not set
+
+#
+# Regions
+#
+CONFIG_ENV_REGION_KERNEL="fis://kernel"
+# CONFIG_ENV_REGION_KERNEL_ALT_P is not set
+
+#
+# Overrides
+#
CONFIG_ENV_DEFAULT_CMDLINE_OVERRIDE=y
CONFIG_ENV_DEFAULT_CMDLINE="console=ttyS0,115200 rootfstype=jffs2 root=/dev/mtdblock4 rw init=/linuxrc noirqdebug"
+# CONFIG_ENV_DEFAULT_CMDLINE_ALT_P is not set
# CONFIG_ENV_DEFAULT_STARTUP_OVERRIDE is not set
+# CONFIG_ENV_DEFAULT_STARTUP_ALT_P is not set
CONFIG_USES_NOR_BOOTFLASH=y
-# CONFIG_LITTLEENDIAN is not set
CONFIG_CLEAR_STACKS=y
CONFIG_ALIASES=y
diff --git a/packages/linux/ixp4xx-kernel.inc b/packages/linux/ixp4xx-kernel.inc
index a45a690955..099bfca2d3 100644
--- a/packages/linux/ixp4xx-kernel.inc
+++ b/packages/linux/ixp4xx-kernel.inc
@@ -72,6 +72,9 @@ python () {
# pre patches actually require the *preceding* kernel version the code
# fixes that up appropriately.
pv = bb.data.getVar("PV",d,1).split('-')
+ if pv[0].count('+'):
+ prev = pv[0].split('+')
+ pv[0] = prev[1];
kernel = pv[0].split('.')
base = pv[0]
name = [base]
diff --git a/packages/linux/ixp4xx-kernel_2.6.19+2.6.20-rc4.bb b/packages/linux/ixp4xx-kernel_2.6.19+2.6.20-rc4.bb
new file mode 100644
index 0000000000..d7d4de3b63
--- /dev/null
+++ b/packages/linux/ixp4xx-kernel_2.6.19+2.6.20-rc4.bb
@@ -0,0 +1,22 @@
+# Kernel for IXP4xx
+#
+# This bitbake file pulls patches and the defconfig straight
+# from the NSLU2-Linux SVN repository. Information about this
+# repository can be found at:
+# http://trac.nslu2-linux.org/kernel/
+#
+# The revision that is pulled from SVN is specified below
+IXP4XX_KERNEL_SVN_REV = "659"
+#
+# The directory containing the patches to be applied is
+# specified below
+IXP4XX_KERNEL_PATCH_DIR = "2.6.20"
+#
+# Increment the number below (i.e. the digits after PR) when
+# the changes in SVN between revisions include changes in the
+# patches applied to the kernel, rather than simply defconfig
+# changes
+PR = "r1.${IXP4XX_KERNEL_SVN_REV}"
+
+require ixp4xx-kernel.inc
+require ixp4xx-kernel-svnpatch.inc