summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2007-10-26 06:43:02 +0000
committerGraeme Gregory <dp@xora.org.uk>2007-10-26 06:43:02 +0000
commitf46070f9d10967b0c0424445cc44399291483f88 (patch)
tree23db08a0137bda238ea0543107b1e74d57715245
parent2cf54b5931aca6815573e7ce83e7f8073201d49e (diff)
gsm/libgsmd_svn.bb, gsm/libgsmd_svn.bb : split gsmd into two packages.
libgsm_svn is to follow OpenMoko svn and shouldi not have patches applied. libgsm-devel_svn is one to allow people to add patches in OE OpenMoko distro will use libgsm, anyone else is invited to use libgsm-devel and add the patches they need for testing.
-rw-r--r--packages/gsm/gsmd.inc98
-rw-r--r--packages/gsm/libgsmd-devel_svn.bb20
-rw-r--r--packages/gsm/libgsmd_svn.bb77
3 files changed, 121 insertions, 74 deletions
diff --git a/packages/gsm/gsmd.inc b/packages/gsm/gsmd.inc
new file mode 100644
index 0000000000..d84da91612
--- /dev/null
+++ b/packages/gsm/gsmd.inc
@@ -0,0 +1,98 @@
+DESCRIPTION = "GSM libraries and daemons implementing the 07.10 specification"
+HOMEPAGE = "http://www.openmoko.org"
+LICENSE = "GPL LGPL"
+SECTION = "libs/gsm"
+PROVIDES += "gsmd"
+PV = "0.1+svnr${SRCREV}"
+PR = "r32"
+
+SRC_URI = "svn://svn.openmoko.org/trunk/src/target;module=gsm;proto=http \
+ file://gsmd \
+ file://default"
+S = "${WORKDIR}/gsm"
+
+inherit autotools pkgconfig update-rc.d
+# handle update-rc.d RDEPENDS manually, we don't need it on
+# anything but gsmd
+RDEPENDS_append = ""
+
+INITSCRIPT_NAME = "gsmd"
+INITSCRIPT_PARAMS = "defaults 35"
+
+do_stage() {
+ autotools_stage_all
+}
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/gsmd ${D}/${sysconfdir}/init.d/
+ install -d ${D}/${sysconfdir}/default
+ install ${WORKDIR}/default ${D}/${sysconfdir}/default/gsmd
+}
+
+PACKAGES =+ "${PN}-tools ${BASEPN} \
+ ${BASEPN}-plugins \
+ ${BASEPN}-plugin-machine-generic \
+ ${BASEPN}-plugin-machine-tihtc \
+ ${BASEPN}-plugin-vendor-bcm \
+ ${BASEPN}-plugin-vendor-qc \
+ ${BASEPN}-plugin-vendor-ti \
+ ${BASEPN}-plugin-vendor-tihtc \
+ "
+
+RDEPENDS_${PN} = "${BASEPN}"
+RDEPENDS_${BASEPN}-plugins = "${BASEPN}-plugin-machine-generic \
+ ${BASEPN}-plugin-machine-tihtc \
+ ${BASEPN}-plugin-vendor-bcm \
+ ${BASEPN}-plugin-vendor-qc \
+ ${BASEPN}-plugin-vendor-ti \
+ ${BASEPN}-plugin-vendor-tihtc \
+ "
+
+RDEPENDS_${BASEPN} = "update-rc.d initscripts"
+RRECOMMENDS_${BASEPN} = "${BASEPN}-plugins"
+
+FILES_${PN}-dbg += "${libdir}/gsmd/.debug/*"
+FILES_${PN}-tools = "${bindir}/*"
+FILES_${BASEPN} = "${sbindir}/gsmd ${sysconfdir}"
+FILES_${BASEPN}-plugins = ""
+FILES_${BASEPN}-plugin-machine-generic = "${libdir}/gsmd/libgsmd-machine_generic.so*"
+FILES_${BASEPN}-plugin-machine-tihtc = "${libdir}/gsmd/libgsmd-machine_tihtc.so*"
+FILES_${BASEPN}-plugin-vendor-qc = "${libdir}/gsmd/libgsmd-vendor_qc.so*"
+FILES_${BASEPN}-plugin-vendor-bcm = "${libdir}/gsmd/libgsmd-vendor_bcm.so*"
+FILES_${BASEPN}-plugin-vendor-ti = "${libdir}/gsmd/libgsmd-vendor_ti.so*"
+FILES_${BASEPN}-plugin-vendor-tihtc = "${libdir}/gsmd/libgsmd-vendor_tihtc.so*"
+
+PACKAGES_DYNAMIC = "lib${BASEPN}* ${BASEPN}"
+
+ALLOW_EMPTY_${BASEPN}-plugins = "1"
+
+RCONFLICTS_lib${BASEPN} = "lib${CONFLICTNAME}"
+RCONFLICTS_${BASEPN} = "${CONFLICTNAME}"
+RCONFLICTS_${BASEPN}-plugins = "${CONFLICTNAME}-plugins"
+RCONFLICTS_${BASEPN}-plugin-machine-generic = "${CONFLICTNAME}-plugin-machine-generic"
+RCONFLICTS_${BASEPN}-plugin-machine-tihtc = "${CONFLICTNAME}-plugin-machine-tihtc"
+RCONFLICTS_${BASEPN}-plugin-vendor-qc = "${CONFLICTNAME}-plugin-vendor-qc"
+RCONFLICTS_${BASEPN}-plugin-vendor-bcm = "${CONFLICTNAME}-plugin-vendor-bcm"
+RCONFLICTS_${BASEPN}-plugin-vendor-ti = "${CONFLICTNAME}-plugin-vendor-ti"
+RCONFLICTS_${BASEPN}-plugin-vendor-tihtc = "${CONFLICTNAME}-plugin-vendor-tihtc"
+
+RREPLACES_lib${BASEPN} = "lib${CONFLICTNAME}"
+RREPLACES_${BASEPN} = "${CONFLICTNAME}"
+RREPLACES_${BASEPN}-plugins = "${CONFLICTNAME}-plugins"
+RREPLACES_${BASEPN}-plugin-machine-generic = "${CONFLICTNAME}-plugin-machine-generic"
+RREPLACES_${BASEPN}-plugin-machine-tihtc = "${CONFLICTNAME}-plugin-machine-tihtc"
+RREPLACES_${BASEPN}-plugin-vendor-qc = "${CONFLICTNAME}-plugin-vendor-qc"
+RREPLACES_${BASEPN}-plugin-vendor-bcm = "${CONFLICTNAME}-plugin-vendor-bcm"
+RREPLACES_${BASEPN}-plugin-vendor-ti = "${CONFLICTNAME}-plugin-vendor-ti"
+RREPLACES_${BASEPN}-plugin-vendor-tihtc = "${CONFLICTNAME}-plugin-vendor-tihtc"
+
+RPROVIDES_lib${BASEPN} = "lib${CONFLICTNAME}"
+RPROVIDES_${BASEPN} = "${CONFLICTNAME}"
+RPROVIDES_${BASEPN}-plugins = "${CONFLICTNAME}-plugins"
+RPROVIDES_${BASEPN}-plugin-machine-generic = "${CONFLICTNAME}-plugin-machine-generic"
+RPROVIDES_${BASEPN}-plugin-machine-tihtc = "${CONFLICTNAME}-plugin-machine-tihtc"
+RPROVIDES_${BASEPN}-plugin-vendor-qc = "${CONFLICTNAME}-plugin-vendor-qc"
+RPROVIDES_${BASEPN}-plugin-vendor-bcm = "${CONFLICTNAME}-plugin-vendor-bcm"
+RPROVIDES_${BASEPN}-plugin-vendor-ti = "${CONFLICTNAME}-plugin-vendor-ti"
+RPROVIDES_${BASEPN}-plugin-vendor-tihtc = "${CONFLICTNAME}-plugin-vendor-tihtc"
diff --git a/packages/gsm/libgsmd-devel_svn.bb b/packages/gsm/libgsmd-devel_svn.bb
new file mode 100644
index 0000000000..4216dfc48b
--- /dev/null
+++ b/packages/gsm/libgsmd-devel_svn.bb
@@ -0,0 +1,20 @@
+BASEPN = "gsmd-devel"
+CONFLICTNAME = "gsmd"
+
+require gsmd.inc
+
+PROVIDES += "libgsmd"
+
+SRC_URI += " file://024_sms-text-in-bracket.patch;patch=1;minrev=2957;maxrev=3199 \
+ file://025_sms-status-report.patch;patch=1;minrev=2957;maxrev=3200 \
+ file://027_phonebook-find-and-read-range-support.patch;patch=1;minrev=2957;maxrev=3202 \
+ file://028_shell-phonebook-find-and-read-range-support.patch;patch=1;minrev=2957;maxrev=3203 \
+ file://0001-Introduce-ports.patch;patch=1;minrev=2957 \
+ file://0002-Flush-all-pending-commands-before-restarting-the-mod.patch;patch=1;minrev=2957 \
+ file://0003-Correctly-segment-incoming-usock-data-into-packets.patch;patch=1;minrev=2957 \
+ file://0004-Handle-read-and-write-return-values.patch;patch=1;minrev=2957 \
+ file://0005-Add-ask-ds-option-forSMS.patch;patch=1;minrev=2957;maxrev=3201 \
+ file://lgsm_send_fix_return_value.patch;patch=1;maxrev=3266 \
+ file://gsmd \
+ file://default"
+
diff --git a/packages/gsm/libgsmd_svn.bb b/packages/gsm/libgsmd_svn.bb
index 13d5393738..9d3ca19c04 100644
--- a/packages/gsm/libgsmd_svn.bb
+++ b/packages/gsm/libgsmd_svn.bb
@@ -1,76 +1,5 @@
-DESCRIPTION = "GSM libraries and daemons implementing the 07.10 specification"
-HOMEPAGE = "http://www.openmoko.org"
-LICENSE = "GPL LGPL"
-SECTION = "libs/gsm"
-PROVIDES += "gsmd"
-PV = "0.1+svnr${SRCREV}"
-PR = "r31"
+BASEPN = "gsmd"
+CONFLICTNAME = "gsmd-devel"
-SRC_URI = "svn://svn.openmoko.org/trunk/src/target;module=gsm;proto=http \
- file://024_sms-text-in-bracket.patch;patch=1;minrev=2957;maxrev=3199 \
- file://025_sms-status-report.patch;patch=1;minrev=2957;maxrev=3200 \
- file://027_phonebook-find-and-read-range-support.patch;patch=1;minrev=2957;maxrev=3202 \
- file://028_shell-phonebook-find-and-read-range-support.patch;patch=1;minrev=2957;maxrev=3203 \
- file://0001-Introduce-ports.patch;patch=1;minrev=2957 \
- file://0002-Flush-all-pending-commands-before-restarting-the-mod.patch;patch=1;minrev=2957 \
- file://0003-Correctly-segment-incoming-usock-data-into-packets.patch;patch=1;minrev=2957 \
- file://0004-Handle-read-and-write-return-values.patch;patch=1;minrev=2957 \
- file://0005-Add-ask-ds-option-forSMS.patch;patch=1;minrev=2957;maxrev=3201 \
- file://lgsm_send_fix_return_value.patch;patch=1;maxrev=3266 \
- file://gsmd \
- file://default"
-S = "${WORKDIR}/gsm"
+require gsmd.inc
-inherit autotools pkgconfig update-rc.d
-# handle update-rc.d RDEPENDS manually, we don't need it on
-# anything but gsmd
-RDEPENDS_append = ""
-
-INITSCRIPT_NAME = "gsmd"
-INITSCRIPT_PARAMS = "defaults 35"
-
-do_stage() {
- autotools_stage_all
-}
-
-do_install_append() {
- install -d ${D}/${sysconfdir}/init.d
- install -m 0755 ${WORKDIR}/gsmd ${D}/${sysconfdir}/init.d/
- install -d ${D}/${sysconfdir}/default
- install ${WORKDIR}/default ${D}/${sysconfdir}/default/gsmd
-}
-
-PACKAGES =+ "${PN}-tools gsmd gsmd-plugins \
- gsmd-plugin-machine-generic gsmd-plugin-machine-tihtc \
- gsmd-plugin-vendor-bcm \
- gsmd-plugin-vendor-qc \
- gsmd-plugin-vendor-ti \
- gsmd-plugin-vendor-tihtc \
- "
-
-RDEPENDS_${PN} = "gsmd"
-RDEPENDS_gsmd-plugins = "gsmd-plugin-machine-generic \
- gsmd-plugin-machine-tihtc \
- gsmd-plugin-vendor-bcm \
- gsmd-plugin-vendor-qc \
- gsmd-plugin-vendor-ti \
- gsmd-plugin-vendor-tihtc \
- "
-
-RDEPENDS_gsmd = "update-rc.d initscripts"
-RRECOMMENDS_gsmd = "gsmd-plugins"
-
-FILES_${PN}-dbg += "${libdir}/gsmd/.debug/*"
-FILES_${PN}-tools = "${bindir}/*"
-FILES_gsmd = "${sbindir}/gsmd ${sysconfdir}"
-FILES_gsmd-plugins = ""
-FILES_gsmd-plugin-machine-generic = "${libdir}/gsmd/libgsmd-machine_generic.so*"
-FILES_gsmd-plugin-machine-tihtc = "${libdir}/gsmd/libgsmd-machine_tihtc.so*"
-FILES_gsmd-plugin-vendor-qc = "${libdir}/gsmd/libgsmd-vendor_qc.so*"
-FILES_gsmd-plugin-vendor-bcm = "${libdir}/gsmd/libgsmd-vendor_bcm.so*"
-FILES_gsmd-plugin-vendor-ti = "${libdir}/gsmd/libgsmd-vendor_ti.so*"
-FILES_gsmd-plugin-vendor-tihtc = "${libdir}/gsmd/libgsmd-vendor_tihtc.so*"
-
-PACKAGES_DYNAMIC = "libgsmd* gsmd"
-
-ALLOW_EMPTY_gsmd-plugins = "1"