summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2005-09-10 15:46:40 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-10 15:46:40 +0000
commitedb9e20aec763fc6d371ed2cd4b08dbf247a56e6 (patch)
treebd8bd51238e280249572c12f8be3d24a006bf5b4
parenta8333ac3fbf2d2890e329502ce0f3d027f6ef173 (diff)
Opietooth:
do not install the headers with generic names like parser.h in $STAGING_INCDIR but in a dedicated subdir packages/libopietooth/libopietooth: -create a common file (libopietooth1.inc) -install the headers in a subdirectory -adjust the 1.2.0 and cvs version to include the new file packages/opie-bluetoothmanager/opie-bluetoothmanager: -adjust to the new place for the header files packages/opie-bluetoothapplet/opie-bluetoothapplet: -adjust to the new place for the header files
-rw-r--r--packages/libopietooth/libopietooth1_1.2.0.bb21
-rw-r--r--packages/libopietooth/libopietooth1_cvs.bb21
-rw-r--r--packages/opie-bluetoothapplet/opie-bluetoothapplet.inc2
-rw-r--r--packages/opie-bluetoothmanager/opie-bluetoothmanager.inc2
4 files changed, 6 insertions, 40 deletions
diff --git a/packages/libopietooth/libopietooth1_1.2.0.bb b/packages/libopietooth/libopietooth1_1.2.0.bb
index 79cb6389b5..0dc91b2731 100644
--- a/packages/libopietooth/libopietooth1_1.2.0.bb
+++ b/packages/libopietooth/libopietooth1_1.2.0.bb
@@ -1,24 +1,5 @@
-DESCRIPTION = "Opie Bluetooth library"
-SECTION = "opie/libs"
-PRIORITY = "optional"
-DEPENDS = "libopie2"
-MAINTAINER = "Team Opie <opie@handhelds.org>"
-LICENSE = "LGPL"
-
-
SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/noncore/net/opietooth/lib"
-inherit opie
-
-
-S = "${WORKDIR}/lib"
+include libopietooth1.inc
-do_stage() {
- install -m 0644 *.h ${STAGING_INCDIR}/
- oe_libinstall -so libopietooth1 ${STAGING_LIBDIR}/
-}
-
-do_install() {
- oe_libinstall -so libopietooth1 ${D}${palmtopdir}/lib
-}
diff --git a/packages/libopietooth/libopietooth1_cvs.bb b/packages/libopietooth/libopietooth1_cvs.bb
index 2d167b9489..79244a69b4 100644
--- a/packages/libopietooth/libopietooth1_cvs.bb
+++ b/packages/libopietooth/libopietooth1_cvs.bb
@@ -1,23 +1,4 @@
-DESCRIPTION = "Opie Bluetooth library"
-SECTION = "opie/libs"
-PRIORITY = "optional"
-DEPENDS = "libopie2"
-MAINTAINER = "Team Opie <opie@handhelds.org>"
-LICENSE = "LGPL"
-
SRC_URI = "${HANDHELDS_CVS};module=opie/noncore/net/opietooth/lib"
PV = "1.2.0+cvs-${CVSDATE}"
-inherit opie
-
-S = "${WORKDIR}/lib"
-
-do_stage() {
- install -m 0644 *.h ${STAGING_INCDIR}/
- oe_libinstall -so libopietooth1 ${STAGING_LIBDIR}/
-}
-
-do_install() {
- oe_libinstall -so libopietooth1 ${D}${palmtopdir}/lib
-}
-
+include libopietooth1.inc
diff --git a/packages/opie-bluetoothapplet/opie-bluetoothapplet.inc b/packages/opie-bluetoothapplet/opie-bluetoothapplet.inc
index 9fc0723659..57930e40c0 100644
--- a/packages/opie-bluetoothapplet/opie-bluetoothapplet.inc
+++ b/packages/opie-bluetoothapplet/opie-bluetoothapplet.inc
@@ -8,6 +8,8 @@ APPNAME = "bluetoothapplet"
S = "${WORKDIR}/applet"
+EXTRA_QMAKEVARS_POST += " INCLUDEPATH+=${STAGING_INCDIR}/opietooth "
+
inherit opie
do_install() {
diff --git a/packages/opie-bluetoothmanager/opie-bluetoothmanager.inc b/packages/opie-bluetoothmanager/opie-bluetoothmanager.inc
index 8e7f003b0e..f5ebf88cb2 100644
--- a/packages/opie-bluetoothmanager/opie-bluetoothmanager.inc
+++ b/packages/opie-bluetoothmanager/opie-bluetoothmanager.inc
@@ -9,6 +9,8 @@ APPNAME = "bluetooth-manager"
S = "${WORKDIR}/manager"
+EXTRA_QMAKEVARS_POST += " INCLUDEPATH+=${STAGING_INCDIR}/opietooth "
+
inherit opie
# Files: plugins/application/libbluetooth-manager.so* bin/bluetooth-manager apps/Settings/bluetooth-manager.desktop pics/opietooth/*