summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@datenfreihafen.org>2008-12-07 02:30:46 +0100
committerStefan Schmidt <stefan@datenfreihafen.org>2008-12-07 02:30:46 +0100
commite533cf2ca6eb03eb641ca54553b8fbb3c8390ef1 (patch)
treeea058624838ec87785d103625aeea26400d4bac4
parent332c3ff017430b453bf6ff645d3568216a90bad0 (diff)
connman: Add the 0.1 "Nikolaus" release
* Factor out common bits from the git and the 0.1 recipe into .inc * Add checksum for the release tarball * DEFAULT_PREFERENCE = "-1" in the 0.1 recipe for now. Needs more testing and perhaps packaging tweaks
-rw-r--r--conf/checksums.ini4
-rw-r--r--packages/connman/connman.inc42
-rw-r--r--packages/connman/connman_0.1.bb11
-rw-r--r--packages/connman/connman_git.bb43
4 files changed, 59 insertions, 41 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index c84c638ddd..04a7990167 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -3086,6 +3086,10 @@ sha256=905ee280a38f479ab7da75e6dfba21f221b23bb068111ebddc4c2e853f3fff09
md5=4bc9b73d77ebd571ac834619ce0b3582
sha256=65451d8d6f5d4ca1dbd0700f3ef2ef257b52b542b3bab4bbeddd539f1c23f859
+[ftp://ftp.moblin.org/connman/releases/connman-0.1.tar.gz]
+md5=493aa462d01d7c5f0461d6d7f9f549b1
+sha256=1d56be1036de59926548e3defa4b9af894af9e2121d3598da13769da5c0f55b1
+
[http://www.conserver.com/conserver-8.1.14.tar.gz]
md5=f7825728e5af8992ed4a99fb560a3df8
sha256=48a9e2f8a02054bc6740ae354433bfa1636a6e726f2d62af22752d7a6103410b
diff --git a/packages/connman/connman.inc b/packages/connman/connman.inc
new file mode 100644
index 0000000000..cbc4010c32
--- /dev/null
+++ b/packages/connman/connman.inc
@@ -0,0 +1,42 @@
+HOMEPAGE = "http://www.moblin.org/projects/projects_connman.php"
+SUMMARY = "Moblin Connection Manager"
+LICENSE = "GPL"
+
+DEPENDS = "dbus glib-2.0"
+RDEPENDS = "dhcp-client wpa-supplicant resolvconf"
+
+EXTRA_OECONF += " \
+ ac_cv_path_WPASUPPLICANT=/usr/sbin/wpa_supplicant \
+ ac_cv_path_DHCLIENT=/sbin/dhclient "
+
+INITSCRIPT_NAME = "connman"
+INITSCRIPT_PARAMS = "defaults 22"
+
+inherit autotools pkgconfig update-rc.d
+
+do_install_append() {
+ install -m 0755 ${WORKDIR}/connman ${D}${sysconfdir}/init.d/connman
+}
+
+PACKAGES_DYNAMIC = "${PN}-plugin-*"
+PACKAGES += "${PN}-script-dhclient"
+FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*.so.* \
+ ${sysconfdir} ${sharedstatedir} ${localstatedir} \
+ ${base_bindir}/* ${base_sbindir}/* ${base_libdir}/*.so* ${datadir}/${PN} \
+ ${datadir}/pixmaps ${datadir}/applications \
+ ${datadir}/idl ${datadir}/omf ${datadir}/sounds \
+ ${libdir}/bonobo/servers \
+ ${datadir}/dbus-1/system-services/*"
+FILES_${PN}-script-dhclient += "${libdir}/connman/scripts/dhclient*"
+FILES_${PN}-dbg += "${libdir}/connman/plugins/.debug \
+ ${libdir}/connman/scripts/.debug"
+
+python populate_packages_prepend() {
+ plugin_dir = bb.data.expand('${libdir}/connman/plugins/', d)
+ plugin_name = bb.data.expand('${PN}-plugin-%s', d)
+ do_split_packages(d, plugin_dir, '^(.*).so$', plugin_name, '${PN} plugin for %s', extra_depends='' )
+}
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/packages/connman/connman_0.1.bb b/packages/connman/connman_0.1.bb
new file mode 100644
index 0000000000..8159b9410d
--- /dev/null
+++ b/packages/connman/connman_0.1.bb
@@ -0,0 +1,11 @@
+require connman.inc
+PR = "r0"
+
+DEFAULT_PREFERENCE = "-1"
+
+EXTRA_OECONF += " \
+ --disable-gtk-doc "
+
+SRC_URI = "ftp://ftp.moblin.org/connman/releases/connman-${PV}.tar.gz \
+ file://connman "
+
diff --git a/packages/connman/connman_git.bb b/packages/connman/connman_git.bb
index bc5840fb4c..f22125e16e 100644
--- a/packages/connman/connman_git.bb
+++ b/packages/connman/connman_git.bb
@@ -1,50 +1,11 @@
-HOMEPAGE = "http://www.moblin.org/projects/projects_connman.php"
-SUMMARY = "Moblin Connection Manager"
+require connman.inc
PV = "0.0+gitr${SRCREV}"
PR = "r4.02"
PE = "1"
S = "${WORKDIR}/git"
-LICENSE = "GPL"
-DEPENDS = "libgdbus dbus glib-2.0 hal"
-RDEPENDS = "dhcp-client wpa-supplicant resolvconf"
-
-EXTRA_OECONF += " \
- ac_cv_path_WPASUPPLICANT=/usr/sbin/wpa_supplicant \
- ac_cv_path_DHCLIENT=/sbin/dhclient "
+DEPENDS += "libgdbus hal"
SRC_URI = "git://git.moblin.org/repos/projects/connman.git;protocol=http \
file://use_nm_in_cross_compiling.patch;patch=1\
file://connman "
-
-INITSCRIPT_NAME = "connman"
-INITSCRIPT_PARAMS = "defaults 22"
-
-inherit autotools pkgconfig update-rc.d
-
-do_install_append() {
- install -m 0755 ${WORKDIR}/connman ${D}${sysconfdir}/init.d/connman
-}
-
-PACKAGES_DYNAMIC = "${PN}-plugin-*"
-PACKAGES += "${PN}-script-dhclient"
-FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*.so.* \
- ${sysconfdir} ${sharedstatedir} ${localstatedir} \
- ${base_bindir}/* ${base_sbindir}/* ${base_libdir}/*.so* ${datadir}/${PN} \
- ${datadir}/pixmaps ${datadir}/applications \
- ${datadir}/idl ${datadir}/omf ${datadir}/sounds \
- ${libdir}/bonobo/servers \
- ${datadir}/dbus-1/system-services/*"
-FILES_${PN}-script-dhclient += "${libdir}/connman/scripts/dhclient*"
-FILES_${PN}-dbg += "${libdir}/connman/plugins/.debug \
- ${libdir}/connman/scripts/.debug"
-
-python populate_packages_prepend() {
- plugin_dir = bb.data.expand('${libdir}/connman/plugins/', d)
- plugin_name = bb.data.expand('${PN}-plugin-%s', d)
- do_split_packages(d, plugin_dir, '^(.*).so$', plugin_name, '${PN} plugin for %s', extra_depends='' )
-}
-
-do_stage() {
- autotools_stage_all
-}