summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-10-24 08:01:26 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-10-24 08:01:26 +0000
commitd9ec5a373d6cc93e9382214ff0d047feb223b45f (patch)
treed0b9bd5ea885aa5c395d0f20516f5fe703141fc8
parente9a68b128341bc55fdab42bea281b08726a38453 (diff)
nslu2-kernel: fix redboot.c compiler warning messages in 2.6.14(all)
-rw-r--r--packages/linux/nslu2-kernel/2.6.14/10-mtdpart-redboot-fis-byteswap.patch28
-rw-r--r--packages/linux/nslu2-kernel_2.6.14-rc5.bb2
2 files changed, 13 insertions, 17 deletions
diff --git a/packages/linux/nslu2-kernel/2.6.14/10-mtdpart-redboot-fis-byteswap.patch b/packages/linux/nslu2-kernel/2.6.14/10-mtdpart-redboot-fis-byteswap.patch
index c5e322ccac..bf115fd716 100644
--- a/packages/linux/nslu2-kernel/2.6.14/10-mtdpart-redboot-fis-byteswap.patch
+++ b/packages/linux/nslu2-kernel/2.6.14/10-mtdpart-redboot-fis-byteswap.patch
@@ -1,12 +1,6 @@
-On IXP4XX systems the FIS directory is big endian even with a little
-endian kernel. This patch recognises the FIS directory on such a
-system and byte swaps it to obtain a valid table based on the 'size'
-field of the FIS directory (the size field is know to always match the
-erase block size on such systems, and probably all systems.)
-
---- linux-2.6.13/drivers/mtd/redboot.c.orig 2005-10-19 17:14:19.304956677 -0700
-+++ linux-2.6.13/drivers/mtd/redboot.c 2005-10-19 17:48:16.457146582 -0700
-@@ -89,8 +89,32 @@
+--- linux-2.6.13/.pc/10-mtdpart-redboot-fis-byteswap.patch/drivers/mtd/redboot.c 2005-08-28 16:41:01.000000000 -0700
++++ linux-2.6.13/drivers/mtd/redboot.c 2005-10-23 21:44:59.999694674 -0700
+@@ -89,8 +89,34 @@
i = numslots;
break;
}
@@ -26,13 +20,15 @@ erase block size on such systems, and probably all systems.)
+ /* The unsigned long fields were written with the
+ * wrong byte sex, name and pad have no byte sex.
+ */
-+ swab32s(&buf[j].flash_base);
-+ swab32s(&buf[j].mem_base);
-+ swab32s(&buf[j].size);
-+ swab32s(&buf[j].entry_point);
-+ swab32s(&buf[j].data_length);
-+ swab32s(&buf[j].desc_cksum);
-+ swab32s(&buf[j].file_cksum);
++# define do_swab32(x) (x) = swab32(x)
++ do_swab32(buf[j].flash_base);
++ do_swab32(buf[j].mem_base);
++ do_swab32(buf[j].size);
++ do_swab32(buf[j].entry_point);
++ do_swab32(buf[j].data_length);
++ do_swab32(buf[j].desc_cksum);
++ do_swab32(buf[j].file_cksum);
++# undef do_swab32
+ }
+ }
break;
diff --git a/packages/linux/nslu2-kernel_2.6.14-rc5.bb b/packages/linux/nslu2-kernel_2.6.14-rc5.bb
index 6bb04a1010..848650da28 100644
--- a/packages/linux/nslu2-kernel_2.6.14-rc5.bb
+++ b/packages/linux/nslu2-kernel_2.6.14-rc5.bb
@@ -8,7 +8,7 @@ PR_CONFIG = "1"
# Increment the number below (i.e. the digits after PR) when
# making changes within this file or for changes to the patches
# applied to the kernel.
-PR = "r0.${PR_CONFIG}"
+PR = "r1.${PR_CONFIG}"
include nslu2-kernel.inc