summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-04-11 12:32:45 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-11 12:32:45 +0000
commitd25409164d0ce017b9703c9c1e60a0587f4f5f2f (patch)
tree7ad63904bd065addb4ca76f70f979d4e494ed67d
parentbde705e9d300d987bdaed6f94e534182ec6201f5 (diff)
parent530227dfcd82122db8963f9014b906122fa6f62d (diff)
merge of b9308de4d2d1072e26d134bd4eada0efa17993f6
and efd8840244d74e5cab246e93e24993c96eeb9db8
-rw-r--r--packages/qt/qt4-x11-free_4.1.1.bb6
-rw-r--r--packages/texmaker/.mtn2git_empty0
-rw-r--r--packages/texmaker/texmaker_1.3.bb16
3 files changed, 21 insertions, 1 deletions
diff --git a/packages/qt/qt4-x11-free_4.1.1.bb b/packages/qt/qt4-x11-free_4.1.1.bb
index 15a87bdf94..6c32026f38 100644
--- a/packages/qt/qt4-x11-free_4.1.1.bb
+++ b/packages/qt/qt4-x11-free_4.1.1.bb
@@ -6,7 +6,7 @@ LICENSE = "GPL QPL"
MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
DEPENDS = "uicmoc4-native qmake2-native freetype jpeg libx11 xft libxext libxrender libxrandr libxcursor"
PROVIDES = "qt4x11"
-PR = "r1"
+PR = "r2"
SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-x11-opensource-src-${PV}.tar.gz \
file://cross-compile.patch;patch=1 \
@@ -69,6 +69,10 @@ PARTS = "3Support Core Designer DesignerComponents Gui Network Sql Svg Test Xml"
do_stage() {
oe_runmake install INSTALL_ROOT=/
+ install -m 0755 ${STAGING_BINDIR}/rcc4 ${STAGING_QT_DIR}/bin/rcc
+ install -m 0755 ${STAGING_BINDIR}/moc4 ${STAGING_QT_DIR}/bin/moc
+ install -m 0755 ${STAGING_BINDIR}/uic4 ${STAGING_QT_DIR}/bin/uic
+
}
# FIXME: Might want to call oe_runmake install INSTALL_ROOT=${D}/${prefix} as well...
diff --git a/packages/texmaker/.mtn2git_empty b/packages/texmaker/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/texmaker/.mtn2git_empty
diff --git a/packages/texmaker/texmaker_1.3.bb b/packages/texmaker/texmaker_1.3.bb
new file mode 100644
index 0000000000..0ca09032cb
--- /dev/null
+++ b/packages/texmaker/texmaker_1.3.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "TeXmaker is a free cross-platform LaTeX editor"
+HOMEPAGE = "http://www.xm1math.net/texmaker"
+SECTION = "x11/apps"
+LICENSE = "GPL"
+DEPENDS = "qt4x11"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+
+SRC_URI = "http://www.xm1math.net/texmaker/texmaker-${PV}.tar.bz2"
+
+inherit qmake qt4x11
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 texmaker ${D}${bindir}/texmaker
+}
+