summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2007-08-13 13:18:19 +0000
committerGraeme Gregory <dp@xora.org.uk>2007-08-13 13:18:19 +0000
commitc7c81cd5132693b4541572ae5080b1912560c9a0 (patch)
tree1fb3eb445d6149a207f206f118f4af8fff9e13b0
parent4630c0bfa9fc5d99b94bfed19f647fcb546ecea3 (diff)
parentb534530b8cc4e34ca4301458bc0e5eeb64efbe08 (diff)
merge of '188bf8cfee8efc3cb5e4670c99fcdb1dc6534bb2'
and '83c27aa0850cb7750b6c99b01d999e085f33ddcc'
-rw-r--r--classes/seppuku.bbclass4
-rw-r--r--packages/gsm/libgsmd_svn.bb2
-rw-r--r--packages/hal/ohm_git.bb16
3 files changed, 19 insertions, 3 deletions
diff --git a/classes/seppuku.bbclass b/classes/seppuku.bbclass
index 7ae1458b89..7e4b2098be 100644
--- a/classes/seppuku.bbclass
+++ b/classes/seppuku.bbclass
@@ -129,7 +129,7 @@ def seppuku_find_bug_report(debug_file, opener, query, product, component, bugna
component = urllib.quote(component)
bugname = urllib.quote(bugname)
- result = opener.open("%(query)s?product=%(product)s&component=%(component)s&short_desc_type=substring&short_desc=%(bugname)s" % vars())
+ result = opener.open("%(query)sproduct=%(product)s&component=%(component)s&short_desc_type=substring&short_desc=%(bugname)s" % vars())
if result.code != 200:
raise "Can not query the bugzilla at all"
txt = result.read()
@@ -137,7 +137,7 @@ def seppuku_find_bug_report(debug_file, opener, query, product, component, bugna
scanner.feed(txt)
if len(scanner.result()) == 0:
print >> debug_file, "Scanner failed to scan the html site"
- print >> debug_file, "%(query)s?product=%(product)s&component=%(component)s&short_desc_type=substring&short_desc=%(bugname)s" % vars()
+ print >> debug_file, "%(query)sproduct=%(product)s&component=%(component)s&short_desc_type=substring&short_desc=%(bugname)s" % vars()
print >> debug_file, txt
return (False,None)
else: # silently pick the first result
diff --git a/packages/gsm/libgsmd_svn.bb b/packages/gsm/libgsmd_svn.bb
index fbdbfe1e45..10c8c01ad0 100644
--- a/packages/gsm/libgsmd_svn.bb
+++ b/packages/gsm/libgsmd_svn.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.openmoko.org"
LICENSE = "GPL LGPL"
SECTION = "libs/gsm"
PROVIDES += "gsmd"
-PV = "0.1+svnr${SRCREV}"
+PV = "0.1+svn${SRCDATE}"
PR = "r18"
SRC_URI_OVERRIDES_PACKAGE_ARCH = "1"
diff --git a/packages/hal/ohm_git.bb b/packages/hal/ohm_git.bb
new file mode 100644
index 0000000000..4ef1a6dfa9
--- /dev/null
+++ b/packages/hal/ohm_git.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Open Hardware Manager"
+HOMEPAGE = "http://freedesktop.org/Software/ohm"
+LICENSE = "LGPL"
+
+DEPENDS = "dbus-glib intltool-native hal"
+RDEPENDS += "udev hal-info"
+SRC_URI = "git://anongit.freedesktop.org/git/ohm/;protocol=git"
+
+PV = "0.0+git${SRCDATE}"
+PR = "r1"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--with-distro=debian"