summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-12-10 19:01:11 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-12-10 19:01:11 +0000
commitbcea7c7f723f9b558e4a6bbef556b3c9ceb5aedf (patch)
tree08937807506c332b110aa6be651ff527f0e7ffb9
parent2aa1085279b9545d87606a10964a4280c2d32e96 (diff)
bootshim: add 0.2
-rw-r--r--packages/bootshim/.mtn2git_empty0
-rw-r--r--packages/bootshim/bootShim_0.2.bb28
2 files changed, 28 insertions, 0 deletions
diff --git a/packages/bootshim/.mtn2git_empty b/packages/bootshim/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/bootshim/.mtn2git_empty
diff --git a/packages/bootshim/bootShim_0.2.bb b/packages/bootshim/bootShim_0.2.bb
new file mode 100644
index 0000000000..96bd6e1657
--- /dev/null
+++ b/packages/bootshim/bootShim_0.2.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Bootshim for Greatwall bootloaders"
+MAINTAINER = "Koen Kooi <koen@handhelds.org>"
+
+DEPENDS = "sed-native LAB-kernel"
+#requires perl on the host system, will fix that later
+
+SRC_URI = "http://handhelds.org/~mreimer/${P}.tgz"
+
+do_configure() {
+cp ${DEPLOY_DIR}/images/LAB-image-${MACHINE} ${S}/zImage
+sed -i /^CROSS/d Makefile
+}
+
+do_compile() {
+oe_runmake CROSS=${CROSS_DIR}/bin/${TARGET_ARCH}-${TARGET_OS}-
+}
+
+
+do_deploy() {
+ install -d ${DEPLOY_DIR}/images
+ install -m 0644 htc_bootshim.bin ${DEPLOY_DIR}/images/LAB-image-${MACHINE}.shimmed
+}
+
+do_deploy[dirs] = "${S}"
+
+addtask deploy before do_build after do_compile
+
+