summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-03-20 15:42:12 +0100
committerKoen Kooi <koen@openembedded.org>2009-03-20 15:42:12 +0100
commitba0746e14d2f6eb5ffce1c29fb9832f780d80e53 (patch)
tree99704545a074132a576a848186e70fe29b435c47
parent5cc2f409298c7994f3c70f3e11530ba2099ad96b (diff)
parent2fbac192f15a4d3dc91ff3a7c4d5db17f55522f8 (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
-rw-r--r--recipes/beecrypt/beecrypt_3.1.0.bb2
-rw-r--r--recipes/beecrypt/files/x64fix.patch48
-rw-r--r--recipes/rpm/files/rpmconfigdir.patch27
-rw-r--r--recipes/rpm/rpm-native_4.4.2.3.bb2
-rw-r--r--recipes/rpm/rpm_4.4.2.3.bb3
-rw-r--r--recipes/yum/files/paths2.patch4
6 files changed, 74 insertions, 12 deletions
diff --git a/recipes/beecrypt/beecrypt_3.1.0.bb b/recipes/beecrypt/beecrypt_3.1.0.bb
index 720d99a416..8de6232fc5 100644
--- a/recipes/beecrypt/beecrypt_3.1.0.bb
+++ b/recipes/beecrypt/beecrypt_3.1.0.bb
@@ -7,7 +7,7 @@ HOMEPAGE="http://sourceforge.net/projects/beecrypt"
SRC_URI="${SOURCEFORGE_MIRROR}/beecrypt/beecrypt-${PV}.tar.gz \
file://x64fix.patch;patch=1"
-PR = "r3"
+PR = "r4"
inherit autotools
acpaths=""
diff --git a/recipes/beecrypt/files/x64fix.patch b/recipes/beecrypt/files/x64fix.patch
index 9ee75c1404..b8b50766fd 100644
--- a/recipes/beecrypt/files/x64fix.patch
+++ b/recipes/beecrypt/files/x64fix.patch
@@ -1,11 +1,13 @@
Index: beecrypt-3.1.0/configure.ac
===================================================================
---- beecrypt-3.1.0.orig/configure.ac 2008-08-16 12:08:02.000000000 +0100
-+++ beecrypt-3.1.0/configure.ac 2008-08-16 12:08:26.000000000 +0100
-@@ -754,15 +754,6 @@
+--- beecrypt-3.1.0.orig/configure.ac 2003-08-17 06:46:57.000000000 +0000
++++ beecrypt-3.1.0/configure.ac 2009-03-20 14:36:59.000000000 +0000
+@@ -752,19 +752,6 @@
- # Check where to install the libraries
- bc_libalt=
+ AC_SUBST([MAYBE_OPT])
+
+-# Check where to install the libraries
+-bc_libalt=
-case $target_os in
-linux*)
- case $bc_target_arch in
@@ -15,6 +17,38 @@ Index: beecrypt-3.1.0/configure.ac
- esac
- ;;
-esac
- AC_SUBST(LIBALT,$bc_libalt)
-
+-AC_SUBST(LIBALT,$bc_libalt)
+-
# Generate output files.
+ AC_CONFIG_FILES([Makefile
+ Doxyfile
+Index: beecrypt-3.1.0/Makefile.am
+===================================================================
+--- beecrypt-3.1.0.orig/Makefile.am 2003-08-17 06:46:57.000000000 +0000
++++ beecrypt-3.1.0/Makefile.am 2009-03-20 14:36:59.000000000 +0000
+@@ -43,9 +43,7 @@
+
+ BEECRYPT_OBJECTS = aes.lo aesopt.lo base64.lo beecrypt.lo blockmode.lo blockpad.lo blowfish.lo blowfishopt.lo dhaes.lo dldp.lo dlkp.lo dlpk.lo dlsvdp-dh.lo dsa.lo elgamal.lo endianness.lo entropy.lo fips186.lo hmac.lo hmacmd5.lo hmacsha1.lo hmacsha256.lo md5.lo memchunk.lo mp.lo mpopt.lo mpbarrett.lo mpnumber.lo mpprime.lo mtprng.lo rsa.lo rsakp.lo rsapk.lo sha1.lo sha1opt.lo sha256.lo timestamp.lo
+
+-libaltdir=$(prefix)/lib@LIBALT@
+-
+-libalt_LTLIBRARIES = libbeecrypt.la
++lib_LTLIBRARIES = libbeecrypt.la
+
+ libbeecrypt_la_SOURCES = aes.c base64.c beecrypt.c blockmode.c blockpad.c blowfish.c dhaes.c dldp.c dlkp.c dlpk.c dlsvdp-dh.c dsa.c elgamal.c endianness.c entropy.c fips186.c hmac.c hmacmd5.c hmacsha1.c hmacsha256.c md5.c memchunk.c mp.c mpbarrett.c mpnumber.c mpprime.c mtprng.c rsa.c rsakp.c rsapk.c sha1.c sha256.c timestamp.c
+
+Index: beecrypt-3.1.0/java/Makefile.am
+===================================================================
+--- beecrypt-3.1.0.orig/java/Makefile.am 2003-06-25 19:25:41.000000000 +0000
++++ beecrypt-3.1.0/java/Makefile.am 2009-03-20 14:37:19.000000000 +0000
+@@ -26,9 +26,7 @@
+
+ BEECRYPT_JAVA_OBJECTS = javaglue.lo
+
+-libaltdir=$(prefix)/lib@LIBALT@
+-
+-libalt_LTLIBRARIES = libbeecrypt_java.la
++lib_LTLIBRARIES = libbeecrypt_java.la
+
+ noinst_HEADERS = javaglue.h
+
diff --git a/recipes/rpm/files/rpmconfigdir.patch b/recipes/rpm/files/rpmconfigdir.patch
new file mode 100644
index 0000000000..24f884c9f0
--- /dev/null
+++ b/recipes/rpm/files/rpmconfigdir.patch
@@ -0,0 +1,27 @@
+Index: rpm-4.4.2.3/Makefile.am
+===================================================================
+--- rpm-4.4.2.3.orig/Makefile.am 2009-03-18 17:12:48.000000000 +0000
++++ rpm-4.4.2.3/Makefile.am 2009-03-18 17:32:34.000000000 +0000
+@@ -122,14 +122,14 @@
+
+ install-data-local:
+ @$(mkinstalldirs) $(DESTDIR)$(varprefix)/lib/rpm
+- @rm -f $(DESTDIR)$(libdir)/rpm/rpmt
+- @@LN_S@ rpmb $(DESTDIR)$(libdir)/rpm/rpmt
+- @rm -f $(DESTDIR)$(libdir)/rpm/rpme
+- @@LN_S@ rpmi $(DESTDIR)$(libdir)/rpm/rpme
+- @rm -f $(DESTDIR)$(libdir)/rpm/rpmu
+- @@LN_S@ rpmi $(DESTDIR)$(libdir)/rpm/rpmu
+- @rm -f $(DESTDIR)$(libdir)/rpm/rpmv
+- @@LN_S@ rpmq $(DESTDIR)$(libdir)/rpm/rpmv
++ @rm -f $(DESTDIR)@RPMCONFIGDIR@/rpmt
++ @@LN_S@ rpmb $(DESTDIR)@RPMCONFIGDIR@/rpmt
++ @rm -f $(DESTDIR)@RPMCONFIGDIR@/rpme
++ @@LN_S@ rpmi $(DESTDIR)@RPMCONFIGDIR@/rpme
++ @rm -f $(DESTDIR)@RPMCONFIGDIR@/rpmu
++ @@LN_S@ rpmi $(DESTDIR)@RPMCONFIGDIR@/rpmu
++ @rm -f $(DESTDIR)@RPMCONFIGDIR@/rpmv
++ @@LN_S@ rpmq $(DESTDIR)@RPMCONFIGDIR@/rpmv
+ rm -f $(DESTDIR)$(bindir)/rpmbuild
+ @LN_S@ ../lib/rpm/rpmb $(DESTDIR)$(bindir)/rpmbuild
+ rm -f $(DESTDIR)$(bindir)/rpmquery
diff --git a/recipes/rpm/rpm-native_4.4.2.3.bb b/recipes/rpm/rpm-native_4.4.2.3.bb
index 5ed737e366..935d07723f 100644
--- a/recipes/rpm/rpm-native_4.4.2.3.bb
+++ b/recipes/rpm/rpm-native_4.4.2.3.bb
@@ -1,7 +1,7 @@
require rpm_${PV}.bb
inherit native
-DEPENDS = "beecrypt-native zlib-native file-native popt-native python-native"
+DEPENDS = "beecrypt-native gettext-native zlib-native file-native popt-native python-native"
export localstatedir = "${layout_localstatedir}"
export varprefix = "${layout_localstatedir}"
diff --git a/recipes/rpm/rpm_4.4.2.3.bb b/recipes/rpm/rpm_4.4.2.3.bb
index 6c2dc55e69..db88282f33 100644
--- a/recipes/rpm/rpm_4.4.2.3.bb
+++ b/recipes/rpm/rpm_4.4.2.3.bb
@@ -7,6 +7,7 @@ PR = "r13"
SRC_URI = "http://www.rpm.org/releases/rpm-4.4.x/rpm-4.4.2.3.tar.gz \
file://external-tools.patch;patch=1 \
file://cross_libpaths.patch;patch=1 \
+ file://rpmconfigdir.patch;patch=1 \
file://weakdeps.patch;patch=1;pnum=0 \
file://tagsbackport.patch;patch=1;pnum=0 \
file://missingok.patch;patch=1;pnum=0 \
@@ -30,7 +31,7 @@ EXTRA_OECONF = "--with-python \
--without-efence"
PACKAGES += "python-rpm"
-FILES_python-rpm = "${libdir}/python*/site-recipes/rpm/_*"
+FILES_python-rpm = "${libdir}/python*/site-packages/rpm/_*"
# Handle the db MUTEX settings here, the POSIX library is
# the default - "POSIX/pthreads/library".
diff --git a/recipes/yum/files/paths2.patch b/recipes/yum/files/paths2.patch
index db614dfbbd..2e11bdc71e 100644
--- a/recipes/yum/files/paths2.patch
+++ b/recipes/yum/files/paths2.patch
@@ -13,7 +13,7 @@
-PYSYSDIR := $(shell $(PYTHON) -c 'import sys; print sys.prefix')
+PYSYSDIR = $(prefix)
PYLIBDIR = $(PYSYSDIR)/lib/python$(PYVER)
- PKGDIR = $(PYLIBDIR)/site-recipes/$(PACKAGE)
+ PKGDIR = $(PYLIBDIR)/site-packages/$(PACKAGE)
all:
echo "Nothing to do"
@@ -27,7 +27,7 @@
-PYSYSDIR := $(shell $(PYTHON) -c 'import sys; print sys.prefix')
+PYSYSDIR = $(prefix)
PYLIBDIR = $(PYSYSDIR)/lib/python$(PYVER)
- PKGDIR = $(PYLIBDIR)/site-recipes/$(PACKAGE)
+ PKGDIR = $(PYLIBDIR)/site-packages/$(PACKAGE)
all:
echo "Nothing to do"