summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2005-07-02 08:32:03 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-02 08:32:03 +0000
commitb87b907d9a14d0badd6c8d65b945306b66c5e4a1 (patch)
tree8db56e7a3f56cac31139ff65e76ebfd4cc270848
parent51876931408c994bff03fb088c80bd170da9774a (diff)
parenta28a4ef535221081707137c3922380fe9c642e31 (diff)
merge of c351a21c44ec49f4848614ef97f23d6d69f93a15
and db6c2c937cf31ea87f4a78972b6063d545212c44
-rw-r--r--packages/linux/nslu2-kernel.inc5
-rw-r--r--packages/linux/nslu2-kernel/2.6.12/defconfig2
-rw-r--r--packages/linux/nslu2-kernel_2.6.12.2.bb23
3 files changed, 28 insertions, 2 deletions
diff --git a/packages/linux/nslu2-kernel.inc b/packages/linux/nslu2-kernel.inc
index f5b035a6e5..e3dfa1814c 100644
--- a/packages/linux/nslu2-kernel.inc
+++ b/packages/linux/nslu2-kernel.inc
@@ -104,9 +104,10 @@ python () {
base = pv[0]
name = [base]
major = '.'.join(name[0].split('.')[0:2])
+ minor = '.'.join(name[0].split('.')[0:3])
patch_uri = [ None ]
filedir = "${FILE_DIRNAME}/nslu2-kernel/%s"
- # This entry will become the last one (everything is insertd before it)
+ # This entry will become the last one (everything is inserted before it)
filepath = [ filedir % "files" ]
pref = 10
mmac = 0
@@ -141,6 +142,8 @@ python () {
base = '.'.join(kernel)
patch_uri[0] = "ftp://ftp.kernel.org/pub/linux/kernel/v%s/linux-%s.tar.bz2" % (major, base)
filepath[-1:-1] = [ filedir % base ]
+ if base != minor:
+ filepath[-1:-1] = [ filedir % minor ]
filepath[-1:-1] = [ filedir % major ]
bb.data.setVar("N2K_SRCMAJ", major, d)
diff --git a/packages/linux/nslu2-kernel/2.6.12/defconfig b/packages/linux/nslu2-kernel/2.6.12/defconfig
index 37a3ffc411..5985a29ee3 100644
--- a/packages/linux/nslu2-kernel/2.6.12/defconfig
+++ b/packages/linux/nslu2-kernel/2.6.12/defconfig
@@ -495,7 +495,7 @@ CONFIG_NETDEVICES=y
# CONFIG_DUMMY is not set
# CONFIG_BONDING is not set
# CONFIG_EQUALIZER is not set
-# CONFIG_TUN is not set
+CONFIG_TUN=m
#
# ARCnet devices
diff --git a/packages/linux/nslu2-kernel_2.6.12.2.bb b/packages/linux/nslu2-kernel_2.6.12.2.bb
new file mode 100644
index 0000000000..ca24279832
--- /dev/null
+++ b/packages/linux/nslu2-kernel_2.6.12.2.bb
@@ -0,0 +1,23 @@
+# Kernel for NSLU2
+PR = r0
+include nslu2-kernel.inc
+
+# N2K_EXTRA_PATCHES - list of patches to apply (can include
+# patches to the files installed above)
+# N2K_PATCHES - full list of patches to apply, defaults to:
+# file://nslu2_2.6.11.patch;patch=1
+# file://usbnet.patch;patch=1
+# file://ixp4xx_copy_from.patch;patch=1
+# ${N2K_EXTRA_PATCHES}
+#
+
+N2K_PATCHES = "\
+ file://nslu2-arch.patch;patch=1 \
+ file://x1205-rtc.patch;patch=1 \
+ file://ixp4xx-regs.patch;patch=1 \
+ file://compile-switches.patch;patch=1 \
+ file://ixp4xx_copy_from.patch;patch=1 \
+ file://anonymiser.patch;patch=1 \
+ file://xscale-reset.patch;patch=1 \
+ file://x1205-rtc.c-id.patch;patch=1 \
+"