summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2003-10-16 17:58:41 +0000
committerChris Larson <clarson@kergoth.com>2003-10-16 17:58:41 +0000
commitaf86cb6de7ef50d8e9ff5db257bdca30b5de0011 (patch)
treed118ea933202b8a1870faa8647984a23618b6899
parent0611ae8d09c4a477bae5464a2fbcff52baa71642 (diff)
Add stage to liblockfile, add install to mailx (which builds now, btw), add depends to mailx, and correct the nano configure patch.
BKrev: 3f8edc519m2iW_sbD0e2rGGTxlN_Ew
-rw-r--r--liblockfile/liblockfile_1.05.oe23
-rw-r--r--mailx/mailx/install.patch0
-rw-r--r--mailx/mailx_8.1.2-0.20020411cvs.oe13
-rw-r--r--mailx/mailx_8.1.2-0.20031014cvs.oe13
-rw-r--r--nano/nano-1.2.1/configure.patch846
5 files changed, 895 insertions, 0 deletions
diff --git a/liblockfile/liblockfile_1.05.oe b/liblockfile/liblockfile_1.05.oe
index e69de29bb2..f9bc02a1f3 100644
--- a/liblockfile/liblockfile_1.05.oe
+++ b/liblockfile/liblockfile_1.05.oe
@@ -0,0 +1,23 @@
+DEPENDS = virtual/libc
+RDEPENDS = libc6
+
+SRC_URI = ${DEBIAN_MIRROR}/main/libl/liblockfile/liblockfile_${PV}.tar.gz \
+ file:/${FILESDIR}/install.patch;patch=1
+
+inherit autotools
+
+EXTRA_OECONF = "--enable-shared --enable-static"
+
+do_stage () {
+ install -m 644 lockfile.h maillock.h ${STAGING_DIR}/target/include/
+ install -m 755 liblockfile.so \
+ ${STAGING_LIBDIR}/liblockfile.so.1.0
+ ln -sf liblockfile.so.1.0 ${STAGING_LIBDIR}/liblockfile.so
+ install -m 644 liblockfile.a ${STAGING_LIBDIR}/
+# install -m 755 nfslock.so.1.0 ${STAGING_LIBDIR}/
+}
+
+do_install () {
+ install -d ${D}/${includedir}
+ oe_runmake 'ROOT=${D}' INSTGRP='' install
+}
diff --git a/mailx/mailx/install.patch b/mailx/mailx/install.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/mailx/mailx/install.patch
diff --git a/mailx/mailx_8.1.2-0.20020411cvs.oe b/mailx/mailx_8.1.2-0.20020411cvs.oe
index e69de29bb2..73806ee5b6 100644
--- a/mailx/mailx_8.1.2-0.20020411cvs.oe
+++ b/mailx/mailx_8.1.2-0.20020411cvs.oe
@@ -0,0 +1,13 @@
+DEPENDS = virtual/libc liblockfile
+RDEPENDS = libc6 liblockfile
+
+SRC_URI := ${DEBIAN_MIRROR}/main/m/mailx/mailx_${PV}.orig.tar.gz \
+ ${DEBIAN_MIRROR}/main/m/mailx/mailx_${PV}-1.diff.gz;patch=1 \
+ file://${FILESDIR}/install.patch;patch=1
+S := ${WORKDIR}/mailx-${PV}.orig
+
+CFLAGS_append = ' -D_BSD_SOURCE -DDEBIAN'
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+}
diff --git a/mailx/mailx_8.1.2-0.20031014cvs.oe b/mailx/mailx_8.1.2-0.20031014cvs.oe
index e69de29bb2..17fa867e64 100644
--- a/mailx/mailx_8.1.2-0.20031014cvs.oe
+++ b/mailx/mailx_8.1.2-0.20031014cvs.oe
@@ -0,0 +1,13 @@
+DEPENDS = virtual/libc liblockfile
+RDEPENDS = libc6 liblockfile
+
+SRC_URI := ${DEBIAN_MIRROR}/main/m/mailx/mailx_${PV}.orig.tar.gz \
+ ${DEBIAN_MIRROR}/main/m/mailx/mailx_${PV}-1.diff.gz;patch=1 \
+ file://${FILESDIR}/install.patch;patch=1
+S := ${WORKDIR}/mailx-${PV}.orig
+
+CFLAGS_append = ' -D_BSD_SOURCE -DDEBIAN -I${S}/EXT'
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+}
diff --git a/nano/nano-1.2.1/configure.patch b/nano/nano-1.2.1/configure.patch
index e69de29bb2..ad900c5a69 100644
--- a/nano/nano-1.2.1/configure.patch
+++ b/nano/nano-1.2.1/configure.patch
@@ -0,0 +1,846 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- nano-1.2.1/configure.ac~configure
++++ nano-1.2.1/configure.ac
+@@ -19,12 +19,12 @@
+ #
+ # $Id$
+
+-AC_INIT([GNU Nano], [1.2.1], [nano-devel@gnu.org], [nano])
++AC_INIT([GNU Nano],[1.2.1],[nano-devel@gnu.org],[nano])
+ AC_CONFIG_SRCDIR([nano.c])
+ AM_INIT_AUTOMAKE
+ AM_CONFIG_HEADER([config.h:config.h.in])
+
+-AC_PREREQ(2.52)
++AC_PREREQ(2.57)
+
+ dnl Checks for programs.
+ AC_PROG_CC
+@@ -38,14 +38,15 @@
+ dnl Checks for header files.
+ AC_HEADER_STDC
+ AC_CHECK_HEADERS(fcntl.h getopt.h libintl.h limits.h regex.h termio.h termios.h unistd.h)
++
+ AC_CHECK_HEADER(regex.h,
+- AC_MSG_CHECKING([for broken regexec])
+- AC_TRY_RUN([
++ AC_CACHE_CHECK([for broken regexec],
++ ac_cv_regexec_segfault_emptystr,
++ AC_RUN_IFELSE([AC_LANG_SOURCE([[
+ #include <sys/types.h>
+ #include <regex.h>
+-int main() { regex_t reg; size_t n; regmatch_t r; regcomp(&reg, ".", 0); regexec(&reg, "", n, &r, 0); return 0; }],
+- AC_MSG_RESULT(no),
+- AC_MSG_RESULT(yes); AC_DEFINE(BROKEN_REGEXEC, 1, [Define this if your regexec() function segfaults when passed an empty string.])
++int main() { regex_t reg; size_t n; regmatch_t r; regcomp(&reg, ".", 0); regexec(&reg, "", n, &r, 0); return 0; }]])],[AC_MSG_RESULT(no)],[AC_MSG_RESULT(yes); AC_DEFINE(BROKEN_REGEXEC, 1, Define this if your regexec() function segfaults when passed an empty string.)
++ ],[])
+ )
+ )
+
+@@ -198,11 +199,10 @@
+ AC_MSG_CHECKING([for SLtt_initialize in -lslang])
+ _libs=$LIBS
+ LIBS="$LIBS -lslang"
+- AC_TRY_RUN([
++ AC_RUN_IFELSE([AC_LANG_SOURCE([[
+ #include <stdio.h>
+ #include <slcurses.h>
+-int main () { SLtt_initialize (NULL); return 0; }],
+- [AC_MSG_RESULT(yes)
++int main () { SLtt_initialize (NULL); return 0; }]])],[AC_MSG_RESULT(yes)
+ AC_DEFINE(USE_SLANG, 1, [Define to use the slang wrappers for curses instead of native curses.])
+ slang_support=yes
+ if test "$with_slang" != "yes"; then
+@@ -210,7 +210,7 @@
+ else
+ CURSES_LIB="-lslang"
+ fi
+- CURSES_LIB_NAME=slang], [
++ CURSES_LIB_NAME=slang],[
+ AC_MSG_RESULT(no)
+ # We might need the term library
+ for termlib in ncurses curses termcap terminfo termlib; do
+@@ -220,7 +220,8 @@
+
+ AC_MSG_CHECKING([for SLtt_initialize in -lslang $tcap])
+ LIBS="$LIBS $tcap"
+- AC_TRY_RUN([
++ _au_changequote([,])
++AC_TRY_RUN([
+ #include <stdio.h>
+ #include <slcurses.h>
+ int main () { SLtt_initialize (NULL); return 0; }],
+@@ -237,7 +238,8 @@
+ # We might need the math library
+ AC_MSG_CHECKING([for SLtt_initialize in -lslang $tcap -lm])
+ LIBS="$LIBS -lm"
+- AC_TRY_RUN([
++ _au_changequote([,])
++AC_TRY_RUN([
+ #include <stdio.h>
+ #include <slcurses.h>
+ int main () { SLtt_initialize (NULL); return 0; }],
+@@ -252,8 +254,7 @@
+ CURSES_LIB_NAME=slang],
+ [AC_MSG_RESULT(no)],
+ AC_MSG_WARN([*** Can not use slang when cross-compiling]))],
+-AC_MSG_WARN([*** Can not use slang when cross-compiling]))],
+-AC_MSG_WARN([*** Can not use slang when cross-compiling])),
++AC_MSG_WARN([*** Can not use slang when cross-compiling]))],[AC_MSG_WARN(*** Can not use slang when cross-compiling)]),
+ AC_MSG_ERROR([
+ *** The header file slcurses.h was not found. If you wish to use
+ *** slang support this header file is required. Please either
+@@ -334,12 +335,11 @@
+ # Taken from aumix (can't tell from the variable name?)
+ AC_CACHE_CHECK([for private member _use_keypad in WINDOW],
+ aumix_cv_struct_window_usekeypad,
+- [AC_TRY_COMPILE([#ifdef HAVE_NCURSES_H
++ [AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#ifdef HAVE_NCURSES_H
+ #include <ncurses.h>
+ #else
+ #include <curses.h>
+-#endif], [WINDOW w; w._use_keypad;],
+- aumix_cv_struct_window_usekeypad=yes, aumix_cv_struct_window_usekeypad=no)])
++#endif]], [[WINDOW w; w._use_keypad;]])],[aumix_cv_struct_window_usekeypad=yes],[aumix_cv_struct_window_usekeypad=no])])
+
+ if test $aumix_cv_struct_window_usekeypad = yes; then
+ AC_DEFINE(HAVE_USEKEYPAD, 1, [Define this if your curses lib has the _use_keypad flag.])
+--- nano-1.2.1/configure~configure
++++ nano-1.2.1/configure
+@@ -5290,6 +5290,7 @@
+
+ done
+
++
+ if test "${ac_cv_header_regex_h+set}" = set; then
+ echo "$as_me:$LINENO: checking for regex.h" >&5
+ echo $ECHO_N "checking for regex.h... $ECHO_C" >&6
+@@ -5422,7 +5423,10 @@
+ if test $ac_cv_header_regex_h = yes; then
+ echo "$as_me:$LINENO: checking for broken regexec" >&5
+ echo $ECHO_N "checking for broken regexec... $ECHO_C" >&6
+- if test "$cross_compiling" = yes; then
++if test "${ac_cv_regexec_segfault_emptystr+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ if test "$cross_compiling" = yes; then
+ { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
+ See \`config.log' for more details." >&5
+ echo "$as_me: error: cannot run test program while cross compiling
+@@ -5472,6 +5476,10 @@
+ fi
+
+ fi
++echo "$as_me:$LINENO: result: $ac_cv_regexec_segfault_emptystr" >&5
++echo "${ECHO_T}$ac_cv_regexec_segfault_emptystr" >&6
++
++fi
+
+
+
+@@ -6037,7 +6045,8 @@
+ echo "$as_me:$LINENO: checking for SLtt_initialize in -lslang $tcap" >&5
+ echo $ECHO_N "checking for SLtt_initialize in -lslang $tcap... $ECHO_C" >&6
+ LIBS="$LIBS $tcap"
+- if test "$cross_compiling" = yes; then
++ _au_changequote(,)
++if test "$cross_compiling" = yes; then
+ { echo "$as_me:$LINENO: WARNING: *** Can not use slang when cross-compiling" >&5
+ echo "$as_me: WARNING: *** Can not use slang when cross-compiling" >&2;}
+ else
+@@ -6091,7 +6100,8 @@
+ echo "$as_me:$LINENO: checking for SLtt_initialize in -lslang $tcap -lm" >&5
+ echo $ECHO_N "checking for SLtt_initialize in -lslang $tcap -lm... $ECHO_C" >&6
+ LIBS="$LIBS -lm"
+- if test "$cross_compiling" = yes; then
++ _au_changequote(,)
++if test "$cross_compiling" = yes; then
+ { echo "$as_me:$LINENO: WARNING: *** Can not use slang when cross-compiling" >&5
+ echo "$as_me: WARNING: *** Can not use slang when cross-compiling" >&2;}
+ else
+--- nano-1.2.1/Makefile.am~configure
++++ nano-1.2.1/Makefile.am
+@@ -31,6 +31,6 @@
+ SUBDIRS = po m4
+
+ localedir = $(datadir)/locale
+-INCLUDES = -Iintl -DLOCALEDIR=\"$(localedir)\" -I@includedir@
++INCLUDES = -Iintl -DLOCALEDIR=\"$(localedir)\"
+
+ ACLOCAL_AMFLAGS = -I m4
+--- nano-1.2.1/Makefile.in~configure
++++ nano-1.2.1/Makefile.in
+@@ -1,7 +1,7 @@
+-# Makefile.in generated by automake 1.6.3 from Makefile.am.
++# Makefile.in generated by automake 1.7.7 from Makefile.am.
+ # @configure_input@
+
+-# Copyright 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002
++# Copyright 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003
+ # Free Software Foundation, Inc.
+ # This Makefile.in is free software; the Free Software Foundation
+ # gives unlimited permission to copy and/or distribute it,
+@@ -13,100 +13,124 @@
+ # PARTICULAR PURPOSE.
+
+ @SET_MAKE@
+-SHELL = @SHELL@
+
+ srcdir = @srcdir@
+ top_srcdir = @top_srcdir@
+ VPATH = @srcdir@
+-prefix = @prefix@
+-exec_prefix = @exec_prefix@
+-
+-bindir = @bindir@
+-sbindir = @sbindir@
+-libexecdir = @libexecdir@
+-datadir = @datadir@
+-sysconfdir = @sysconfdir@
+-sharedstatedir = @sharedstatedir@
+-localstatedir = @localstatedir@
+-libdir = @libdir@
+-infodir = @infodir@
+-mandir = @mandir@
+-includedir = @includedir@
+-oldincludedir = /usr/include
+ pkgdatadir = $(datadir)/@PACKAGE@
+ pkglibdir = $(libdir)/@PACKAGE@
+ pkgincludedir = $(includedir)/@PACKAGE@
+ top_builddir = .
+
+-ACLOCAL = @ACLOCAL@
+-AUTOCONF = @AUTOCONF@
+-AUTOMAKE = @AUTOMAKE@
+-AUTOHEADER = @AUTOHEADER@
+-
+ am__cd = CDPATH="$${ZSH_VERSION+.}$(PATH_SEPARATOR)" && cd
+ INSTALL = @INSTALL@
+-INSTALL_PROGRAM = @INSTALL_PROGRAM@
+-INSTALL_DATA = @INSTALL_DATA@
+ install_sh_DATA = $(install_sh) -c -m 644
+ install_sh_PROGRAM = $(install_sh) -c
+ install_sh_SCRIPT = $(install_sh) -c
+-INSTALL_SCRIPT = @INSTALL_SCRIPT@
+ INSTALL_HEADER = $(INSTALL_DATA)
+-transform = @program_transform_name@
++transform = $(program_transform_name)
+ NORMAL_INSTALL = :
+ PRE_INSTALL = :
+ POST_INSTALL = :
+ NORMAL_UNINSTALL = :
+ PRE_UNINSTALL = :
+ POST_UNINSTALL = :
+-host_alias = @host_alias@
+ host_triplet = @host@
+-
+-EXEEXT = @EXEEXT@
+-OBJEXT = @OBJEXT@
+-PATH_SEPARATOR = @PATH_SEPARATOR@
++ACLOCAL = @ACLOCAL@
++AMDEP_FALSE = @AMDEP_FALSE@
++AMDEP_TRUE = @AMDEP_TRUE@
+ AMTAR = @AMTAR@
++AUTOCONF = @AUTOCONF@
++AUTOHEADER = @AUTOHEADER@
++AUTOMAKE = @AUTOMAKE@
+ AWK = @AWK@
+-BUILD_INCLUDED_LIBINTL = @BUILD_INCLUDED_LIBINTL@
+-CATOBJEXT = @CATOBJEXT@
+ CC = @CC@
++CCDEPMODE = @CCDEPMODE@
++CFLAGS = @CFLAGS@
++CPP = @CPP@
++CPPFLAGS = @CPPFLAGS@
+ CURSES_LIB = @CURSES_LIB@
+-DATADIRNAME = @DATADIRNAME@
++CYGPATH_W = @CYGPATH_W@
++
++DEFS = -DSYSCONFDIR=\"$(sysconfdir)\"
+ DEPDIR = @DEPDIR@
+-GENCAT = @GENCAT@
+-GLIBC21 = @GLIBC21@
++ECHO_C = @ECHO_C@
++ECHO_N = @ECHO_N@
++ECHO_T = @ECHO_T@
++EGREP = @EGREP@
++EXEEXT = @EXEEXT@
+ GLIB_CFLAGS = @GLIB_CFLAGS@
+ GLIB_CONFIG = @GLIB_CONFIG@
+ GLIB_LIBS = @GLIB_LIBS@
+ GMSGFMT = @GMSGFMT@
+-HAVE_LIB = @HAVE_LIB@
++INSTALL_DATA = @INSTALL_DATA@
++INSTALL_PROGRAM = @INSTALL_PROGRAM@
++INSTALL_SCRIPT = @INSTALL_SCRIPT@
+ INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
+-INSTOBJEXT = @INSTOBJEXT@
+-INTLBISON = @INTLBISON@
+ INTLLIBS = @INTLLIBS@
+-INTLOBJS = @INTLOBJS@
+-INTL_LIBTOOL_SUFFIX_PREFIX = @INTL_LIBTOOL_SUFFIX_PREFIX@
+-LIB = @LIB@
++LDFLAGS = @LDFLAGS@
+ LIBICONV = @LIBICONV@
+ LIBINTL = @LIBINTL@
+-LTLIB = @LTLIB@
++LIBOBJS = @LIBOBJS@
++LIBS = @LIBS@
+ LTLIBICONV = @LTLIBICONV@
+ LTLIBINTL = @LTLIBINTL@
++LTLIBOBJS = @LTLIBOBJS@
++MAKEINFO = makeinfo --no-split
+ MKINSTALLDIRS = @MKINSTALLDIRS@
++MSGFMT = @MSGFMT@
++MSGMERGE = @MSGMERGE@
++OBJEXT = @OBJEXT@
+ PACKAGE = @PACKAGE@
++PACKAGE_BUGREPORT = @PACKAGE_BUGREPORT@
++PACKAGE_NAME = @PACKAGE_NAME@
++PACKAGE_STRING = @PACKAGE_STRING@
++PACKAGE_TARNAME = @PACKAGE_TARNAME@
++PACKAGE_VERSION = @PACKAGE_VERSION@
++PATH_SEPARATOR = @PATH_SEPARATOR@
+ POSUB = @POSUB@
+-RANLIB = @RANLIB@
++SET_MAKE = @SET_MAKE@
++SHELL = @SHELL@
+ STRIP = @STRIP@
+-USE_INCLUDED_LIBINTL = @USE_INCLUDED_LIBINTL@
+ USE_NLS = @USE_NLS@
+ VERSION = @VERSION@
++XGETTEXT = @XGETTEXT@
++ac_ct_CC = @ac_ct_CC@
++ac_ct_STRIP = @ac_ct_STRIP@
++am__fastdepCC_FALSE = @am__fastdepCC_FALSE@
++am__fastdepCC_TRUE = @am__fastdepCC_TRUE@
+ am__include = @am__include@
++am__leading_dot = @am__leading_dot@
+ am__quote = @am__quote@
++bindir = @bindir@
++build = @build@
++build_alias = @build_alias@
++build_cpu = @build_cpu@
++build_os = @build_os@
++build_vendor = @build_vendor@
++datadir = @datadir@
++exec_prefix = @exec_prefix@
++host = @host@
++host_alias = @host_alias@
++host_cpu = @host_cpu@
++host_os = @host_os@
++host_vendor = @host_vendor@
++includedir = @includedir@
++infodir = @infodir@
+ install_sh = @install_sh@
++libdir = @libdir@
++libexecdir = @libexecdir@
++localstatedir = @localstatedir@
++mandir = @mandir@
++oldincludedir = @oldincludedir@
++prefix = @prefix@
++program_transform_name = @program_transform_name@
++sbindir = @sbindir@
++sharedstatedir = @sharedstatedir@
++sysconfdir = @sysconfdir@
++target_alias = @target_alias@
+ AUTOMAKE_OPTIONS = gnu no-dependencies
+
+-DEFS = -DSYSCONFDIR=\"$(sysconfdir)\"
+-
+ bin_PROGRAMS = nano
+ nano_SOURCES = color.c \
+ cut.c \
+@@ -126,7 +150,6 @@
+ nano_LDADD = @GLIB_LIBS@ @LIBINTL@
+
+ info_TEXINFOS = nano.texi
+-MAKEINFO = makeinfo --no-split
+
+ EXTRA_DIST = ABOUT-NLS AUTHORS BUGS COPYING ChangeLog INSTALL NEWS \
+ README THANKS TODO UPGRADE config.rpath install-sh missing \
+@@ -137,7 +160,7 @@
+ SUBDIRS = po m4
+
+ localedir = $(datadir)/locale
+-INCLUDES = -Iintl -DLOCALEDIR=\"$(localedir)\" -I@includedir@
++INCLUDES = -Iintl -DLOCALEDIR=\"$(localedir)\"
+
+ ACLOCAL_AMFLAGS = -I m4
+ subdir = .
+@@ -154,34 +177,35 @@
+ nano_OBJECTS = $(am_nano_OBJECTS)
+ nano_DEPENDENCIES =
+ nano_LDFLAGS =
++
+ DEFAULT_INCLUDES = -I. -I$(srcdir) -I.
+-CPPFLAGS = @CPPFLAGS@
+-LDFLAGS = @LDFLAGS@
+-LIBS = @LIBS@
+ depcomp =
+ am__depfiles_maybe =
+ COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
+ $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+ CCLD = $(CC)
+ LINK = $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS) -o $@
+-CFLAGS = @CFLAGS@
+ DIST_SOURCES = $(nano_SOURCES)
++am__TEXINFO_TEX_DIR = $(srcdir)
+ INFO_DEPS = nano.info
+ DVIS = nano.dvi
++PDFS = nano.pdf
++PSS = nano.ps
+ TEXINFOS = nano.texi
+
+ NROFF = nroff
+ MANS = $(man_MANS)
+
+-RECURSIVE_TARGETS = info-recursive dvi-recursive install-info-recursive \
+- uninstall-info-recursive all-recursive install-data-recursive \
+- install-exec-recursive installdirs-recursive install-recursive \
+- uninstall-recursive check-recursive installcheck-recursive
+-DIST_COMMON = README ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL \
+- Makefile.am Makefile.in NEWS THANKS TODO aclocal.m4 \
+- config.guess config.h.in config.rpath config.sub configure \
+- configure.ac install-sh missing mkinstalldirs nano.spec.in \
+- texinfo.tex
++RECURSIVE_TARGETS = info-recursive dvi-recursive pdf-recursive \
++ ps-recursive install-info-recursive uninstall-info-recursive \
++ all-recursive install-data-recursive install-exec-recursive \
++ installdirs-recursive install-recursive uninstall-recursive \
++ check-recursive installcheck-recursive
++DIST_COMMON = README $(srcdir)/Makefile.in $(srcdir)/configure \
++ ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL Makefile.am NEWS \
++ THANKS TODO aclocal.m4 config.guess config.h.in config.rpath \
++ config.sub configure configure.ac install-sh missing \
++ mkinstalldirs nano.spec.in texinfo.tex
+ DIST_SUBDIRS = $(SUBDIRS)
+ SOURCES = $(nano_SOURCES)
+
+@@ -189,7 +213,7 @@
+ $(MAKE) $(AM_MAKEFLAGS) all-recursive
+
+ .SUFFIXES:
+-.SUFFIXES: .c .dvi .info .o .obj .ps .texi
++.SUFFIXES: .c .dvi .info .o .obj .pdf .ps .texi
+
+ am__CONFIG_DISTCLEAN_FILES = config.status config.cache config.log \
+ configure.lineno
+@@ -235,7 +259,7 @@
+ ; then \
+ f=`echo "$$p1" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`; \
+ echo " $(INSTALL_PROGRAM_ENV) $(binPROGRAMS_INSTALL) $$p $(DESTDIR)$(bindir)/$$f"; \
+- $(INSTALL_PROGRAM_ENV) $(binPROGRAMS_INSTALL) $$p $(DESTDIR)$(bindir)/$$f; \
++ $(INSTALL_PROGRAM_ENV) $(binPROGRAMS_INSTALL) $$p $(DESTDIR)$(bindir)/$$f || exit 1; \
+ else :; fi; \
+ done
+
+@@ -263,55 +287,58 @@
+ $(COMPILE) -c `test -f '$<' || echo '$(srcdir)/'`$<
+
+ .c.obj:
+- $(COMPILE) -c `cygpath -w $<`
+-
+-nano.info: nano.texi
+-nano.dvi: nano.texi
++ $(COMPILE) -c `if test -f '$<'; then $(CYGPATH_W) '$<'; else $(CYGPATH_W) '$(srcdir)/$<'; fi`
+
+ .texi.info:
+- @cd $(srcdir) && rm -f $@ $@-[0-9] $@-[0-9][0-9]
+- cd $(srcdir) \
+- && $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) \
+- `echo $< | sed 's,.*/,,'`
++ @rm -f $@ $@-[0-9] $@-[0-9][0-9] $(@:.info=).i[0-9] $(@:.info=).i[0-9][0-9]
++ $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) \
++ -o $@ `test -f '$<' || echo '$(srcdir)/'`$<
+
+ .texi.dvi:
+- TEXINPUTS="$(srcdir)$(PATH_SEPARATOR)$$TEXINPUTS" \
++ TEXINPUTS="$(am__TEXINFO_TEX_DIR)$(PATH_SEPARATOR)$$TEXINPUTS" \
+ MAKEINFO='$(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir)' \
+- $(TEXI2DVI) $<
++ $(TEXI2DVI) `test -f '$<' || echo '$(srcdir)/'`$<
+
+-.texi:
+- @cd $(srcdir) && rm -f $@ $@-[0-9] $@-[0-9][0-9]
+- cd $(srcdir) \
+- && $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) \
+- `echo $< | sed 's,.*/,,'`
++.texi.pdf:
++ TEXINPUTS="$(am__TEXINFO_TEX_DIR)$(PATH_SEPARATOR)$$TEXINPUTS" \
++ MAKEINFO='$(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir)' \
++ $(TEXI2PDF) `test -f '$<' || echo '$(srcdir)/'`$<
++nano.info: nano.texi
++nano.dvi: nano.texi
++nano.pdf: nano.texi
+ TEXI2DVI = texi2dvi
++
++TEXI2PDF = $(TEXI2DVI) --pdf --batch
+ DVIPS = dvips
+ .dvi.ps:
+- $(DVIPS) $< -o $@
++ $(DVIPS) -o $@ $<
+
+ uninstall-info-am:
+ $(PRE_UNINSTALL)
+ @if (install-info --version && \
+- install-info --version | fgrep -i -v debian) >/dev/null 2>&1; then \
++ install-info --version | grep -i -v debian) >/dev/null 2>&1; then \
+ list='$(INFO_DEPS)'; \
+ for file in $$list; do \
+- echo " install-info --info-dir=$(DESTDIR)$(infodir) --remove $(DESTDIR)$(infodir)/$$file"; \
+- install-info --info-dir=$(DESTDIR)$(infodir) --remove $(DESTDIR)$(infodir)/$$file; \
++ relfile=`echo "$$file" | sed 's|^.*/||'`; \
++ echo " install-info --info-dir=$(DESTDIR)$(infodir) --remove $(DESTDIR)$(infodir)/$$relfile"; \
++ install-info --info-dir=$(DESTDIR)$(infodir) --remove $(DESTDIR)$(infodir)/$$relfile; \
+ done; \
+ else :; fi
+ @$(NORMAL_UNINSTALL)
+ @list='$(INFO_DEPS)'; \
+ for file in $$list; do \
++ relfile=`echo "$$file" | sed 's|^.*/||'`; \
++ relfile_i=`echo "$$relfile" | sed 's|\.info$$||;s|$$|.i|'`; \
+ (if cd $(DESTDIR)$(infodir); then \
+- echo " rm -f $$file $$file-[0-9] $$file-[0-9][0-9])"; \
+- rm -f $$file $$file-[0-9] $$file-[0-9][0-9]; \
++ echo " rm -f $$relfile $$relfile-[0-9] $$relfile-[0-9][0-9] $$relfile_i[0-9] $$relfile_i[0-9][0-9])"; \
++ rm -f $$relfile $$relfile-[0-9] $$relfile-[0-9][0-9] $$relfile_i[0-9] $$relfile_i[0-9][0-9]; \
+ else :; fi); \
+ done
+
+ dist-info: $(INFO_DEPS)
+ list='$(INFO_DEPS)'; \
+ for base in $$list; do \
+- d=$(srcdir); \
++ if test -f $$base; then d=.; else d=$(srcdir); fi; \
+ for file in $$d/$$base*; do \
+ relfile=`expr "$$file" : "$$d/\(.*\)"`; \
+ test -f $(distdir)/$$relfile || \
+@@ -320,16 +347,15 @@
+ done
+
+ mostlyclean-aminfo:
+- -rm -f nano.aux nano.cp nano.dvi nano.fn nano.ky nano.log nano.pg nano.ps \
+- nano.tmp nano.toc nano.tp nano.vr
++ -rm -f nano.aux nano.cp nano.cps nano.fn nano.fns nano.ky nano.kys nano.log \
++ nano.pg nano.pgs nano.tmp nano.toc nano.tp nano.tps nano.vr \
++ nano.vrs nano.dvi nano.pdf nano.ps
+
+ maintainer-clean-aminfo:
+- cd $(srcdir) && \
+- list='$(INFO_DEPS)'; for i in $$list; do \
+- rm -f $$i; \
+- if test "`echo $$i-[0-9]*`" != "$$i-[0-9]*"; then \
+- rm -f $$i-[0-9]*; \
+- fi; \
++ @list='$(INFO_DEPS)'; for i in $$list; do \
++ i_i=`echo "$$i" | sed 's|\.info$$||;s|$$|.i|'`; \
++ echo " rm -f $$i $$i-[0-9] $$i-[0-9][0-9] $$i_i[0-9] $$i_i[0-9][0-9]"; \
++ rm -f $$i $$i-[0-9] $$i-[0-9][0-9] $$i_i[0-9] $$i_i[0-9][0-9]; \
+ done
+
+ man1dir = $(mandir)/man1
+@@ -368,6 +394,10 @@
+ done; \
+ for i in $$list; do \
+ ext=`echo $$i | sed -e 's/^.*\\.//'`; \
++ case "$$ext" in \
++ 1*) ;; \
++ *) ext='1' ;; \
++ esac; \
+ inst=`echo $$i | sed -e 's/\\.[0-9a-z]*$$//'`; \
+ inst=`echo $$inst | sed -e 's/^.*\///'`; \
+ inst=`echo $$inst | sed '$(transform)'`.$$ext; \
+@@ -411,6 +441,10 @@
+ done; \
+ for i in $$list; do \
+ ext=`echo $$i | sed -e 's/^.*\\.//'`; \
++ case "$$ext" in \
++ 5*) ;; \
++ *) ext='5' ;; \
++ esac; \
+ inst=`echo $$i | sed -e 's/\\.[0-9a-z]*$$//'`; \
+ inst=`echo $$inst | sed -e 's/^.*\///'`; \
+ inst=`echo $$inst | sed '$(transform)'`.$$ext; \
+@@ -472,10 +506,17 @@
+ list='$(SUBDIRS)'; for subdir in $$list; do \
+ test "$$subdir" = . || (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) tags); \
+ done
++ctags-recursive:
++ list='$(SUBDIRS)'; for subdir in $$list; do \
++ test "$$subdir" = . || (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) ctags); \
++ done
+
+ ETAGS = etags
+ ETAGSFLAGS =
+
++CTAGS = ctags
++CTAGSFLAGS =
++
+ tags: TAGS
+
+ ID: $(HEADERS) $(SOURCES) $(LISP) $(TAGS_FILES)
+@@ -491,9 +532,15 @@
+ $(TAGS_FILES) $(LISP)
+ tags=; \
+ here=`pwd`; \
++ if (etags --etags-include --version) >/dev/null 2>&1; then \
++ include_option=--etags-include; \
++ else \
++ include_option=--include; \
++ fi; \
+ list='$(SUBDIRS)'; for subdir in $$list; do \
+ if test "$$subdir" = .; then :; else \
+- test -f $$subdir/TAGS && tags="$$tags -i $$here/$$subdir/TAGS"; \
++ test -f $$subdir/TAGS && \
++ tags="$$tags $$include_option=$$here/$$subdir/TAGS"; \
+ fi; \
+ done; \
+ list='$(SOURCES) $(HEADERS) config.h.in $(LISP) $(TAGS_FILES)'; \
+@@ -506,13 +553,28 @@
+ || $(ETAGS) $(ETAGSFLAGS) $(AM_ETAGSFLAGS) $(ETAGS_ARGS) \
+ $$tags $$unique
+
++ctags: CTAGS
++CTAGS: ctags-recursive $(HEADERS) $(SOURCES) config.h.in $(TAGS_DEPENDENCIES) \
++ $(TAGS_FILES) $(LISP)
++ tags=; \
++ here=`pwd`; \
++ list='$(SOURCES) $(HEADERS) config.h.in $(LISP) $(TAGS_FILES)'; \
++ unique=`for i in $$list; do \
++ if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
++ done | \
++ $(AWK) ' { files[$$0] = 1; } \
++ END { for (i in files) print i; }'`; \
++ test -z "$(CTAGS_ARGS)$$tags$$unique" \
++ || $(CTAGS) $(CTAGSFLAGS) $(AM_CTAGSFLAGS) $(CTAGS_ARGS) \
++ $$tags $$unique
++
+ GTAGS:
+ here=`$(am__cd) $(top_builddir) && pwd` \
+ && cd $(top_srcdir) \
+ && gtags -i $(GTAGS_ARGS) $$here
+
+ distclean-tags:
+- -rm -f TAGS ID GTAGS GRTAGS GSYMS GPATH
++ -rm -f TAGS ID GTAGS GRTAGS GSYMS GPATH tags
+ DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
+
+ top_distdir = .
+@@ -524,13 +586,20 @@
+ && rm -fr $(distdir); }; }
+
+ GZIP_ENV = --best
++distuninstallcheck_listfiles = find . -type f -print
+ distcleancheck_listfiles = find . -type f -print
+
+ distdir: $(DISTFILES)
+ $(am__remove_distdir)
+ mkdir $(distdir)
+ $(mkinstalldirs) $(distdir)/. $(distdir)/po
+- @list='$(DISTFILES)'; for file in $$list; do \
++ @srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`; \
++ topsrcdirstrip=`echo "$(top_srcdir)" | sed 's|.|.|g'`; \
++ list='$(DISTFILES)'; for file in $$list; do \
++ case $$file in \
++ $(srcdir)/*) file=`echo "$$file" | sed "s|^$$srcdirstrip/||"`;; \
++ $(top_srcdir)/*) file=`echo "$$file" | sed "s|^$$topsrcdirstrip/|$(top_builddir)/|"`;; \
++ esac; \
+ if test -f $$file || test -d $$file; then d=.; else d=$(srcdir); fi; \
+ dir=`echo "$$file" | sed -e 's,/[^/]*$$,,'`; \
+ if test "$$dir" != "$$file" && test "$$dir" != "."; then \
+@@ -564,7 +633,7 @@
+ fi; \
+ done
+ $(MAKE) $(AM_MAKEFLAGS) \
+- top_distdir="${top_distdir}" distdir="$(distdir)" \
++ top_distdir="$(top_distdir)" distdir="$(distdir)" \
+ dist-info
+ -find $(distdir) -type d ! -perm -777 -exec chmod a+rwx {} \; -o \
+ ! -type d ! -perm -444 -links 1 -exec chmod a+r {} \; -o \
+@@ -586,13 +655,13 @@
+ $(am__remove_distdir)
+ GZIP=$(GZIP_ENV) gunzip -c $(distdir).tar.gz | $(AMTAR) xf -
+ chmod -R a-w $(distdir); chmod a+w $(distdir)
+- mkdir $(distdir)/=build
+- mkdir $(distdir)/=inst
++ mkdir $(distdir)/_build
++ mkdir $(distdir)/_inst
+ chmod a-w $(distdir)
+- dc_install_base=`$(am__cd) $(distdir)/=inst && pwd` \
+- && cd $(distdir)/=build \
+- && ../configure --srcdir=.. --prefix=$$dc_install_base \
+- --with-included-gettext \
++ dc_install_base=`$(am__cd) $(distdir)/_inst && pwd | sed -e 's,^[^:\\/]:[\\/],/,'` \
++ && dc_destdir="$${TMPDIR-/tmp}/am-dc-$$$$/" \
++ && cd $(distdir)/_build \
++ && ../configure --srcdir=.. --prefix="$$dc_install_base" \
+ $(DISTCHECK_CONFIGURE_FLAGS) \
+ && $(MAKE) $(AM_MAKEFLAGS) \
+ && $(MAKE) $(AM_MAKEFLAGS) dvi \
+@@ -600,23 +669,39 @@
+ && $(MAKE) $(AM_MAKEFLAGS) install \
+ && $(MAKE) $(AM_MAKEFLAGS) installcheck \
+ && $(MAKE) $(AM_MAKEFLAGS) uninstall \
+- && (test `find $$dc_install_base -type f -print | wc -l` -le 1 \
+- || { echo "ERROR: files left after uninstall:" ; \
+- find $$dc_install_base -type f -print ; \
+- exit 1; } >&2 ) \
++ && $(MAKE) $(AM_MAKEFLAGS) distuninstallcheck_dir="$$dc_install_base" \
++ distuninstallcheck \
++ && chmod -R a-w "$$dc_install_base" \
++ && ({ \
++ (cd ../.. && $(mkinstalldirs) "$$dc_destdir") \
++ && $(MAKE) $(AM_MAKEFLAGS) DESTDIR="$$dc_destdir" install \
++ && $(MAKE) $(AM_MAKEFLAGS) DESTDIR="$$dc_destdir" uninstall \
++ && $(MAKE) $(AM_MAKEFLAGS) DESTDIR="$$dc_destdir" \
++ distuninstallcheck_dir="$$dc_destdir" distuninstallcheck; \
++ } || { rm -rf "$$dc_destdir"; exit 1; }) \
++ && rm -rf "$$dc_destdir" \
+ && $(MAKE) $(AM_MAKEFLAGS) dist-gzip \
+ && rm -f $(distdir).tar.gz \
+ && $(MAKE) $(AM_MAKEFLAGS) distcleancheck
+ $(am__remove_distdir)
+ @echo "$(distdir).tar.gz is ready for distribution" | \
+ sed 'h;s/./=/g;p;x;p;x'
++distuninstallcheck:
++ @cd $(distuninstallcheck_dir) \
++ && test `$(distuninstallcheck_listfiles) | wc -l` -le 1 \
++ || { echo "ERROR: files left after uninstall:" ; \
++ if test -n "$(DESTDIR)"; then \
++ echo " (check DESTDIR support)"; \
++ fi ; \
++ $(distuninstallcheck_listfiles) ; \
++ exit 1; } >&2
+ distcleancheck: distclean
+- if test '$(srcdir)' = . ; then \
++ @if test '$(srcdir)' = . ; then \
+ echo "ERROR: distcleancheck can only run from a VPATH build" ; \
+ exit 1 ; \
+ fi
+- test `$(distcleancheck_listfiles) | wc -l` -eq 0 \
+- || { echo "ERROR: files left after distclean:" ; \
++ @test `$(distcleancheck_listfiles) | wc -l` -eq 0 \
++ || { echo "ERROR: files left in build directory after distclean:" ; \
+ $(distcleancheck_listfiles) ; \
+ exit 1; } >&2
+ check-am: all-am
+@@ -645,7 +730,7 @@
+ clean-generic:
+
+ distclean-generic:
+- -rm -f Makefile $(CONFIG_CLEAN_FILES)
++ -rm -f $(CONFIG_CLEAN_FILES)
+
+ maintainer-clean-generic:
+ @echo "This command is intended for maintainers to use"
+@@ -656,6 +741,8 @@
+
+ distclean: distclean-recursive
+ -rm -f $(am__CONFIG_DISTCLEAN_FILES)
++
++ -rm -f Makefile
+ distclean-am: clean-am distclean-compile distclean-generic distclean-hdr \
+ distclean-tags
+
+@@ -678,10 +765,12 @@
+ $(mkinstalldirs) $(DESTDIR)$(infodir)
+ @list='$(INFO_DEPS)'; \
+ for file in $$list; do \
+- d=$(srcdir); \
+- for ifile in echo $$d/$$file $$d/$$file-[0-9] $$d/$$file-[0-9][0-9]; do \
++ if test -f $$file; then d=.; else d=$(srcdir); fi; \
++ file_i=`echo "$$file" | sed 's|\.info$$||;s|$$|.i|'`; \
++ for ifile in $$d/$$file $$d/$$file-[0-9] $$d/$$file-[0-9][0-9] \
++ $$d/$$file_i[0-9] $$d/$$file_i[0-9][0-9] ; do \
+ if test -f $$ifile; then \
+- relfile=`expr "$$ifile" : "$$d/\(.*\)"`; \
++ relfile=`echo "$$ifile" | sed 's|^.*/||'`; \
+ echo " $(INSTALL_DATA) $$ifile $(DESTDIR)$(infodir)/$$relfile"; \
+ $(INSTALL_DATA) $$ifile $(DESTDIR)$(infodir)/$$relfile; \
+ else : ; fi; \
+@@ -689,11 +778,12 @@
+ done
+ @$(POST_INSTALL)
+ @if (install-info --version && \
+- install-info --version | fgrep -i -v debian) >/dev/null 2>&1; then \
++ install-info --version | grep -i -v debian) >/dev/null 2>&1; then \
+ list='$(INFO_DEPS)'; \
+ for file in $$list; do \
+- echo " install-info --info-dir=$(DESTDIR)$(infodir) $(DESTDIR)$(infodir)/$$file";\
+- install-info --info-dir=$(DESTDIR)$(infodir) $(DESTDIR)$(infodir)/$$file || :;\
++ relfile=`echo "$$file" | sed 's|^.*/||'`; \
++ echo " install-info --info-dir=$(DESTDIR)$(infodir) $(DESTDIR)$(infodir)/$$relfile";\
++ install-info --info-dir=$(DESTDIR)$(infodir) $(DESTDIR)$(infodir)/$$relfile || :;\
+ done; \
+ else : ; fi
+ install-man: install-man1 install-man5
+@@ -702,7 +792,9 @@
+
+ maintainer-clean: maintainer-clean-recursive
+ -rm -f $(am__CONFIG_DISTCLEAN_FILES)
+- -rm -rf autom4te.cache
++ -rm -rf $(top_srcdir)/autom4te.cache
++
++ -rm -f Makefile
+ maintainer-clean-am: distclean-am maintainer-clean-aminfo \
+ maintainer-clean-generic
+
+@@ -711,29 +803,38 @@
+ mostlyclean-am: mostlyclean-aminfo mostlyclean-compile \
+ mostlyclean-generic
+
++pdf: pdf-recursive
++
++pdf-am: $(PDFS)
++
++ps: ps-recursive
++
++ps-am: $(PSS)
++
+ uninstall-am: uninstall-binPROGRAMS uninstall-info-am uninstall-man
+
+ uninstall-info: uninstall-info-recursive
+
+ uninstall-man: uninstall-man1 uninstall-man5
+
+-.PHONY: $(RECURSIVE_TARGETS) GTAGS all all-am check check-am clean \
+- clean-binPROGRAMS clean-generic clean-recursive dist dist-all \
+- dist-gzip dist-info distcheck distclean distclean-compile \
+- distclean-generic distclean-hdr distclean-recursive \
+- distclean-tags distcleancheck distdir dvi dvi-am dvi-recursive \
+- info info-am info-recursive install install-am \
+- install-binPROGRAMS install-data install-data-am \
+- install-data-recursive install-exec install-exec-am \
+- install-exec-recursive install-info install-info-am \
+- install-info-recursive install-man install-man1 install-man5 \
+- install-recursive install-strip installcheck installcheck-am \
+- installdirs installdirs-am installdirs-recursive \
+- maintainer-clean maintainer-clean-aminfo \
++.PHONY: $(RECURSIVE_TARGETS) CTAGS GTAGS all all-am check check-am clean \
++ clean-binPROGRAMS clean-generic clean-recursive ctags \
++ ctags-recursive dist dist-all dist-gzip dist-info distcheck \
++ distclean distclean-compile distclean-generic distclean-hdr \
++ distclean-recursive distclean-tags distcleancheck distdir \
++ distuninstallcheck dvi dvi-am dvi-recursive info info-am \
++ info-recursive install install-am install-binPROGRAMS \
++ install-data install-data-am install-data-recursive \
++ install-exec install-exec-am install-exec-recursive \
++ install-info install-info-am install-info-recursive install-man \
++ install-man1 install-man5 install-recursive install-strip \
++ installcheck installcheck-am installdirs installdirs-am \
++ installdirs-recursive maintainer-clean maintainer-clean-aminfo \
+ maintainer-clean-generic maintainer-clean-recursive mostlyclean \
+ mostlyclean-aminfo mostlyclean-compile mostlyclean-generic \
+- mostlyclean-recursive tags tags-recursive uninstall \
+- uninstall-am uninstall-binPROGRAMS uninstall-info-am \
++ mostlyclean-recursive pdf pdf-am pdf-recursive ps ps-am \
++ ps-recursive tags tags-recursive uninstall uninstall-am \
++ uninstall-binPROGRAMS uninstall-info-am \
+ uninstall-info-recursive uninstall-man uninstall-man1 \
+ uninstall-man5 uninstall-recursive
+