summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenys Dmytriyenko <[denis@denix.org]>2010-01-22 10:18:39 +0100
committerKoen Kooi <koen@openembedded.org>2010-04-12 19:43:14 +0200
commita2962af827253c823b6b61525f56e228d44e7e99 (patch)
treec9b8e22fd88fe2c96992ea8690bc8653350068b1
parenta3ce66f2d449c710a027c0340919cca433db1460 (diff)
ti-codecs-dm6467: add newer version
Signed-off-by: Koen Kooi <k-kooi@ti.com>
-rw-r--r--recipes/ti/ti-codecs-dm6467_1.0.0.3.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes/ti/ti-codecs-dm6467_1.0.0.3.bb b/recipes/ti/ti-codecs-dm6467_1.0.0.3.bb
new file mode 100644
index 0000000000..21e8b6d02e
--- /dev/null
+++ b/recipes/ti/ti-codecs-dm6467_1.0.0.3.bb
@@ -0,0 +1,41 @@
+require ti-codec.inc
+
+PR = "r1"
+CSVER = "2"
+PV = "1_00_00_03"
+
+SRC_URI = "http://install.source.dir.local/cs${CSVER}dm6467_${PV}.tar.gz;name=dm6467codecs"
+
+SRC_URI[dm6467codecs.md5sum] = "b7732ecbf329520dd2d25b14fbeef8f2"
+SRC_URI[dm6467codecs.sha256sum] = "ab9115477f52814f4f0e860f89ca56bfd9ed0e8b89a3cbae9337aeac35a4abfe"
+
+# Set the source directory
+S = "${WORKDIR}/cs${CSVER}dm6467_${PV}"
+
+# compile time dependencies
+DEPENDS="ti-codec-engine ti-biosutils ti-dsplink-module"
+
+do_compile() {
+ make CE_INSTALL_DIR=${CE_INSTALL_DIR} \
+ FC_INSTALL_DIR=${FC_INSTALL_DIR} \
+ EDMA3_LLD_INSTALL_DIR=${EDMA3_LLD_INSTALL_DIR} \
+ LINK_INSTALL_DIR=${LINK_INSTALL_DIR} \
+ CMEM_INSTALL_DIR=${CMEM_INSTALL_DIR} \
+ LPM_INSTALL_DIR=${LPM_INSTALL_DIR} \
+ BIOS_INSTALL_DIR=${BIOS_INSTALL_DIR} \
+ CODEGEN_INSTALL_DIR=${CODEGEN_INSTALL_DIR} \
+ XDC_INSTALL_DIR=${XDC_INSTALL_DIR} \
+ clean all
+
+}
+
+do_install () {
+ install -d ${D}/${installdir}/codec-combo
+ cd ${S}
+ for file in `find . -name *.x64P`; do
+ cp ${file} ${D}/${installdir}/codec-combo
+ done
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+INHIBIT_PACKAGE_STRIP = "1"