summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Lee <john_lee@openmoko.org>2008-01-23 04:05:57 +0000
committerOpenmoko anonymizer key <devel@lists.openmoko.org>2008-01-23 04:05:57 +0000
commit9abe95dd3d38718f0d399bcf858f35652e14400c (patch)
treee06fcc9e9045d9ea4a9868f520208ef5c03c6ecb
parent80ed869c73abee32442ead36dec94b4b84020a97 (diff)
parent197a36f6add53d65332aa4dd33bc013270b6c927 (diff)
merge of '558d7f8556530ca23dc6e4b7d687d6727d3a7397'
and 'a22503624f899a2e28116f2ca9acb54520778734'
-rw-r--r--classes/sourcepkg.bbclass43
-rw-r--r--packages/geoclue/geoclue_git.bb4
-rw-r--r--packages/gypsy/gypsy.inc4
-rw-r--r--packages/ipkg/files/ipkg_bugfix.patch44
-rw-r--r--packages/linux/linux-openmoko_2.6.22.5.bb22
-rw-r--r--packages/meta/external-toolchain.bb2
-rw-r--r--packages/xorg-xserver/xserver-kdrive_1.3.0.0.bb17
7 files changed, 59 insertions, 77 deletions
diff --git a/classes/sourcepkg.bbclass b/classes/sourcepkg.bbclass
index bbc9f187ec..f7daa9f46c 100644
--- a/classes/sourcepkg.bbclass
+++ b/classes/sourcepkg.bbclass
@@ -18,14 +18,20 @@ def get_src_tree(d):
bb.error("S not defined, unable to find source tree.")
return
- s_tree_raw = s.split('/')[1]
+ try:
+ s_tree_raw = s.split('/')[1]
+ except IndexError:
+ return
+
s_tree = bb.data.expand(s_tree_raw, d)
src_tree_path = os.path.join(workdir, s_tree)
try:
os.listdir(src_tree_path)
except OSError:
- bb.fatal("Expected to find source tree in '%s' which doesn't exist." % src_tree_path)
+ bb.error("Expected to find source tree in '%s' which doesn't exist." % src_tree_path, s)
+ return
+
bb.debug("Assuming source tree is '%s'" % src_tree_path)
return s_tree
@@ -39,11 +45,14 @@ sourcepkg_do_create_orig_tgz(){
done
src_tree=${@get_src_tree(d)}
-
- echo $src_tree
+ if test x${src_tree} = x; then
+ oenote "Skipping empty source tree"
+ return
+ fi
+
oenote "Creating .orig.tar.gz in ${DEPLOY_DIR_SRC}/${P}.orig.tar.gz"
tar cvzf ${DEPLOY_DIR_SRC}/${P}.orig.tar.gz --exclude-from temp/exclude-from-file $src_tree
- cp -pPR $src_tree $src_tree.orig
+ cp -av $src_tree $src_tree.orig
}
sourcepkg_do_archive_bb() {
@@ -74,7 +83,14 @@ python sourcepkg_do_dumpdata() {
bb.note("Dumping metadata into '%s'" % dumpfile)
f = open(dumpfile, "w")
# emit variables and shell functions
- bb.data.emit_env(f, d, True)
+
+ # FIXME: if we emit all, bitbake will get error while
+ # evaluating AUTOREV since we have AUTOREV =
+ # "${@bb.fetch.get_srcrev(d)}" in bitbake.conf, but get_srcrev
+ # without a valid SRC_URI will cause problem.
+
+ bb.data.emit_env(f, d, True)
+
# emit the metadata which isnt valid shell
for e in d.keys():
if bb.data.getVarFlag(e, 'python', d):
@@ -89,8 +105,11 @@ sourcepkg_do_create_diff_gz(){
echo $i >> temp/exclude-from-file
done
-
src_tree=${@get_src_tree(d)}
+ if test x${src_tree} = x; then
+ oenote "Skipping empty source tree"
+ return
+ fi
for i in `find . -maxdepth 1 -type f`; do
mkdir -p $src_tree/${DISTRO}/files
@@ -102,10 +121,10 @@ sourcepkg_do_create_diff_gz(){
rm -rf $src_tree.orig
}
-EXPORT_FUNCTIONS do_create_orig_tgz do_archive_bb do_dumpdata do_create_diff_gz
+#EXPORT_FUNCTIONS do_create_orig_tgz do_archive_bb do_dumpdata do_create_diff_gz
+EXPORT_FUNCTIONS do_create_orig_tgz do_archive_bb do_create_diff_gz
addtask create_orig_tgz after do_unpack before do_patch
-addtask archive_bb after do_patch before do_dumpdata
-addtask dumpdata after do_archive_bb before do_create_diff_gz
-addtask create_diff_gz after do_dump_data before do_configure
-
+addtask archive_bb after do_patch before do_configure
+#addtask dumpdata after do_archive_bb before do_configure
+addtask create_diff_gz after do_archive_bb before do_configure
diff --git a/packages/geoclue/geoclue_git.bb b/packages/geoclue/geoclue_git.bb
index bd6778213a..b4a0cbda3a 100644
--- a/packages/geoclue/geoclue_git.bb
+++ b/packages/geoclue/geoclue_git.bb
@@ -20,6 +20,10 @@ EXTRA_OECONF = " --enable-applet=no \
--enable-gpsd \
--enable-system-bus"
+do_stage() {
+ autotools_stage_all
+}
+
do_install_append() {
mkdir -p ${D}/usr/share/
cp -pPr ${D}${STAGING_DATADIR}/* ${D}/usr/share
diff --git a/packages/gypsy/gypsy.inc b/packages/gypsy/gypsy.inc
index 6d78943bd5..77797151ff 100644
--- a/packages/gypsy/gypsy.inc
+++ b/packages/gypsy/gypsy.inc
@@ -5,6 +5,10 @@ DEPENDS = "glib-2.0 dbus bluez-libs"
inherit autotools pkgconfig
+do_stage () {
+ autotools_stage_all
+}
+
do_configure_prepend () {
touch ${S}/gtk-doc.make
}
diff --git a/packages/ipkg/files/ipkg_bugfix.patch b/packages/ipkg/files/ipkg_bugfix.patch
deleted file mode 100644
index 51eccbb2bd..0000000000
--- a/packages/ipkg/files/ipkg_bugfix.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-Index: C/ipkg_conf.c
-===================================================================
---- C.orig/ipkg_conf.c 2005-06-21 13:59:32.000000000 +0000
-+++ C/ipkg_conf.c 2007-11-27 01:11:17.000000000 +0000
-@@ -423,6 +423,7 @@
- nv_pair_t *nv_pair;
- pkg_dest_t *dest;
- char *root_dir;
-+ char *list_dir2;
-
- for (iter = nv_pair_list->head; iter; iter = iter->next) {
- nv_pair = iter->data;
-@@ -432,8 +433,14 @@
- } else {
- root_dir = strdup(nv_pair->value);
- }
-- dest = pkg_dest_list_append(&conf->pkg_dest_list, nv_pair->name, root_dir, lists_dir);
-+ if (conf->offline_root) {
-+ sprintf_alloc(&list_dir2, "%s%s", conf->offline_root, lists_dir);
-+ } else {
-+ list_dir2 = strdup(lists_dir);
-+ }
-+ dest = pkg_dest_list_append(&conf->pkg_dest_list, nv_pair->name, root_dir, list_dir2);
- free(root_dir);
-+ free(list_dir2);
- if (dest == NULL) {
- continue;
- }
-@@ -562,13 +569,13 @@
- } else if (strcmp(type, "dest") == 0) {
- nv_pair_list_append(tmp_dest_nv_pair_list, name, value);
- } else if (strcmp(type, "lists_dir") == 0) {
-- *lists_dir = realloc(*lists_dir,strlen(value)+1);
-+ *lists_dir = realloc(*lists_dir,strlen(name)+1);
- if (*lists_dir == NULL) {
- ipkg_message(conf, IPKG_ERROR, "ERROR: Not enough memory\n");
- free(options);
- return EINVAL;
- }
-- sprintf (*lists_dir,"%s",value);
-+ sprintf (*lists_dir,"%s", name);
- } else if (strcmp(type, "arch") == 0) {
- ipkg_message(conf, IPKG_INFO, "supported arch %s priority (%s)\n", name, value);
- if (!value) {
diff --git a/packages/linux/linux-openmoko_2.6.22.5.bb b/packages/linux/linux-openmoko_2.6.22.5.bb
index fe46c59a58..fc702c8719 100644
--- a/packages/linux/linux-openmoko_2.6.22.5.bb
+++ b/packages/linux/linux-openmoko_2.6.22.5.bb
@@ -60,12 +60,18 @@ module_autoload_snd-mixer-oss = "snd-mixer-oss"
# sd/mmc
module_autoload_s3cmci = "s3cmci"
-do_prepatch() {
- mv ${WORKDIR}/patches ${S}/patches && cd ${S} && quilt push -av
- mv patches patches.openmoko
- mv .pc .pc.old
- mv ${WORKDIR}/defconfig-${KERNEL_RELEASE} ${WORKDIR}/defconfig
+python do_patch_prepend() {
+ def runcmd(cmd):
+ import commands
+ (status, output) = commands.getstatusoutput(cmd)
+ if status != 0:
+ raise Exception, "Status %i: %s" % (status >> 8, output)
+ return output
+ runcmd('mv %(WORKDIR)s/patches %(S)s/patches && cd %(S)s && '
+ 'quilt push -av && mv patches patches.openmoko && '
+ 'mv .pc .pc.old && mv %(WORKDIR)s/defconfig-%(KERNEL_RELEASE)s %(WORKDIR)s/defconfig' %
+ {'WORKDIR': bb.data.getVar('WORKDIR', d, 1),
+ 'S': bb.data.getVar('S', d, 1),
+ 'KERNEL_RELEASE': bb.data.getVar('KERNEL_RELEASE', d, 1)})
+ del runcmd
}
-
-addtask prepatch after do_unpack before do_patch
-
diff --git a/packages/meta/external-toolchain.bb b/packages/meta/external-toolchain.bb
index 47d9a93a15..69f16b10df 100644
--- a/packages/meta/external-toolchain.bb
+++ b/packages/meta/external-toolchain.bb
@@ -15,7 +15,7 @@ PROVIDES = "\
virtual/linux-libc-headers \
"
-RPROVIDES = "glibc-utils libsegfault glibc-thread-db libgcc-dev libstdc++-dev libstdc++"
+#RPROVIDES = "glibc-utils libsegfault glibc-thread-db libgcc-dev libstdc++-dev libstdc++"
PACKAGES_DYNAMIC = "glibc-gconv-*"
PR = "r1"
diff --git a/packages/xorg-xserver/xserver-kdrive_1.3.0.0.bb b/packages/xorg-xserver/xserver-kdrive_1.3.0.0.bb
index 4367e40adf..e3bb271ef2 100644
--- a/packages/xorg-xserver/xserver-kdrive_1.3.0.0.bb
+++ b/packages/xorg-xserver/xserver-kdrive_1.3.0.0.bb
@@ -3,9 +3,10 @@ require xserver-kdrive-common.inc
DEPENDS += "libxkbfile libxcalibrate"
PE = "1"
-PR = "r23"
+PR = "r22"
-SRC_URI = "${XORG_MIRROR}/individual/xserver/xorg-server-${PV}.tar.bz2 \
+#SRC_URI = "${XORG_MIRROR}/individual/xserver/xorg-server-${PV}.tar.bz2 \
+SRC_URI = "git://people.freedesktop.org/~dodji/xglamo;protocol=git;tag=master \
${KDRIVE_COMMON_PATCHES} \
file://enable-epson.patch;patch=1 \
file://enable-builtin-fonts.patch;patch=1 \
@@ -21,18 +22,10 @@ SRC_URI = "${XORG_MIRROR}/individual/xserver/xorg-server-${PV}.tar.bz2 \
file://w100-fix-offscreen-bmp.patch;patch=1 \
file://kdrive-1.3-18bpp.patch;patch=1 \
file://gumstix-kmode.patch;patch=1 \
- file://smedia-glamo.patch;patch=1 \
- file://build-glamo.patch;patch=1 \
- file://00-xglamo-logs.patch;patch=1 \
- file://01-xglamo-scrolling-artifact-fix.patch;patch=1 \
- file://02-xglamo-no-dri.patch;patch=1 \
- file://03-xglamo-no-vesa.patch;patch=1 \
"
-SRC_URI_append_tosa = "file://tosa-fbdev.patch;patch=1"
-PACKAGE_ARCH_xserver-kdrive-fbdev_tosa = "${MACHINE_ARCH}"
-
-S = "${WORKDIR}/xorg-server-${PV}"
+#S = "${WORKDIR}/xorg-server-${PV}"
+S = "${WORKDIR}/git"
W100_OECONF = "--disable-w100"
W100_OECONF_arm = "--enable-w100"