summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-07-30 20:46:24 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-30 20:46:24 +0000
commit92c083d055ae8f958ae2ad79cb1f9751e697bb47 (patch)
treee502c9598355fc4f9e73c5b861d33955edb26d40
parent3d97034fa59463df76195e5845189fc6d1e10933 (diff)
parent82eca06c34e4483962439a7e363e1c299cc1c59e (diff)
merge of d5c1c82a4f4d4259c9ae9a22865774bf9df663ca
and e8a8ea202059d2f8a7a8f6d316818ee71b449d4a
-rw-r--r--classes/tinderclient.bbclass40
-rw-r--r--conf/distro/openslug-packages.conf3
-rw-r--r--conf/tinder.conf5
-rw-r--r--packages/base-files/base-files/profile6
-rw-r--r--packages/base-files/base-files_3.0.14.bb2
-rw-r--r--packages/dbus/dbus/dbus-1.init87
-rw-r--r--packages/linux/linux-openzaurus_2.6.11.bb34
-rw-r--r--packages/meta/openslug-native.bb3
-rw-r--r--packages/meta/openslug-packages.bb2
-rw-r--r--packages/perl/perl-5.8.7/config.sh-arm-linux.patch3
-rw-r--r--packages/perl/perl_5.8.7.bb16
11 files changed, 132 insertions, 69 deletions
diff --git a/classes/tinderclient.bbclass b/classes/tinderclient.bbclass
index 5de9b8755a..5b55589ec0 100644
--- a/classes/tinderclient.bbclass
+++ b/classes/tinderclient.bbclass
@@ -1,6 +1,26 @@
-def tinder_tinder_time():
- import time
- return time.strftime('%m/%d/%Y %H:%M:%S', time.localtime())
+def tinder_tz_offset(off):
+ # get the offset. Either it is a number like
+ # +200 or -300
+ try:
+ return int(off)
+ except ValueError:
+ if off == "Europe/Berlin":
+ return 200
+ else:
+ return 0
+
+def tinder_tinder_time(offset):
+ import datetime
+ td = datetime.timedelta(tinder_tz_offset(offset))
+ time = datetime.datetime.utcnow() + td
+ return time.strftime('%m/%d/%Y %H:%M:%S')
+
+def tinder_tinder_start(date,offset):
+ import datetime, time
+ td = datetime.timedelta(tinder_tz_offset(offset))
+ ti = time.strptime(date, "%m/%d/%Y %H:%M:%S")
+ ti = datetime.datetime(*ti[0:7])-td
+ return time.strftime('%m/%d/%Y %H:%M:%S')
def tinder_send_email(da, header, log):
import smtplib
@@ -21,8 +41,8 @@ def tinder_send_http(da, header, log):
from bb import data
import httplib, urllib
cont = "\n%s\n%s" % ( header, log)
- headers = {"Content-type": "multipart/form-data" }
-
+ headers = {"Content-type": "multipart/form-data" }
+
conn = httplib.HTTPConnection(data.getVar('TINDER_HOST',da, True))
conn.request("POST", data.getVar('TINDER_URL',da,True), cont, headers)
conn.close()
@@ -33,11 +53,11 @@ def tinder_prepare_mail_header(da, status):
from bb import data
str = "tinderbox: administrator: %s\n" % data.getVar('TINDER_ADMIN', da, True)
- str += "tinderbox: starttime: %s\n" % data.getVar('BUILDSTART', da, True) or data.getVar('TINDER_START', da, True)
+ str += "tinderbox: starttime: %s\n" % tinder_tinder_start(data.getVar('TINDER_START', da, True) or data.getVar('BUILDSTART', da, True), data.getVar('TINDER_TZ', da, True))
str += "tinderbox: buildname: %s\n" % data.getVar('TINDER_BUILD', da, True)
str += "tinderbox: errorparser: %s\n" % data.getVar('TINDER_ERROR', da, True)
str += "tinderbox: status: %s\n" % status
- str += "tinderbox: timenow: %s\n" % tinder_tinder_time()
+ str += "tinderbox: timenow: %s\n" % tinder_tinder_time(data.getVar('TINDER_TZ', da, True))
str += "tinderbox: tree: %s\n" % data.getVar('TINDER_TREE', da, True)
str += "tinderbox: buildfamily: %s\n" % "unix"
str += "tinderbox: END"
@@ -76,8 +96,8 @@ def tinder_do_tinder_report(event):
if name == "PkgFailed" or name == "BuildCompleted":
status = 'build_failed'
- if name == "BuildCompleted":
- status = "success"
+ if name == "BuildCompleted":
+ status = "success"
header = tinder_prepare_mail_header(event.data, status)
# append the log
log_file = data.getVar('TINDER_LOG', event.data, True)
@@ -120,7 +140,7 @@ def tinder_do_tinder_report(event):
log_post_method = tinder_send_email
if data.getVar('TINDER_SENDLOG', event.data, True) == "http":
- log_post_method = tinder_send_http
+ log_post_method = tinder_send_http
log_post_method(event.data, header, log)
diff --git a/conf/distro/openslug-packages.conf b/conf/distro/openslug-packages.conf
index e4da231aa5..5972afdbf0 100644
--- a/conf/distro/openslug-packages.conf
+++ b/conf/distro/openslug-packages.conf
@@ -19,6 +19,8 @@ ${PKGDIR}/packages/bzip2/*.bb \
${PKGDIR}/packages/coreutils/*.bb \
${PKGDIR}/packages/cpio/*.bb \
${PKGDIR}/packages/cron/*.bb \
+${PKGDIR}/packages/cyrus-imapd/*.bb \
+${PKGDIR}/packages/cyrus-sasl/*.bb \
${PKGDIR}/packages/cvs/*.bb \
${PKGDIR}/packages/db/*.bb \
${PKGDIR}/packages/devio/*.bb \
@@ -92,6 +94,7 @@ ${PKGDIR}/packages/musicpd/*.bb \
${PKGDIR}/packages/mutt/*.bb \
${PKGDIR}/packages/mysql/*.bb \
${PKGDIR}/packages/nail/*.bb \
+${PKGDIR}/packages/nano/*.bb \
${PKGDIR}/packages/ncftp/*.bb \
${PKGDIR}/packages/ncurses/*.bb \
${PKGDIR}/packages/netbase/*.bb \
diff --git a/conf/tinder.conf b/conf/tinder.conf
index 3d65dcb51b..2c50b62a17 100644
--- a/conf/tinder.conf
+++ b/conf/tinder.conf
@@ -12,7 +12,7 @@ INHERIT += "tinderclient"
#One mail/post per task
#TINDER_VERBOSE_REPORT = "1"
-#TINDER_LOG = "${TMPDIR}/tinder.log"
+#TINDER_LOG = "${TMPbDIR}/tinder.log"
#TINDER_TREE = "OpenEmbeddedBuild"
@@ -30,6 +30,9 @@ INHERIT += "tinderclient"
#TINDER_SENDLOG = "http"
+# TimeZone handling
+#TINDER_TZ = "+0200"
+
# Do a report at all
#TINDER_REPORT = "1"
diff --git a/packages/base-files/base-files/profile b/packages/base-files/base-files/profile
index f24fec92ca..a4c16944b9 100644
--- a/packages/base-files/base-files/profile
+++ b/packages/base-files/base-files/profile
@@ -5,6 +5,12 @@ PATH="/usr/local/bin:/usr/bin:/bin"
EDITOR="/bin/vi" # needed for packages like cron
TERM="vt100" # Basic terminal capab. For screen etc.
+if [ ! -e /etc/localtime ]; then
+ TZ="UTC" # Time Zone. Look at http://theory.uwinnipeg.ca/gnu/glibc/libc_303.html
+ # for an explanation of how to set this to your local timezone.
+ export TZ
+fi
+
if [ "`id -u`" -eq 0 ]; then
PATH=$PATH:/usr/local/sbin:/usr/sbin:/sbin:
fi
diff --git a/packages/base-files/base-files_3.0.14.bb b/packages/base-files/base-files_3.0.14.bb
index ec58e08bef..144bf2e135 100644
--- a/packages/base-files/base-files_3.0.14.bb
+++ b/packages/base-files/base-files_3.0.14.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Miscellaneous files for the base system."
SECTION = "base"
PRIORITY = "required"
-PR = "r38"
+PR = "r39"
LICENSE = "GPL"
SRC_URI = " \
diff --git a/packages/dbus/dbus/dbus-1.init b/packages/dbus/dbus/dbus-1.init
index 118b801da7..bd31b6208c 100644
--- a/packages/dbus/dbus/dbus-1.init
+++ b/packages/dbus/dbus/dbus-1.init
@@ -1,15 +1,17 @@
#! /bin/sh
-# -*- coding: iso8859-1 -*-
+# -*- coding: utf-8 -*-
# Debian init.d script for D-BUS
-# Copyright (c) 2003 Colin Walters <walters@debian.org>
+# Copyright © 2003 Colin Walters <walters@debian.org>
set -e
DAEMON=/usr/bin/dbus-daemon-1
NAME=dbus-1
DAEMONUSER=messagebus
-PIDFILE=/var/run/dbus/pid
+PIDDIR=/var/run/dbus
+PIDFILE=$PIDDIR/pid
DESC="system message bus"
+EVENTDIR=/etc/dbus-1/event.d
test -x $DAEMON || exit 0
@@ -17,41 +19,68 @@ test -x $DAEMON || exit 0
ENABLED=1
PARAMS=""
if [ -e /etc/default/dbus-1 ]; then
- . /etc/default/dbus-1
+ . /etc/default/dbus-1
fi
test "$ENABLED" != "0" || exit 0
+start_it_up()
+{
+ if [ ! -d $PIDDIR ]; then
+ mkdir -p $PIDDIR
+ chown $DAEMONUSER $PIDDIR
+ chgrp $DAEMONUSER $PIDDIR
+ fi
+ if [ -e $PIDFILE ]; then
+ PIDDIR=/proc/$(cat $PIDFILE)
+ if [ -d ${PIDDIR} -a "$(readlink -f ${PIDDIR}/exe)" = "${DAEMON}" ]; then
+ echo "$DESC already started; not starting."
+ else
+ echo "Removing stale PID file $PIDFILE."
+ rm -f $PIDFILE
+ fi
+ fi
+ echo -n "Starting $DESC: "
+ start-stop-daemon --start --quiet --pidfile $PIDFILE \
+ --user $DAEMONUSER --exec $DAEMON -- --system $PARAMS
+ echo "$NAME."
+ if [ -d $EVENTDIR ]; then
+ run-parts --arg=start $EVENTDIR
+ fi
+}
+
+shut_it_down()
+{
+ if [ -d $EVENTDIR ]; then
+ run-parts --reverse --arg=stop $EVENTDIR
+ fi
+ echo -n "Stopping $DESC: "
+ start-stop-daemon --stop --retry 60 --quiet --oknodo --pidfile $PIDFILE \
+ --user $DAEMONUSER
+ # We no longer include these arguments so that start-stop-daemon
+ # can do its job even given that we may have been upgraded.
+ # We rely on the pidfile being sanely managed
+ # --exec $DAEMON -- --system $PARAMS
+ echo "$NAME."
+ rm -f $PIDFILE
+}
+
case "$1" in
start)
- echo -n "Starting $DESC: "
- if [ ! -d /var/run/dbus ]; then
- mkdir /var/run/dbus
- chown $DAEMONUSER:$DAEMONUSER /var/run/dbus
- fi
- start-stop-daemon -S \
- -u $DAEMONUSER -x $DAEMON -- --system $PARAMS
- echo "$NAME."
- ;;
+ start_it_up
+ ;;
stop)
- echo -n "Stopping $DESC: "
- start-stop-daemon -K \
- -u $DAEMONUSER -x $DAEMON -- --system $PARAMS
- echo "$NAME."
- ;;
+ shut_it_down
+ ;;
restart|force-reload)
- echo -n "Restarting $DESC: "
- start-stop-daemon -K \
- -u $DAEMONUSER -x $DAEMON -- --system $PARAMS
- sleep 1
- start-stop-daemon -S \
- -u $DAEMONUSER -x $DAEMON -- --system $PARAMS
- echo "$NAME."
- ;;
+ shut_it_down
+ sleep 1
+ start_it_up
+ ;;
*)
- echo "Usage: /etc/init.d/$NAME {start|stop|restart|force-reload}" >&2
- exit 1
- ;;
+ echo "Usage: /etc/init.d/$NAME {start|stop|restart|force-reload}" >&2
+ exit 1
+ ;;
esac
exit 0
diff --git a/packages/linux/linux-openzaurus_2.6.11.bb b/packages/linux/linux-openzaurus_2.6.11.bb
index d93006ffa7..ef1a97d2e4 100644
--- a/packages/linux/linux-openzaurus_2.6.11.bb
+++ b/packages/linux/linux-openzaurus_2.6.11.bb
@@ -21,31 +21,31 @@ JLSRC = "http://www.cs.wisc.edu/~lenz/zaurus/files/"
SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.11.tar.gz \
http://www.kernel.org/pub/linux/kernel/people/rml/inotify/v2.6/0.22/inotify-0.22-rml-2.6.11-1.patch;patch=1 \
${JLSRC}/zaurus-base-2.6.11.diff.gz;patch=1 \
- ${RPSRC}/rndis_fix-r0.patch;patch=1 \
- ${RPSRC}/w100_malloc-r2.patch;patch=1 \
- ${RPSRC}/pxairq_printk-r0.patch;patch=1 \
- ${RPSRC}/corgi_kbd-r14.patch;patch=1 \
- ${RPSRC}/corgi_ts-r10.patch;patch=1 \
- ${RPSRC}/sharp_multi_scoop-r1.patch;patch=1 \
- ${RPSRC}/corgi_kbd1-r0.patch;patch=1 \
- ${RPSRC}/sharpsl_param-r5.patch;patch=1 \
+ ${RPSRC}/archive/rndis_fix-r0.patch;patch=1 \
+ ${RPSRC}/archive/w100_malloc-r2.patch;patch=1 \
+ ${RPSRC}/archive/pxairq_printk-r0.patch;patch=1 \
+ ${RPSRC}/archive/corgi_kbd-r14.patch;patch=1 \
+ ${RPSRC}/archive/corgi_ts-r10.patch;patch=1 \
+ ${RPSRC}/archive/sharp_multi_scoop-r1.patch;patch=1 \
+ ${RPSRC}/archive/corgi_kbd1-r0.patch;patch=1 \
+ ${RPSRC}/archive/sharpsl_param-r5.patch;patch=1 \
${RPSRC}/pxa_rtc-r1.patch;patch=1 \
- ${RPSRC}/pxa_irda-r1.patch;patch=1 \
- ${RPSRC}/pxaudc_susres-r1.patch;patch=1 \
+ ${RPSRC}/archive/pxa_irda-r1.patch;patch=1 \
+ ${RPSRC}/archive/pxaudc_susres-r1.patch;patch=1 \
${RPSRC}/sharp_multi_pcmcia-r2.patch;patch=1 \
- ${RPSRC}/pxa_turbo-r0.patch;patch=1 \
- ${RPSRC}/sharpsl_mapprom-r1.patch;patch=1 \
- ${RPSRC}/input_power-r1.patch;patch=1 \
+ ${RPSRC}/archive/pxa_turbo-r0.patch;patch=1 \
+ ${RPSRC}/archive/sharpsl_mapprom-r1.patch;patch=1 \
+ ${RPSRC}/archive/input_power-r1.patch;patch=1 \
${RPSRC}/corgi_irda-r2.patch;patch=1 \
${RPSRC}/corgi_base_extras1-r2.patch;patch=1 \
${RPSRC}/jffs2_longfilename-r0.patch;patch=1 \
- ${RPSRC}/corgi_power-r22.patch;patch=1 \
+ ${RPSRC}/archive/corgi_power-r22.patch;patch=1 \
${RPSRC}/corgi_power1-r1.patch;patch=1 \
- ${RPSRC}/ide_fixes-r1.patch;patch=1 \
- ${RPSRC}/mmc_sd-r4.patch;patch=1 \
+ ${RPSRC}/archive/ide_fixes-r1.patch;patch=1 \
+ ${RPSRC}/archive/mmc_sd-r4.patch;patch=1 \
${RPSRC}/mmc_timeout-r0.patch;patch=1 \
${RPSRC}/corgi_snd-r6.patch;patch=1 \
- ${RPSRC}/w100_split-r5-r1.patch;patch=1 \
+ ${RPSRC}/archive/w100_split-r5-r1.patch;patch=1 \
${DOSRC}/pxa2xx-ir-dma-r0.patch;patch=1 \
${DOSRC}/tc6393-device-r2.patch;patch=1 \
${DOSRC}/tc6393_nand-r2.patch;patch=1 \
diff --git a/packages/meta/openslug-native.bb b/packages/meta/openslug-native.bb
index a3bd0a830a..d61815eb6a 100644
--- a/packages/meta/openslug-native.bb
+++ b/packages/meta/openslug-native.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "Packages that are required for the OpenSlug native build environment"
LICENSE = MIT
-PR = "r5"
+PR = "r6"
INHIBIT_DEFAULT_DEPS = "1"
ALLOW_EMPTY = 1
@@ -34,6 +34,7 @@ OPENSLUG_NATIVE = "\
monotone-5 \
ncurses ncurses-dev ncurses-terminfo \
patch \
+ perl perl-modules \
python-core python-io python-lang python-pickle python-shell python-textutils \
sed \
tar \
diff --git a/packages/meta/openslug-packages.bb b/packages/meta/openslug-packages.bb
index 96d81e1d31..7a62698dd0 100644
--- a/packages/meta/openslug-packages.bb
+++ b/packages/meta/openslug-packages.bb
@@ -53,6 +53,7 @@ OPENSLUG_PACKAGES = "\
coreutils \
cron \
cvs\
+ cyrus-imapd \
dnsmasq \
expat \
ftpd-topfield \
@@ -70,6 +71,7 @@ OPENSLUG_PACKAGES = "\
mutt \
mysql \
nail \
+ nano \
ncftp \
obexftp openobex openobex-apps ircp \
openssh \
diff --git a/packages/perl/perl-5.8.7/config.sh-arm-linux.patch b/packages/perl/perl-5.8.7/config.sh-arm-linux.patch
index ae162fbdc6..0f56601b8b 100644
--- a/packages/perl/perl-5.8.7/config.sh-arm-linux.patch
+++ b/packages/perl/perl-5.8.7/config.sh-arm-linux.patch
@@ -17,7 +17,8 @@
perl=''
perl_patchlevel=''
perladmin='red@criticalintegration.com'
- perllibs='-lnsl -ldl -lm -lcrypt -lutil -lc'
+-perllibs='-lnsl -ldl -lm -lcrypt -lutil -lc'
++perllibs='-lnsl -ldl -lm -lcrypt -lutil -lc -lgcc_s'
-perlpath='/usr/bin/perl'
+perlpath='hostperl'
pg='pg'
diff --git a/packages/perl/perl_5.8.7.bb b/packages/perl/perl_5.8.7.bb
index 16c43cc8e9..7d79105065 100644
--- a/packages/perl/perl_5.8.7.bb
+++ b/packages/perl/perl_5.8.7.bb
@@ -4,7 +4,7 @@ include perl.inc
SRC_URI += "file://config.sh-armeb-linux"
-PR = "r5"
+PR = "r7"
do_configure() {
ln -sf ${HOSTPERL} ${STAGING_BINDIR}/hostperl
@@ -32,11 +32,9 @@ do_install_append() {
ln -s libperl.so.${PV} ${D}/${libdir}/libperl.so.5
}
-# Create a perl-modules package depending on all the other perl
-# packages (actually the non modules packages too)
-# This means creating lots of empty packages too, so its set to only
-# openslug for the time beeing
-ALLOW_EMPTY_openslug = 1
-PACKAGES_append_openslug = " perl-modules"
-RDEPENDS_perl-modules_openslug = "${PACKAGES}"
-RPROVIDES_perl-lib_openslug = "perl-lib"
+# Create a perl-modules package recommending all the other perl
+# packages (actually the non modules packages and not created too)
+ALLOW_EMPTY_perl-modules = 1
+PACKAGES_append = " perl-modules"
+RRECOMMENDS_perl-modules = "${PACKAGES}"
+RPROVIDES_perl-lib = "perl-lib"