summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Zimmermann <ml@vdm-design.de>2009-12-01 10:43:06 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2009-12-02 23:08:30 +0100
commit82dc7febcd9d777cd594f9ac9e28aa50826bbdd4 (patch)
treea62c81c617e70bcb100170718d4c01e7ffcf5919
parent0d7c70004bf85ee59d8ce48d6d83c68b313859bd (diff)
babiloo, neomis, numberx: update to recent version (addopting callbacks from new python-elementary)
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--conf/distro/include/sane-srcrevs.inc6
-rw-r--r--recipes/openmoko-3rdparty/babiloo-efl_2.0.9-4.bb40
2 files changed, 43 insertions, 3 deletions
diff --git a/conf/distro/include/sane-srcrevs.inc b/conf/distro/include/sane-srcrevs.inc
index e755bf5b75..258966a2d3 100644
--- a/conf/distro/include/sane-srcrevs.inc
+++ b/conf/distro/include/sane-srcrevs.inc
@@ -20,7 +20,7 @@ SRCREV_pn-app-restarter ?= "4552"
SRCREV_pn-assassin ?= "268"
SRCREV_pn-assassin-thumbnail ?= "4690"
SRCREV_pn-aufs2-util ?= "f35ba2292fe40aa94aa83713e0b2719f35a25768"
-SRCREV_pn-babiloo-efl ?= "288"
+SRCREV_pn-babiloo-efl ?= "296"
SRCREV_pn-bfin-uclibc ?= "1857"
SRCREV_pn-blipomoko ?= "93295f36f7b45c691df247cb2a65227facf13654"
SRCREV_pn-bootchart-lite ?= "4"
@@ -198,10 +198,10 @@ SRCREV_pn-multitap-pad ?= "373"
SRCREV_pn-mux ?= "72460e890dbb15edbf7dc193116be0dcf9794a8b"
SRCREV_pn-navit ?= "1096"
SRCREV_pn-neod ?= "4617"
-SRCREV_pn-neomis ?= "2"
+SRCREV_pn-neomis ?= "6"
SRCREV_pn-net-snmp ?= "17367"
SRCREV_pn-netsurf ?= "3859"
-SRCREV_pn-numberx ?= "3"
+SRCREV_pn-numberx ?= "4"
SRCREV_pn-numptyphysics ?= "109"
SRCREV_pn-oh-puzzles ?= "22"
SRCREV_pn-ohm ?= "edfe25d49d67884bf004de7ae0724c162bb5e65e"
diff --git a/recipes/openmoko-3rdparty/babiloo-efl_2.0.9-4.bb b/recipes/openmoko-3rdparty/babiloo-efl_2.0.9-4.bb
new file mode 100644
index 0000000000..04e8524543
--- /dev/null
+++ b/recipes/openmoko-3rdparty/babiloo-efl_2.0.9-4.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "EFL Dictionary Viewer. It supports dictionaries in SDictionary and StarDict format."
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "GPL"
+AUTHOR = "Luca Vaudano <vaudano@gmail.com>"
+HOMEPAGE = "http://babiloo-project.org"
+RDEPENDS = "python-elementary python-compression python-misc python-netclient"
+
+PACKAGE_ARCH = "all"
+
+PV = "2.0.9-4"
+PR = "r0"
+
+SRC_URI = "http://bazaar.launchpad.net/%7Evaudano/babiloo/efl/download/head%3A/babiloo_2.0.94.tar.g-20091201105555-efky7gi6fkm39xw8-2/babiloo_2.0.9-4.tar.gz;name=tarball"
+SRC_URI[tarball.md5sum] = "f5f25daff7accb8d409fa9f94c49fc17"
+SRC_URI[tarball.sha256sum] = "28fc4550f986512aaa96ebf776f16d3cb9d9b493ac1805642def54c8167a0f74"
+
+S = "${WORKDIR}/babiloo"
+
+do_install() {
+ install -d "${D}${datadir}/babiloo"
+ install -d "${D}${datadir}/babiloo/dicts"
+
+ cp -a "${S}/core" "${D}${datadir}/babiloo/"
+ cp -a "${S}/efl" "${D}${datadir}/babiloo/"
+ cp -a "${S}/images" "${D}${datadir}/babiloo/"
+ install -m 0755 "${S}/run.py" "${D}${datadir}/babiloo/"
+ install -d "${D}${bindir}"
+ ln -s "${datadir}/babiloo/run.py" "${D}${bindir}/babiloo"
+ install -d "${D}${datadir}/pixmaps"
+ install -m 0644 "${S}/images/babiloo.png" "${D}${datadir}/pixmaps"
+ install -d "${D}${datadir}/applications"
+ install -m 0644 "${S}/babiloo.desktop" "${D}${datadir}/applications"
+
+ #cp -a "${S}/locale" "${D}${datadir}/"
+ #find ${D}${datadir}/locale -name *.po -exec rm {} \;
+ #rm -f ${D}${datadir}/locale/babiloo.pot
+}
+
+FILES_${PN} += "${datadir}/babiloo"