summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-06-09 10:26:14 +0200
committerKoen Kooi <koen@openembedded.org>2009-06-09 10:26:14 +0200
commit82a25a2ab706258924383427ced521cc46781cde (patch)
tree54847f088b848d5025155ad288346f1eb53724b8
parentf5b1a574ba602da5728fc8a975bb49f2f41461d7 (diff)
webkit-gtk: bump SRCREV
-rw-r--r--conf/distro/include/sane-srcrevs.inc2
-rw-r--r--recipes/webkit/webkit-gtk/configure.ac25
2 files changed, 5 insertions, 22 deletions
diff --git a/conf/distro/include/sane-srcrevs.inc b/conf/distro/include/sane-srcrevs.inc
index fe3885b2af..adfe663f9f 100644
--- a/conf/distro/include/sane-srcrevs.inc
+++ b/conf/distro/include/sane-srcrevs.inc
@@ -254,7 +254,7 @@ SRCREV_pn-usbpath-native ?= "3172"
SRCREV-pn-vala-dbus-binding-tool-native ?= "55a6bc5dd032731d89c238d274b2898ef02d12f8"
SRCREV_pn-vala-terminal ?= "94117f453ce884e9c30b611fae6fc19f85f98f2b"
SRCREV_pn-vala-native ?= "6cf030120cd7f6a76a5d766d7420aea847e02cfd"
-SRCREV_pn-webkit-gtk ?= "44489"
+SRCREV_pn-webkit-gtk ?= "44523"
SRCREV_pn-wlan-ng-modules ?= "1859"
SRCREV_pn-wlan-ng-utils ?= "1859"
SRCREV_pn-wmiconfig ?= "4522"
diff --git a/recipes/webkit/webkit-gtk/configure.ac b/recipes/webkit/webkit-gtk/configure.ac
index 6375788dd3..2ee8210695 100644
--- a/recipes/webkit/webkit-gtk/configure.ac
+++ b/recipes/webkit/webkit-gtk/configure.ac
@@ -548,23 +548,10 @@ else
CFLAGS="$CFLAGS -O0"
fi
-# check whether to use libsoup-gnome
-AC_MSG_CHECKING([whether to use GNOME-specific features of libsoup])
-AC_ARG_WITH(libsoup_gnome,
- AC_HELP_STRING([--with-libsoup-gnome],
- [using GNOME-specific features of libsoup [default=no]]),
- [],[with_libsoup_gnome="no"])
-AC_MSG_RESULT([$with_libsoup_gnome])
-
-if test "$with_libsoup_gnome" = "yes"; then
- PKG_CHECK_MODULES([LIBSOUP],
- [libsoup-gnome-2.4 >= $LIBSOUP_REQUIRED_VERSION])
-else
- PKG_CHECK_MODULES([LIBSOUP],
- [libsoup-2.4 >= $LIBSOUP_REQUIRED_VERSION])
-fi
-AC_SUBST(LIBSOUP_CFLAGS)
-AC_SUBST(LIBSOUP_LIBS)
+PKG_CHECK_MODULES([LIBSOUP],
+ [libsoup-2.4 >= $LIBSOUP_REQUIRED_VERSION])
+AC_SUBST([LIBSOUP_CFLAGS])
+AC_SUBST([LIBSOUP_LIBS])
if test "$enable_gnomekeyring" = "yes"; then
PKG_CHECK_MODULES([GNOMEKEYRING],
@@ -663,9 +650,6 @@ AM_CONDITIONAL([USE_GNOMEKEYRING], [test "$enable_gnomekeyring" = "yes"])
AM_CONDITIONAL([USE_FREETYPE], [test "$with_font_backend" = "freetype"])
AM_CONDITIONAL([USE_PANGO], [test "$with_font_backend" = "pango"])
-# libsoup-gnome conditionals
-AM_CONDITIONAL([USE_SOUP_GNOME], [test "$with_libsoup_gnome" = "yes"])
-
# WebKit feature conditionals
AM_CONDITIONAL([ENABLE_DEBUG],[test "$enable_debug" = "yes"])
AM_CONDITIONAL([ENABLE_DASHBOARD_SUPPORT],[test "$enable_dashboard_support" = "yes"])
@@ -715,7 +699,6 @@ Build configuration:
Unicode backend : $with_unicode_backend
Font backend : $with_font_backend
Optimized memory allocator : $enable_fast_malloc
- Using GNOME-specific features of libsoup : $with_libsoup_gnome
Features:
3D Transforms : $enable_3D_transforms
JIT compilation : $enable_jit