summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-08-05 19:50:54 +0000
committerKoen Kooi <koen@openembedded.org>2006-08-05 19:50:54 +0000
commit7a3ad4715faf8adc906eb394d1c242033c3944fa (patch)
treedab2f1a14da2fda0d520037deafa96a1de6c23ed
parentfafbb42f3369782a8298f59ec45d919cfa48987d (diff)
parentc5590211fb861491261866b9f64bbfb32c474394 (diff)
merge of '2ca01af51f12b07b28c6a80e57347d82f7122780'
and '7f3bc3b8600afa9c810238b8d5a88ec7a80c6c9a'
-rw-r--r--packages/libmatchbox/libmatchbox_1.9.bb9
-rw-r--r--packages/matchbox-wm/matchbox-wm_1.1.bb33
2 files changed, 42 insertions, 0 deletions
diff --git a/packages/libmatchbox/libmatchbox_1.9.bb b/packages/libmatchbox/libmatchbox_1.9.bb
new file mode 100644
index 0000000000..d87eb09150
--- /dev/null
+++ b/packages/libmatchbox/libmatchbox_1.9.bb
@@ -0,0 +1,9 @@
+require libmatchbox.inc
+PR = "r0"
+
+SRC_URI = "http://projects.o-hand.com/matchbox/sources/${PN}/${PV}/${PN}-${PV}.tar.gz \
+ file://check.m4"
+
+do_configure_prepend () {
+ mv ${WORKDIR}/check.m4 ${S}/
+}
diff --git a/packages/matchbox-wm/matchbox-wm_1.1.bb b/packages/matchbox-wm/matchbox-wm_1.1.bb
new file mode 100644
index 0000000000..8e28d0c041
--- /dev/null
+++ b/packages/matchbox-wm/matchbox-wm_1.1.bb
@@ -0,0 +1,33 @@
+SECTION = "x11/wm"
+DESCRIPTION = "Matchbox window manager"
+LICENSE = "GPL"
+DEPENDS = "libmatchbox virtual/libx11 libxext libxcomposite libxfixes libxdamage libxrender startup-notification expat gconf matchbox-common"
+RDEPENDS = "matchbox-common"
+PR="r0"
+
+
+SRC_URI = "http://projects.o-hand.com/matchbox/sources/matchbox-window-manager/1.1/matchbox-window-manager-${PV}.tar.gz \
+ file://kbdconfig"
+
+S = "${WORKDIR}/matchbox-window-manager-${PV}"
+
+inherit autotools pkgconfig update-alternatives
+
+FILES_${PN} = "${bindir} \
+ ${datadir}/matchbox \
+ ${sysconfdir}/matchbox \
+ ${datadir}/themes/blondie/matchbox \
+ ${datadir}/themes/Default/matchbox \
+ ${datadir}/themes/MBOpus/matchbox"
+
+ALTERNATIVE_NAME = "x-window-manager"
+ALTERNATIVE_LINK = "${bindir}/x-window-manager"
+ALTERNATIVE_PATH = "${bindir}/matchbox-session"
+ALTERNATIVE_PRIORITY = "10"
+
+EXTRA_OECONF = " --enable-startup-notification --disable-xrm"
+
+do_install_prepend() {
+ install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig
+}
+