summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCliff Brake <cbrake@bec-systems.com>2007-09-26 21:40:22 +0000
committerCliff Brake <cbrake@bec-systems.com>2007-09-26 21:40:22 +0000
commit6de3b616092096268d10094576dba7c902210d5c (patch)
tree42fd22bc3e28044b913b2aa8d0f09fdd7b6755c0
parent23fdb357ff8b1ce2c629bef826bc32c027fb1932 (diff)
compulab-pxa270 2.6.22: add kernel cmdline for jffs2 rootfs
note, this still works with the initramfs as well as the initramfs will always be mounted if present
-rw-r--r--conf/machine/compulab-pxa270.conf3
-rw-r--r--packages/linux/compulab-pxa270-2.6.22/defconfig2
-rw-r--r--packages/linux/compulab-pxa270_2.6.22.bb2
3 files changed, 5 insertions, 2 deletions
diff --git a/conf/machine/compulab-pxa270.conf b/conf/machine/compulab-pxa270.conf
index 1b802890b1..ff0eb42a11 100644
--- a/conf/machine/compulab-pxa270.conf
+++ b/conf/machine/compulab-pxa270.conf
@@ -52,5 +52,8 @@ MACHINE_FEATURES = "kernel26 pcmcia usbhost usbgadget pcmcia touchscreen alsa"
# now, when you build the image, a cpio.gz will be generated
# that can be used as an initramfs. You can boot into this image and then
# program the main rootfs jffs2 image in NAND flash using mtd-utils
+# you can select booting the initramfs, or the main nand rootfs by using
+# the "ramdisk on", or "ramdisk off" commands in the bootloader
+#
diff --git a/packages/linux/compulab-pxa270-2.6.22/defconfig b/packages/linux/compulab-pxa270-2.6.22/defconfig
index be9f10220a..63bc69533f 100644
--- a/packages/linux/compulab-pxa270-2.6.22/defconfig
+++ b/packages/linux/compulab-pxa270-2.6.22/defconfig
@@ -220,7 +220,7 @@ CONFIG_ALIGNMENT_TRAP=y
#
CONFIG_ZBOOT_ROM_TEXT=0x0
CONFIG_ZBOOT_ROM_BSS=0x0
-CONFIG_CMDLINE="console=ttyS1,38400 monitor=8 bpp=16 mem=64M mtdparts=physmap-flash.0:256k(boot)ro,0x180000(kernel),-(root);cm-x270-nand:64m(app),-(data) rdinit=/sbin/init"
+CONFIG_CMDLINE="console=ttyS1,38400 monitor=8 bpp=16 mem=64M mtdparts=physmap-flash.0:256k(boot)ro,0x180000(kernel),-(root);cm-x270-nand:64m(app),-(data) rdinit=/sbin/init root=mtd3 rootfstype=jffs2"
# CONFIG_XIP_KERNEL is not set
# CONFIG_KEXEC is not set
diff --git a/packages/linux/compulab-pxa270_2.6.22.bb b/packages/linux/compulab-pxa270_2.6.22.bb
index 080ee5f3ef..86a7626d8a 100644
--- a/packages/linux/compulab-pxa270_2.6.22.bb
+++ b/packages/linux/compulab-pxa270_2.6.22.bb
@@ -30,7 +30,7 @@ S = "${WORKDIR}/linux-${PV}"
COMPATIBLE_HOST = 'arm.*-linux'
COMPATIBLE_MACHINE = "compulab-pxa270"
-CMDLINE = "console=${CMX270_CONSOLE_SERIAL_PORT},38400 monitor=8 bpp=16 mem=64M mtdparts=physmap-flash.0:256k(boot)ro,0x180000(kernel),-(root);cm-x270-nand:64m(app),-(data) rdinit=/sbin/init"
+CMDLINE = "console=${CMX270_CONSOLE_SERIAL_PORT},38400 monitor=8 bpp=16 mem=64M mtdparts=physmap-flash.0:256k(boot)ro,0x180000(kernel),-(root);cm-x270-nand:64m(app),-(data) rdinit=/sbin/init root=mtd3 rootfstype=jffs2"
inherit kernel
inherit package