summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2009-10-27 11:28:26 +0100
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2009-10-27 11:28:26 +0100
commit592aec1153c15c489509ed2269c6b60f6ada6f9c (patch)
treed20151e458e881040fe55d31353a4ff6b70b591a
parent03ed4b979cca721ad0e0febaee358a80ff8e44fc (diff)
parentdfa6b034ba29c9c5419f461c0646d7a86cf55dc5 (diff)
Merge branch 'org.openembedded.dev' of git.openembedded.org:openembedded into org.openembedded.dev
-rw-r--r--classes/package.bbclass7
-rw-r--r--conf/bitbake.conf8
-rw-r--r--conf/checksums.ini4
-rw-r--r--conf/distro/angstrom-2008.1.conf2
-rw-r--r--conf/distro/include/angstrom-eglibc.inc2
-rw-r--r--conf/distro/include/angstrom-glibc.inc5
-rw-r--r--conf/distro/include/angstrom-ldflags.inc26
-rw-r--r--recipes/bison/bison_2.3.bb10
-rw-r--r--recipes/flex/flex.inc6
-rw-r--r--recipes/flex/flex_2.5.31.bb2
-rw-r--r--recipes/glibc/glibc-package.bbclass6
-rw-r--r--recipes/libsdl/ballfield_1.0.bb2
-rw-r--r--recipes/libxml/libxml2.inc13
-rw-r--r--recipes/libxml/libxml2_2.7.3.bb2
-rw-r--r--recipes/netbase/netbase/igep0020/interfaces5
-rw-r--r--recipes/netbase/netbase_4.21.bb2
-rw-r--r--recipes/tzcode/tzcode-native_2009k.bb4
-rw-r--r--recipes/xorg-xserver/xserver-xorg-conf/igep0020/xorg.conf29
-rw-r--r--recipes/xorg-xserver/xserver-xorg-conf_0.1.bb2
19 files changed, 117 insertions, 20 deletions
diff --git a/classes/package.bbclass b/classes/package.bbclass
index 046351a415..7a9b987c7c 100644
--- a/classes/package.bbclass
+++ b/classes/package.bbclass
@@ -159,7 +159,7 @@ def runstrip(file, d):
if ret:
bb.error("runstrip: 'file %s' failed (forced strip)" % file)
- if "not stripped" not in result and not file.endswith(".a"):
+ if "not stripped" not in result:
bb.debug(1, "runstrip: skip %s" % file)
return 0
@@ -183,6 +183,9 @@ def runstrip(file, d):
extraflags = "--remove-section=.comment --remove-section=.note --strip-unneeded"
elif "shared" in result or "executable" in result:
extraflags = "--remove-section=.comment --remove-section=.note"
+ elif file.endswith(".a"):
+ extraflags = "--remove-section=.comment --strip-debug"
+
bb.mkdirhier(os.path.join(os.path.dirname(file), ".debug"))
debugfile=os.path.join(os.path.dirname(file), ".debug", os.path.basename(file))
@@ -393,7 +396,7 @@ python populate_packages () {
for root, dirs, files in os.walk(dvar):
for f in files:
file = os.path.join(root, f)
- if not os.path.islink(file) and not os.path.isdir(file) and (isexec(file) or ".a" in file):
+ if not os.path.islink(file) and not os.path.isdir(file) and isexec(file):
runstrip(file, d)
pkgdest = bb.data.getVar('PKGDEST', d, 1)
diff --git a/conf/bitbake.conf b/conf/bitbake.conf
index 7426095ba0..cb647b9640 100644
--- a/conf/bitbake.conf
+++ b/conf/bitbake.conf
@@ -207,7 +207,7 @@ SOLIBSDEV_darwin = ".dylib"
SOLIBSDEV_darwin8 = ".dylib"
SOLIBSDEV_darwin9 = ".dylib"
-PACKAGES = "${PN}-dbg ${PN} ${PN}-doc ${PN}-dev ${PN}-locale"
+PACKAGES = "${PN}-dbg ${PN} ${PN}-doc ${PN}-dev ${PN}-static ${PN}-locale"
#enable this when bitbake is upgraded to cope with ++ values in the field
PACKAGES_DYNAMIC = "${PN}-locale-*"
FILES = ""
@@ -225,9 +225,11 @@ FILES_${PN}-doc = "${docdir} ${mandir} ${infodir} ${datadir}/gtk-doc \
${datadir}/gnome/help"
SECTION_${PN}-doc = "doc"
+FILES_${PN}-static = "${libdir}/*.a ${base_libdir}/*.a"
+
FILES_${PN}-dev = "${includedir} ${libdir}/lib*${SOLIBSDEV} ${libdir}/*.la \
- ${libdir}/*.a ${libdir}/*.o ${libdir}/pkgconfig \
- ${base_libdir}/*.a ${base_libdir}/*.o ${datadir}/aclocal ${datadir}/pkgconfig"
+ ${libdir}/*.o ${libdir}/pkgconfig \
+ ${base_libdir}/*.o ${datadir}/aclocal ${datadir}/pkgconfig"
SECTION_${PN}-dev = "devel"
ALLOW_EMPTY_${PN}-dev = "1"
RDEPENDS_${PN}-dev = "${PN} (= ${EXTENDPV})"
diff --git a/conf/checksums.ini b/conf/checksums.ini
index ec2947d145..49e1a29ca3 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -23894,6 +23894,10 @@ sha256=ec3159feae5324e78f7fc09f8f534bd6a3e7ed735144ee8a8e9e7871e77115e0
md5=c252e5286b142afa54ca49829c51a33f
sha256=ec3159feae5324e78f7fc09f8f534bd6a3e7ed735144ee8a8e9e7871e77115e0
+[http://downloads.sourceforge.net/squashfs/squashfs3.3.tar.gz]
+md5=62d3ff7c067a5aa82f57711b3a4ab86a
+sha256=496049c7e5fd361d8fec814ee05005591380bbcb03a565957b78161cdefe84e5
+
[http://downloads.sourceforge.net/squashfs/squashfs3.3.tgz]
md5=95c40fca0d886893631b5de14a0af25b
sha256=8423027a1e7dc238d27ec227f47ce22d1317b4c9a0a9ee49a38b6e6f8da8a5c8
diff --git a/conf/distro/angstrom-2008.1.conf b/conf/distro/angstrom-2008.1.conf
index 4b601b2409..2d1ed17c5d 100644
--- a/conf/distro/angstrom-2008.1.conf
+++ b/conf/distro/angstrom-2008.1.conf
@@ -74,7 +74,7 @@ PREFERRED_VERSION_linux-handhelds-2.6 ?= "2.6.21-hh20"
#KERNEL_INITRAMFS_PATH = "${KERNEL_INITRAMFS_DIR}/$(readlink ${KERNEL_INITRAMFS_DIR}initramfs-bootmenu-image-${MACHINE}.cpio.gz)"
#This is unrelated to the kernel version, but userspace apps (e.g. HAL) require a recent version to build against
-PREFERRED_VERSION_linux-libc-headers = "2.6.23"
+PREFERRED_VERSION_linux-libc-headers = "2.6.31"
#Prefer glibc 2.6 and uclibc 0.9.30, these have had the most testing.
PREFERRED_VERSION_glibc ?= "2.9"
diff --git a/conf/distro/include/angstrom-eglibc.inc b/conf/distro/include/angstrom-eglibc.inc
index e85b0b8132..69a5b23111 100644
--- a/conf/distro/include/angstrom-eglibc.inc
+++ b/conf/distro/include/angstrom-eglibc.inc
@@ -15,7 +15,7 @@ TARGET_OS .= "${@['','-gnuspe'][bb.data.getVar('TARGET_ARCH',d,1) in ['ppc', 'po
# perl has some problems, see http://bugs.openembedded.net/show_bug.cgi?id=1616
# [23:00] oxo: glibc (any version) on sparc does not like (repeat me) "-Os"
-FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2 -ggdb3"
+FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -Os -ggdb3"
FULL_OPTIMIZATION_pn-perl = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O1"
FULL_OPTIMIZATION_sparc = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
diff --git a/conf/distro/include/angstrom-glibc.inc b/conf/distro/include/angstrom-glibc.inc
index 183f0c1d18..c8607c6001 100644
--- a/conf/distro/include/angstrom-glibc.inc
+++ b/conf/distro/include/angstrom-glibc.inc
@@ -11,7 +11,7 @@ TARGET_OS .= "${@['','-gnueabi'][bb.data.getVar('TARGET_ARCH',d,1) in ['arm', 'a
# perl has some problems, see http://bugs.openembedded.net/show_bug.cgi?id=1616
# [23:00] oxo: glibc (any version) on sparc does not like (repeat me) "-Os"
-FULL_OPTIMIZATION = "-fexpensive-optimizations -frename-registers -fomit-frame-pointer -O2 -ggdb3"
+FULL_OPTIMIZATION = "-fexpensive-optimizations -frename-registers -fomit-frame-pointer -Os -ggdb3"
FULL_OPTIMIZATION_pn-perl = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O1"
FULL_OPTIMIZATION_pn-glibc = "-fexpensive-optimizations -fomit-frame-pointer -O2"
@@ -24,5 +24,8 @@ BUILD_OPTIMIZATION_pn-perl-native = "-O1 -g"
TARGET_LINK_HASH_STYLE = "${@['-Wl,--hash-style=gnu',''][bb.data.getVar('TARGET_ARCH',d,1) in ['mips', 'mipsel']]}"
+# Disable -Wl,as-needed for now till all the test come back OK
+#require conf/distro/include/angstrom-ldflags.inc
+
CXXFLAGS += "-fvisibility-inlines-hidden"
diff --git a/conf/distro/include/angstrom-ldflags.inc b/conf/distro/include/angstrom-ldflags.inc
new file mode 100644
index 0000000000..6c60568798
--- /dev/null
+++ b/conf/distro/include/angstrom-ldflags.inc
@@ -0,0 +1,26 @@
+
+# Set as-need to an intermediate var...
+ASNEEDED = "-Wl,--as-needed"
+
+# ...so we can blacklist it for recipes that break with it
+ASNEEDED_pn-console-tools = ""
+ASNEEDED_pn-distcc = ""
+ASNEEDED_pn-openobex = ""
+ASNEEDED_pn-icu = ""
+ASNEEDED_pn-xserver-kdrive-xomap = ""
+ASNEEDED_pn-minimo = ""
+ASNEEDED_pn-pciutils = ""
+ASNEEDED_pn-puzzles = ""
+ASNEEDED_pn-dialer = ""
+ASNEEDED_pn-pulseaudio = ""
+ASNEEDED_pn-python = ""
+ASNEEDED_pn-libproxy = ""
+ASNEEDED_pn-libxsettings-client = ""
+ASNEEDED_pn-libmatchbox = ""
+ASNEEDED_pn-faac = ""
+ASNEEDED_pn-wireless-tools = ""
+ASNEEDED_pn-ffmpeg = ""
+
+# Append it to TARGET_LDLFLAGS
+TARGET_LDFLAGS += "${ASNEEDED}"
+
diff --git a/recipes/bison/bison_2.3.bb b/recipes/bison/bison_2.3.bb
index edf549f442..729756b0fd 100644
--- a/recipes/bison/bison_2.3.bb
+++ b/recipes/bison/bison_2.3.bb
@@ -4,7 +4,17 @@ LICENSE = "GPL"
SECTION = "devel"
PRIORITY = "optional"
+PR = "r1"
+
SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.gz \
file://m4.patch;patch=1"
inherit autotools
+
+# >> bison-2.3-r0: /usr/lib/liby.a
+# That one is a special case: it wants to stay in the main bison package,
+# since bison itself is a development tool. I'm not sure why it is a
+# static-only library; that might be an error.
+
+FILES_${PN} += "${libdir}/liby.a"
+
diff --git a/recipes/flex/flex.inc b/recipes/flex/flex.inc
index 048b3cb47d..4ebd44a61b 100644
--- a/recipes/flex/flex.inc
+++ b/recipes/flex/flex.inc
@@ -9,3 +9,9 @@ S = "${WORKDIR}/flex-${PV}"
inherit autotools
+# >> flex-2.5.31-r4: /usr/lib/libfl.a
+# That one is a special case: it wants to stay in the main flex package,
+# since flex itself is a development tool. I'm not sure why it is a
+# static-only library; that might be an error
+
+FILES_${PN} += "${libdir}/libfl.a"
diff --git a/recipes/flex/flex_2.5.31.bb b/recipes/flex/flex_2.5.31.bb
index 3062e2d8dc..e247a03ee8 100644
--- a/recipes/flex/flex_2.5.31.bb
+++ b/recipes/flex/flex_2.5.31.bb
@@ -1,5 +1,5 @@
require flex.inc
-PR = "r4"
+PR = "r5"
SRC_URI += "file://include.patch;patch=1"
diff --git a/recipes/glibc/glibc-package.bbclass b/recipes/glibc/glibc-package.bbclass
index 1d7f5cd309..179e41f734 100644
--- a/recipes/glibc/glibc-package.bbclass
+++ b/recipes/glibc/glibc-package.bbclass
@@ -29,7 +29,7 @@ BINARY_LOCALE_ARCHES ?= "arm.* i[3-6]86 x86_64 powerpc"
# Set this to zero if you don't want ldconfig in the output package
USE_LDCONFIG ?= "1"
-PACKAGES = "glibc-dbg glibc catchsegv sln nscd ldd localedef glibc-utils glibc-dev glibc-doc glibc-locale libsegfault glibc-extra-nss glibc-thread-db glibc-pcprofile"
+PACKAGES = "glibc-dbg glibc catchsegv sln nscd ldd localedef glibc-utils glibc-dev glibc-static glibc-doc glibc-locale libcidn libmemusage libsegfault glibc-extra-nss glibc-thread-db glibc-pcprofile"
PACKAGES_DYNAMIC = "glibc-gconv-* glibc-charmap-* glibc-localedata-* locale-base-* glibc-binary-localedata-*"
INSANE_SKIP_glibc-dbg = True
@@ -39,9 +39,11 @@ libc_baselibs = "${base_libdir}/libcrypt*.so.* ${base_libdir}/libcrypt-*.so ${ba
FILES_${PN} = "${libc_baselibs} ${libexecdir}/* ${datadir}/zoneinfo ${@base_conditional('USE_LDCONFIG', '1', '${base_sbindir}/ldconfig', '', d)}"
FILES_ldd = "${bindir}/ldd"
FILES_libsegfault = "${base_libdir}/libSegFault*"
+FILES_libcidn = "${base_libdir}/libcidn*.so"
+FILES_libmemusage = "${base_libdir}/libmemusage.so"
FILES_glibc-extra-nss = "${base_libdir}/libnss*"
FILES_sln = "${base_sbindir}/sln"
-FILES_glibc-dev_append = " ${libdir}/*.o ${bindir}/rpcgen"
+FILES_glibc-dev_append = " ${libdir}/*.o ${bindir}/rpcgen ${libdir}/*nonshared.a"
FILES_nscd = "${sbindir}/nscd* ${sysconfdir}/nscd* ${sysconfdir}/init.d/nscd*"
FILES_glibc-utils = "${bindir}/* ${sbindir}/*"
FILES_glibc-gconv = "${libdir}/gconv/*"
diff --git a/recipes/libsdl/ballfield_1.0.bb b/recipes/libsdl/ballfield_1.0.bb
index 9b44be5516..9cb361add2 100644
--- a/recipes/libsdl/ballfield_1.0.bb
+++ b/recipes/libsdl/ballfield_1.0.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "This is a cute little "3D" sprite demo using SDL and SDL_image."
-DEPENDS = "vrtual/libsdl libsdl-image"
+DEPENDS = "virtual/libsdl libsdl-image"
LICENSE = "GPLv2"
SRC_URI = "http://olofson.net/download/ballfield-${PV}.tar.gz"
diff --git a/recipes/libxml/libxml2.inc b/recipes/libxml/libxml2.inc
index f7ecaff977..bc31123e7c 100644
--- a/recipes/libxml/libxml2.inc
+++ b/recipes/libxml/libxml2.inc
@@ -5,6 +5,8 @@ LICENSE = "MIT"
SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz"
+PR = "r1"
+
inherit autotools pkgconfig binconfig
EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-catalog --without-docbook --with-c14n"
@@ -23,7 +25,14 @@ do_stage() {
DEBIANNAME_${PN} = "libxml2"
-PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
+PACKAGES =+ "${PN}-utils"
+FILES_${PN} = "${libexecdir}/* ${libdir}/lib*${SOLIBS} \
+ ${sysconfdir} ${sharedstatedir} ${localstatedir} \
+ ${base_libdir}/*${SOLIBS} \
+ ${datadir}/${PN} ${libdir}/${PN}/* \
+ ${datadir}/pixmaps ${datadir}/applications \
+ ${datadir}/idl ${datadir}/omf ${datadir}/sounds \
+ ${libdir}/bonobo/servers"
FILES_${PN}-dev += "${bindir}/*-config"
-FILES_${PN}-utils += "${bindir}/* ${libdir}/*.sh"
+FILES_${PN}-utils = "${bindir}/xmllint ${bindir}/xmlcatalog ${libdir}/*.sh"
diff --git a/recipes/libxml/libxml2_2.7.3.bb b/recipes/libxml/libxml2_2.7.3.bb
index 555a436a63..fa80f36f2f 100644
--- a/recipes/libxml/libxml2_2.7.3.bb
+++ b/recipes/libxml/libxml2_2.7.3.bb
@@ -1,4 +1,2 @@
require libxml2.inc
-PR = "r0"
-
diff --git a/recipes/netbase/netbase/igep0020/interfaces b/recipes/netbase/netbase/igep0020/interfaces
new file mode 100644
index 0000000000..d7409f7a64
--- /dev/null
+++ b/recipes/netbase/netbase/igep0020/interfaces
@@ -0,0 +1,5 @@
+# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
+
+# The loopback interface
+auto lo
+iface lo inet loopback
diff --git a/recipes/netbase/netbase_4.21.bb b/recipes/netbase/netbase_4.21.bb
index 403ca191b1..0ce40ba93e 100644
--- a/recipes/netbase/netbase_4.21.bb
+++ b/recipes/netbase/netbase_4.21.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "This package provides the necessary \
infrastructure for basic TCP/IP based networking."
SECTION = "base"
LICENSE = "GPL"
-PR = "r38"
+PR = "r39"
inherit update-rc.d
diff --git a/recipes/tzcode/tzcode-native_2009k.bb b/recipes/tzcode/tzcode-native_2009k.bb
index 868b85418d..632dc8456d 100644
--- a/recipes/tzcode/tzcode-native_2009k.bb
+++ b/recipes/tzcode/tzcode-native_2009k.bb
@@ -1,5 +1,5 @@
require tzcode-native.inc
SRC_URI = "ftp://elsie.nci.nih.gov/pub/tzcode${PV}.tar.gz \
- ftp://elsie.nci.nih.gov/pub/tzdata2009o.tar.gz \
+ ftp://elsie.nci.nih.gov/pub/tzdata2009p.tar.gz \
"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
diff --git a/recipes/xorg-xserver/xserver-xorg-conf/igep0020/xorg.conf b/recipes/xorg-xserver/xserver-xorg-conf/igep0020/xorg.conf
new file mode 100644
index 0000000000..07d849d705
--- /dev/null
+++ b/recipes/xorg-xserver/xserver-xorg-conf/igep0020/xorg.conf
@@ -0,0 +1,29 @@
+Section "Module"
+ Load "extmod"
+ Load "dbe"
+ Load "glx"
+ Load "freetype"
+ Load "type1"
+ Load "record"
+ Load "dri"
+EndSection
+
+Section "Monitor"
+ Identifier "Builtin Default Monitor"
+EndSection
+
+Section "Device"
+ Identifier "Builtin Default fbdev Device 0"
+ Driver "omapfb"
+EndSection
+
+Section "Screen"
+ Identifier "Builtin Default fbdev Screen 0"
+ Device "Builtin Default fbdev Device 0"
+ Monitor "Builtin Default Monitor"
+EndSection
+
+Section "ServerLayout"
+ Identifier "Builtin Default Layout"
+ Screen "Builtin Default fbdev Screen 0"
+EndSection
diff --git a/recipes/xorg-xserver/xserver-xorg-conf_0.1.bb b/recipes/xorg-xserver/xserver-xorg-conf_0.1.bb
index ba52376ab2..37d200ba5d 100644
--- a/recipes/xorg-xserver/xserver-xorg-conf_0.1.bb
+++ b/recipes/xorg-xserver/xserver-xorg-conf_0.1.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "Machine specific xorg.conf files"
-PR = "r11"
+PR = "r12"
SRC_URI = "file://xorg.conf"