summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-04-11 21:44:18 +0200
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-04-11 21:44:18 +0200
commit4db359fb370677be69bb5fca32472f3b3da16bae (patch)
treee9f7d77f08397375bc98d4ab9a1083b067eeae80
parentfd0465c4d55f65735287b3ad5435acca0809e28b (diff)
parent3c109747dee974b2076aa8dd5bb25194aaec6201 (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
-rw-r--r--recipes/freesmartphone/cornucopia.inc15
-rw-r--r--recipes/freesmartphone/enter_0.0.2.bb10
-rw-r--r--recipes/freesmartphone/fsodeviced_git.bb15
-rw-r--r--recipes/freesmartphone/fsogsmd_git.bb2
-rw-r--r--recipes/freesmartphone/libfsoframework_git.bb16
-rw-r--r--recipes/freesmartphone/pylgrim_svn.bb25
6 files changed, 20 insertions, 63 deletions
diff --git a/recipes/freesmartphone/cornucopia.inc b/recipes/freesmartphone/cornucopia.inc
new file mode 100644
index 0000000000..c3bf018369
--- /dev/null
+++ b/recipes/freesmartphone/cornucopia.inc
@@ -0,0 +1,15 @@
+DESCRIPTION = "The freesmartphone.org API reference implementation (FSO 2.0)"
+AUTHOR = "Team FSO"
+LICENSE = "LGPL"
+SECTION = "devel"
+DEPENDS = "vala-native glib-2.0 dbus dbus-glib"
+PV = "0.0.0.0+gitr${SRCREV}"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/cornucopia;protocol=git;branch=master"
+S = "${WORKDIR}/git/${PN}"
+
+inherit autotools_stage pkgconfig vala
+
+FILES_${PN} += "${sysconfdir} ${datadir}"
+# ship vapi files
+FILES_${PN}-dev += "${datadir}/vala"
diff --git a/recipes/freesmartphone/enter_0.0.2.bb b/recipes/freesmartphone/enter_0.0.2.bb
deleted file mode 100644
index 2a51af6506..0000000000
--- a/recipes/freesmartphone/enter_0.0.2.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-DESCRIPTION = "An easy-to-use virtual keyboard for small touchscreen displays"
-SECTION = "openmoko/inputmethods"
-DEPENDS = "ecore evas edje"
-PR = "r0"
-
-inherit autotools
-
-SRC_URI = "http://gstaedtner.net/projects/enter/enter.tar.gz"
-
-FILES_${PN} += "${datadir}"
diff --git a/recipes/freesmartphone/fsodeviced_git.bb b/recipes/freesmartphone/fsodeviced_git.bb
index 4cb61c7c29..cb3e1586db 100644
--- a/recipes/freesmartphone/fsodeviced_git.bb
+++ b/recipes/freesmartphone/fsodeviced_git.bb
@@ -1,13 +1,2 @@
-DESCRIPTION = "Reference implementation of the org.freesmartphone.Device.* APIs"
-SECTION = "console/network"
-DEPENDS = "libfsoframework"
-LICENSE = "GPL"
-PV = "0.0.0.0+gitr${SRCREV}"
-PR = "r0"
-
-SRC_URI = "\
- ${FREESMARTPHONE_GIT}/cornucopia;protocol=git;branch=master \
-"
-S = "${WORKDIR}/git/fsodeviced"
-
-inherit autotools fso-plugin vala
+require cornucopia.inc
+inherit fso-plugin
diff --git a/recipes/freesmartphone/fsogsmd_git.bb b/recipes/freesmartphone/fsogsmd_git.bb
new file mode 100644
index 0000000000..cb3e1586db
--- /dev/null
+++ b/recipes/freesmartphone/fsogsmd_git.bb
@@ -0,0 +1,2 @@
+require cornucopia.inc
+inherit fso-plugin
diff --git a/recipes/freesmartphone/libfsoframework_git.bb b/recipes/freesmartphone/libfsoframework_git.bb
index 7b03e17041..2fb01bfeb2 100644
--- a/recipes/freesmartphone/libfsoframework_git.bb
+++ b/recipes/freesmartphone/libfsoframework_git.bb
@@ -1,17 +1,3 @@
+require cornucopia.inc
DESCRIPTION = "freesmartphone.org support library"
-LICENSE = "GPL"
-SECTION = "devel"
-DEPENDS = "vala-native glib-2.0 dbus dbus-glib"
-PV = "0.0.0.0+gitr${SRCREV}"
-PR = "r0"
-SRC_URI = "\
- ${FREESMARTPHONE_GIT}/cornucopia;protocol=git;branch=master \
-"
-S = "${WORKDIR}/git/libfsoframework"
-
-inherit autotools_stage pkgconfig
-
-FILES_${PN} += "${sysconfdir} ${datadir}"
-# ship vapi files
-FILES_${PN}-dev += "${datadir}/vala"
diff --git a/recipes/freesmartphone/pylgrim_svn.bb b/recipes/freesmartphone/pylgrim_svn.bb
deleted file mode 100644
index beeb44c110..0000000000
--- a/recipes/freesmartphone/pylgrim_svn.bb
+++ /dev/null
@@ -1,25 +0,0 @@
-DESCRIPTION = "A GPS moving map application featuring OpenStreetMap tiles"
-HOMEPAGE = "http://neo1973-germany.de/wiki/pylgrim"
-AUTHOR = "Josch"
-LICENSE = "GPL"
-SECTION = "x11/navigation"
-DEPENDS = "edje-native"
-RDEPENDS = "task-python-efl python-textutils"
-PV = "0.0+svnr${SRCREV}"
-PE = "1"
-
-SRC_URI = "svn://neo1973-germany.de/svn;module=pylgrim;proto=http"
-S = "${WORKDIR}/pylgrim"
-
-do_compile() {
- edje_cc pylgrim.edc
-}
-
-do_install() {
- install -d ${D}${datadir}/pylgrim
- for i in *.py pylgrim.edj; do
- install -m 0755 $i ${D}${datadir}/pylgrim/
- done
-}
-
-FILES_${PN} += "${datadir}"