summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2005-09-01 21:46:29 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-01 21:46:29 +0000
commit4b5b3211cb2800932411d26f0daa271859a0417a (patch)
treeb3e7e38af8c4e0cb389e43841677f5d9d94827c4
parent5638e03ebf55374a57a9996c2289001d79803f55 (diff)
parente22b40e0fef7e2f645282058937453b839aac113 (diff)
merge of 6dd4b1d7e7f2b41926f77732f5d5ea0320d125e7
and c0acc534da9ee6ea1b4881cb97790ae7dadee8e8
-rw-r--r--packages/efl/esmart.inc2
-rw-r--r--packages/zd1211/zd1211_20050822.bb31
2 files changed, 32 insertions, 1 deletions
diff --git a/packages/efl/esmart.inc b/packages/efl/esmart.inc
index f4a5191462..c93ebc233b 100644
--- a/packages/efl/esmart.inc
+++ b/packages/efl/esmart.inc
@@ -41,4 +41,4 @@ DEPENDS_libesmart-container += "libesmart-container-plugins"
FILES_libesmart-container-plugins = "${libdir}/esmart/layout/*.so"
FILES_libesmart-file-dialog = "${libdir}/libesmart_file_dialog*.so*"
FILES_libesmart-draggies = "${libdir}/libesmart_draggies*.so*"
-FILES_libesarmt-trans-x11 = "${libdir}/libesmart_trans_x11*.so*"
+FILES_libesmart-trans-x11 = "${libdir}/libesmart_trans_x11*.so*"
diff --git a/packages/zd1211/zd1211_20050822.bb b/packages/zd1211/zd1211_20050822.bb
new file mode 100644
index 0000000000..3b01d8e317
--- /dev/null
+++ b/packages/zd1211/zd1211_20050822.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Driver for zd1211 family of wireless USB Dongles"
+PRIORITY = "optional"
+SECTION = "kernel/modules"
+MAINTAINER = "dyoung <dyoung8888@yahoo.com>"
+LICENSE = "GPL"
+PR = "r0"
+DEPENDS = "wireless-tools"
+
+SRC_URI = "http://download.sourceforge.net/zd1211/sf_zd1211_${PV}_src.tar.gz"
+
+S = "${WORKDIR}/zd1211"
+
+inherit module
+
+#do_compile_prepend() {
+# cp -f ${WORKDIR}/Makefile ${S}/
+#}
+
+do_compile () {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS CC LD CPP
+ oe_runmake 'KSRC=${STAGING_KERNEL_DIR}' \
+ 'KDIR=${STAGING_KERNEL_DIR}' \
+ 'CC="${KERNEL_CC}"' \
+ 'LD="${KERNEL_LD}"'
+}
+
+do_install() {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net
+ install -m 0644 ${S}/src/modules-${KERNEL_VERSION}/*${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net
+}
+