summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael-Luke Jones <mlj28@cam.ac.uk>2006-09-23 15:39:33 +0000
committerMichael-Luke Jones <mlj28@cam.ac.uk>2006-09-23 15:39:33 +0000
commit485a502c12c532d75c1ebad24cf04c28e0357cc3 (patch)
tree260ae3bfd91c5f320a0e4b4f91a392fa21e81235
parentc26ac145260f540095b52036dac1bdfb4b5e5c8b (diff)
SlugOS Distro & Image Files: Major changes
* Update to kernel version 2.6.18 (new build system) * Change from udev to mdev to handle /dev and hotplug events (slugos-image.bb) * Update to include necessary kernel modules post-modularisation (conf/distro/*)
-rw-r--r--conf/distro/debianslug.conf25
-rw-r--r--conf/distro/include/slugos.inc8
-rw-r--r--conf/distro/openslug.conf25
-rw-r--r--packages/images/slugos-image.bb8
4 files changed, 55 insertions, 11 deletions
diff --git a/conf/distro/debianslug.conf b/conf/distro/debianslug.conf
index da80210b8f..ed39440661 100644
--- a/conf/distro/debianslug.conf
+++ b/conf/distro/debianslug.conf
@@ -87,6 +87,31 @@ kernel-module-nls-cp437 \
kernel-module-nls-utf8 \
"
+# Add modules required for firmware loading
+DEBIANSLUG_STANDARD_RDEPENDS += "\
+kernel-module-firmware-class \
+"
+
+# Add module to create i2c chardev
+DEBIANSLUG_STANDARD_RDEPENDS += "\
+kernel-module-i2c-dev \
+"
+
+# Add module required for HW RNG support
+DEBIANSLUG_STANDARD_RDEPENDS += "\
+kernel-module-ixp4xx-rng \
+"
+
+# Add modules required for usb support
+DEBIANSLUG_STANDARD_RDEPENDS += "\
+kernel-module-usbcore \
+kernel-module-ohci-hcd \
+kernel-module-ehci-hcd \
+kernel-module-uhci-hcd \
+kernel-module-scsi-mod \
+kernel-module-usb-storage \
+"
+
# This documents other file systems which are built but not installed
# by default in the flash image.
#
diff --git a/conf/distro/include/slugos.inc b/conf/distro/include/slugos.inc
index 5e7947f866..3993bf6ec0 100644
--- a/conf/distro/include/slugos.inc
+++ b/conf/distro/include/slugos.inc
@@ -170,13 +170,7 @@ PREFERRED_VERSION_glibc ?= "2.3.5+cvs20050627"
# Select the correct versions of the kernel and modules (these are the
# defaults, override in the conf/distro top-level distro file).
PREFERRED_PROVIDER_virtual/kernel ?= "ixp4xx-kernel"
-PREFERRED_VERSION_ixp4xx-kernel ?= "2.6.17"
-
-# Built-in ethernet modules
-PREFERRED_PROVIDER_virtual/ixp-eth ?= "ixp400-eth"
-PREFERRED_VERSION_ixp4xx-csr ?= "2.1"
-PREFERRED_VERSION_ixp-osal ?= "2.1"
-PREFERRED_VERSION_ixp400-eth ?= "1.5"
+PREFERRED_VERSION_ixp4xx-kernel ?= "2.6.18"
# Select the smallest provider of x11 libraries
PREFERRED_PROVIDER_virtual/libx11 ?= "diet-x11"
diff --git a/conf/distro/openslug.conf b/conf/distro/openslug.conf
index 6af761e26e..7c8039b6da 100644
--- a/conf/distro/openslug.conf
+++ b/conf/distro/openslug.conf
@@ -87,6 +87,31 @@ kernel-module-nls-cp437 \
kernel-module-nls-utf8 \
"
+# Add modules required for firmware loading
+OPENSLUG_STANDARD_RDEPENDS += "\
+kernel-module-firmware-class \
+"
+
+# Add module to create i2c chardev
+OPENSLUG_STANDARD_RDEPENDS += "\
+kernel-module-i2c-dev \
+"
+
+# Add module required for HW RNG support
+OPENSLUG_STANDARD_RDEPENDS += "\
+kernel-module-ixp4xx-rng \
+"
+
+# Add modules required for usb support
+OPENSLUG_STANDARD_RDEPENDS += "\
+kernel-module-usbcore \
+kernel-module-ohci-hcd \
+kernel-module-ehci-hcd \
+kernel-module-uhci-hcd \
+kernel-module-scsi-mod \
+kernel-module-usb-storage \
+"
+
# This documents other file systems which are built but not installed
# by default in the flash image.
#
diff --git a/packages/images/slugos-image.bb b/packages/images/slugos-image.bb
index 7211c96580..7342a1e639 100644
--- a/packages/images/slugos-image.bb
+++ b/packages/images/slugos-image.bb
@@ -7,7 +7,7 @@ DESCRIPTION = "Generic SlugOS image"
MAINTAINER = "NSLU2 Linux <nslu2-linux@yahoogroups.com>"
HOMEPAGE = "http://www.nslu2-linux.org"
LICENSE = "MIT"
-PR = "r32"
+PR = "r34"
# SLUGOS_IMAGENAME defines the name of the image to be build, if it
# is not set this package will be skipped!
@@ -65,7 +65,7 @@ EXTRA_IMAGEDEPENDS += "${IMAGE_TOOLS}"
# udev is the default way of handling devices, there is no guarantee
# that the static device table is completely correct (it is just
# known to be sufficient for boot.)
-SLUGOS_SUPPORT ?= "diffutils cpio findutils udev"
+SLUGOS_SUPPORT ?= "diffutils cpio findutils busybox-mdev"
# kernel-module-af-packet must be in the image for DHCP to work
# kernel-module-netconsole is here because it is small and is
@@ -73,9 +73,9 @@ SLUGOS_SUPPORT ?= "diffutils cpio findutils udev"
# other than the network to output error messages!)
SLUGOS_KERNEL ?= "kernel-module-af-packet kernel-module-netconsole"
-RDEPENDS = "kernel ixp-eth \
+RDEPENDS = "kernel \
base-files base-passwd netbase \
- busybox hotplug-ng initscripts-slugos slugos-init \
+ busybox initscripts-slugos slugos-init \
update-modules sysvinit tinylogin \
module-init-tools modutils-initscripts \
ipkg-collateral ipkg ipkg-link \