summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2006-05-05 08:54:32 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-05 08:54:32 +0000
commit42b9347b3838185bc30dd8cba40035b346c844f7 (patch)
treed79bb8bb9a662c023013b0d1fe51866254d6913a
parentd3777c05942face0bbd7e2da5dfbb862f5d7978b (diff)
parent6de77d51375f042db0cb2c4e3c44f5895f4c7dff (diff)
merge of 184a2f969c1aae565fcc6649d5bc16c3f6b2e7b3
and fd64cee80d213fd5efaa0473b981ec7e226f3907
-rw-r--r--classes/base.bbclass2
-rw-r--r--conf/distro/slugos.conf2
-rw-r--r--packages/base-files/base-files_3.0.14.bb2
-rw-r--r--packages/gcc/gcc-csl-arm/gcc_optab_arm.patch95
-rw-r--r--packages/linux/handhelds-pxa-2.6_cvs.bb3
-rw-r--r--packages/meta/slugos-image.bb2
-rw-r--r--packages/qscintilla/files/.mtn2git_empty0
-rw-r--r--packages/qscintilla/files/no-external-lexers.patch24
-rw-r--r--packages/qscintilla/qscintilla_1.65-gpl-1.6.bb36
-rw-r--r--packages/visiscript/visiscript_0.4.3.bb36
-rw-r--r--packages/xlibs/libsm_X11R7.0-1.0.0.bb4
-rw-r--r--packages/xproto/xcb-proto_0.9.bb6
12 files changed, 204 insertions, 8 deletions
diff --git a/classes/base.bbclass b/classes/base.bbclass
index 1728b65709..6a9077d55a 100644
--- a/classes/base.bbclass
+++ b/classes/base.bbclass
@@ -196,7 +196,7 @@ oe_libinstall() {
# stop libtool using the final directory name for libraries
# in staging:
__runcmd rm -f $destpath/$libname.la
- __runcmd sed -e 's/^installed=yes$/installed=no/' -e '/^dependency_libs=/s,${WORKDIR}[[:alnum:]/\._+-]*/\([[:alnum:]\._+-]*\),${STAGING_LIBDIR}/\1,' $dotlai >$destpath/$libname.la
+ __runcmd sed -e 's/^installed=yes$/installed=no/' -e '/^dependency_libs=/s,${WORKDIR}[[:alnum:]/\._+-]*/\([[:alnum:]\._+-]*\),${STAGING_LIBDIR}/\1,g' $dotlai >$destpath/$libname.la
else
__runcmd install -m 0644 $dotlai $destpath/$libname.la
fi
diff --git a/conf/distro/slugos.conf b/conf/distro/slugos.conf
index acb055eb42..b1591efadd 100644
--- a/conf/distro/slugos.conf
+++ b/conf/distro/slugos.conf
@@ -36,7 +36,7 @@
#DISTRO_TYPE
# The following may be overridden to make sub-versions
-SLUGOS_VERSION = "3.6"
+SLUGOS_VERSION = "3.7"
DISTRO_REVISION ?= ""
DISTRO_VERSION ?= "${SLUGOS_VERSION}${DISTRO_REVISION}-${DISTRO_TYPE}"
# For release (only):
diff --git a/packages/base-files/base-files_3.0.14.bb b/packages/base-files/base-files_3.0.14.bb
index 25cb1b1bbe..8fec5b01d4 100644
--- a/packages/base-files/base-files_3.0.14.bb
+++ b/packages/base-files/base-files_3.0.14.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Miscellaneous files for the base system."
SECTION = "base"
PRIORITY = "required"
-PR = "r48"
+PR = "r49"
LICENSE = "GPL"
SRC_URI = " \
diff --git a/packages/gcc/gcc-csl-arm/gcc_optab_arm.patch b/packages/gcc/gcc-csl-arm/gcc_optab_arm.patch
new file mode 100644
index 0000000000..fa21b26554
--- /dev/null
+++ b/packages/gcc/gcc-csl-arm/gcc_optab_arm.patch
@@ -0,0 +1,95 @@
+ARM is the only architecture that has a helper function that returns
+an unbiased result. This fix is trivial enough that we can show it
+doesn't effect any of the other arches. Can we consider this a
+regression fix since it used to work until the helper was added :}
+
+Tested with no regressions on x86_64-pc-linux-gnu and arm-none-eabi.
+
+Cheers,
+Carlos.
+--
+Carlos O'Donell
+CodeSourcery
+carlos@codesourcery.com
+(650) 331-3385 x716
+
+gcc/
+
+2006-01-27 Carlos O'Donell <carlos@codesourcery.com>
+
+ * optabs.c (prepare_cmp_insn): If unbaised and unsigned then bias
+ the comparison routine return.
+
+gcc/testsuite/
+
+2006-01-27 Carlos O'Donell <carlos@codesourcery.com>
+
+ * gcc.dg/unsigned-long-compare.c: New test.
+
+Index: gcc/optabs.c
+===================================================================
+--- 1/gcc/optabs.c (revision 110300)
++++ 2/gcc/optabs.c (working copy)
+@@ -3711,18 +3711,24 @@
+ result = emit_library_call_value (libfunc, NULL_RTX, LCT_CONST_MAKE_BLOCK,
+ word_mode, 2, x, mode, y, mode);
+
++ /* There are two kinds of comparison routines. Biased routines
++ return 0/1/2, and unbiased routines return -1/0/1. Other parts
++ of gcc expect that the comparison operation is equivalent
++ to the modified comparison. For signed comparisons compare the
++ result against 1 in the unbiased case, and zero in the biased
++ case. For unsigned comparisons always compare against 1 after
++ biasing the unbased result by adding 1. This gives us a way to
++ represent LTU. */
+ *px = result;
+ *pmode = word_mode;
+- if (TARGET_LIB_INT_CMP_BIASED)
+- /* Integer comparison returns a result that must be compared
+- against 1, so that even if we do an unsigned compare
+- afterward, there is still a value that can represent the
+- result "less than". */
+- *py = const1_rtx;
+- else
++ *py = const1_rtx;
++
++ if (!TARGET_LIB_INT_CMP_BIASED)
+ {
+- *py = const0_rtx;
+- *punsignedp = 1;
++ if (*punsignedp)
++ *px = plus_constant (result, 1);
++ else
++ *py = const0_rtx;
+ }
+ return;
+ }
+Index: gcc/testsuite/gcc.dg/unsigned-long-compare.c
+===================================================================
+--- 1/gcc/testsuite/gcc.dg/unsigned-long-compare.c (revision 0)
++++ 2/gcc/testsuite/gcc.dg/unsigned-long-compare.c (revision 0)
+@@ -0,0 +1,24 @@
++/* Copyright (C) 2006 Free Software Foundation, Inc. */
++/* Contributed by Carlos O'Donell on 2006-01-27 */
++
++/* Test a division corner case where the expression simplifies
++ to a comparison, and the optab expansion is wrong. The optab
++ expansion emits a function whose return is unbiased and needs
++ adjustment. */
++/* Origin: Carlos O'Donell <carlos@codesourcery.com> */
++/* { dg-do run { target arm-*-*eabi* } } */
++/* { dg-options "" } */
++#include <stdlib.h>
++
++#define BIG_CONSTANT 0xFFFFFFFF80000000ULL
++
++int main (void)
++{
++ unsigned long long OneULL = 1ULL;
++ unsigned long long result;
++
++ result = OneULL / BIG_CONSTANT;
++ if (result)
++ abort ();
++ exit (0);
++}
diff --git a/packages/linux/handhelds-pxa-2.6_cvs.bb b/packages/linux/handhelds-pxa-2.6_cvs.bb
index 0423268abe..e7df211acb 100644
--- a/packages/linux/handhelds-pxa-2.6_cvs.bb
+++ b/packages/linux/handhelds-pxa-2.6_cvs.bb
@@ -3,14 +3,13 @@ DESCRIPTION = "handhelds.org Linux kernel for PXA based devices."
MAINTAINER = "Greg Gilbert <greg@treke.net>"
LICENSE = "GPL"
PV = "${K_MAJOR}.${K_MINOR}.${K_MICRO}-hh${HHV}+cvs${SRCDATE}"
-PR = "r1"
+PR = "r2"
#
COMPATIBLE_HOST = "arm.*-linux"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/handhelds-pxa-${PV}"
SRC_URI = "${HANDHELDS_CVS};module=linux/kernel26 \
- file://eabi-enums.patch;patch=1 \
file://defconfig"
S = "${WORKDIR}/kernel26"
diff --git a/packages/meta/slugos-image.bb b/packages/meta/slugos-image.bb
index 9434e5076f..428a48bc28 100644
--- a/packages/meta/slugos-image.bb
+++ b/packages/meta/slugos-image.bb
@@ -7,7 +7,7 @@ DESCRIPTION = "Generic SlugOS image"
MAINTAINER = "NSLU2 Linux <nslu2-linux@yahoogroups.com>"
HOMEPAGE = "http://www.nslu2-linux.org"
LICENSE = "MIT"
-PR = "r26"
+PR = "r28"
# SLUGOS_IMAGENAME defines the name of the image to be build, if it
# is not set this package will be skipped!
diff --git a/packages/qscintilla/files/.mtn2git_empty b/packages/qscintilla/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/qscintilla/files/.mtn2git_empty
diff --git a/packages/qscintilla/files/no-external-lexers.patch b/packages/qscintilla/files/no-external-lexers.patch
new file mode 100644
index 0000000000..5953043190
--- /dev/null
+++ b/packages/qscintilla/files/no-external-lexers.patch
@@ -0,0 +1,24 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- ../src/ExternalLexer.cpp~no-external-lexers
++++ ../src/ExternalLexer.cpp
+@@ -110,7 +110,7 @@
+ // Initialise some members...
+ first = NULL;
+ last = NULL;
+-
++#ifndef ZPATCH
+ // Load the DLL
+ lib = DynamicLibrary::Load(ModuleName);
+ if (lib->IsValid()) {
+@@ -155,6 +155,7 @@
+ }
+ }
+ }
++#endif
+ next = NULL;
+ }
+
diff --git a/packages/qscintilla/qscintilla_1.65-gpl-1.6.bb b/packages/qscintilla/qscintilla_1.65-gpl-1.6.bb
new file mode 100644
index 0000000000..1620ef62c5
--- /dev/null
+++ b/packages/qscintilla/qscintilla_1.65-gpl-1.6.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "Qt/Embedded bindings for the Scintilla source code editor component"
+SECTION = "opie/libs"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://www.mneuroth.de/privat/zaurus/qscintilla-${PV}_zaurus.tar.gz \
+ file://no-external-lexers.patch;patch=1;pnum=0"
+
+S = "${WORKDIR}/qscintilla-${PV}/qt"
+
+inherit opie
+
+QMAKE_PROFILES = "qscintilla.pro"
+
+EXTRA_QMAKEVARS_POST += "INCLUDEPATH+=${S}/patches \
+ DEFINES+=ZPATCH DEFINES+=ZAURUS \
+ HEADERS-=qextscintillaprinter.h \
+ SOURCES-=qextscintillaprinter.cpp \
+ SOURCES+=patches/qsettings.cpp \
+ SOURCES+=patches/qsettings_unix.cpp \
+ HEADERS+=patches/qsettings.h"
+
+PARALLEL_MAKE = ""
+
+do_stage() {
+ install -m 0644 qextscintilla*.h ${STAGING_INCDIR}/
+ oe_libinstall -so libqscintilla ${STAGING_LIBDIR}
+}
+
+do_install() {
+ install -d ${D}${libdir}
+ oe_libinstall -so libqscintilla ${D}${libdir}
+}
+
+FILES_${PN} = "${libdir}"
diff --git a/packages/visiscript/visiscript_0.4.3.bb b/packages/visiscript/visiscript_0.4.3.bb
new file mode 100644
index 0000000000..977cb80738
--- /dev/null
+++ b/packages/visiscript/visiscript_0.4.3.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "VisiScript is a simple graphical frontend for \
+scripting languages like minscript, Python,Ruby, Perl or others. \
+VisiScript runs on the Qtopia desktop environment of the Zaurus."
+SECTION = "opie/applications"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+DEPENDS = "qscintilla"
+LICENSE = "GPL"
+APPNAME = "visiscript"
+APPTYPE = "binary"
+APPDESKTOP = "${S}"
+
+BROKEN = "1"
+
+SRC_URI = "http://www.mneuroth.de/privat/zaurus/visiscript_src_${PV}.tar.gz \
+ file://qptrlist.h file://qcleanuphandler.h"
+
+S = "${WORKDIR}/visiscript-${PV}"
+
+inherit opie
+
+QMAKE_PROFILES = "zvisiscript.pro"
+PARALLEL_MAKE = ""
+
+EXTRA_QMAKEVARS_POST += "LIBS-=../qscintilla-1.65-gpl-1.6/qt/libqscintilla.a LIBS+=-lqscintilla LIBS+=-ldl"
+export OE_QMAKE_LINK="${CXX}"
+
+do_compile_prepend() {
+ install -m 0644 ${WORKDIR}/*.h ${S}
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/
+ install -m 0644 Visiscript.png ${D}${palmtopdir}/pics
+}
+
+#FIXME: package help and translation
diff --git a/packages/xlibs/libsm_X11R7.0-1.0.0.bb b/packages/xlibs/libsm_X11R7.0-1.0.0.bb
index 14ec6ffac0..d102f7db7a 100644
--- a/packages/xlibs/libsm_X11R7.0-1.0.0.bb
+++ b/packages/xlibs/libsm_X11R7.0-1.0.0.bb
@@ -7,8 +7,8 @@ LICENSE = "MIT-X"
DEPENDS = "libx11 libice util-macros"
-SRC_URI = "${XORG_MIRROR}/X11R7.0/src/lib/libSM-1.0.0.tar.bz2"
-S = "${WORKDIR}/libSM-1.0.0"
+SRC_URI = "${XORG_MIRROR}/X11R7.0/src/lib/libSM-${PV}.tar.bz2"
+S = "${WORKDIR}/libSM-${PV}"
inherit autotools pkgconfig
diff --git a/packages/xproto/xcb-proto_0.9.bb b/packages/xproto/xcb-proto_0.9.bb
new file mode 100644
index 0000000000..ba5e3ed953
--- /dev/null
+++ b/packages/xproto/xcb-proto_0.9.bb
@@ -0,0 +1,6 @@
+include proto-common.inc
+
+SRC_URI = "http://xcb.freedesktop.org/dist/${P}.tar.bz2"
+
+
+