summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2006-02-20 21:16:27 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-20 21:16:27 +0000
commit34d33390a3839edf0153138b1dd203ffe28a1afc (patch)
tree3f60665bdd5179135c2678c7ab4bc4da32dd0ff9
parente1a2d999dae61534f9d3fb45dd9c6e58f36403bb (diff)
parent281d9196ae77e0e4ce963126c582aec8fe665db9 (diff)
merge of 21f1a5172e471fd7060a18f3684bb74205fc749b
and d09713477314cd3b481cf7a4b6439a0d2a85a405
-rw-r--r--packages/spca5xx/spca5xx-20060202/.mtn2git_empty0
-rw-r--r--packages/spca5xx/spca5xx-20060202/Makefile.patch19
-rw-r--r--packages/spca5xx/spca5xx_20060202.bb27
3 files changed, 46 insertions, 0 deletions
diff --git a/packages/spca5xx/spca5xx-20060202/.mtn2git_empty b/packages/spca5xx/spca5xx-20060202/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/spca5xx/spca5xx-20060202/.mtn2git_empty
diff --git a/packages/spca5xx/spca5xx-20060202/Makefile.patch b/packages/spca5xx/spca5xx-20060202/Makefile.patch
new file mode 100644
index 0000000000..8053858ee1
--- /dev/null
+++ b/packages/spca5xx/spca5xx-20060202/Makefile.patch
@@ -0,0 +1,19 @@
+*** spca5xx-20060202/Makefile.orig Thu Feb 2 21:33:18 2006
+--- spca5xx-20060202/Makefile Sun Feb 19 12:39:35 2006
+***************
+*** 51,57 ****
+ default:
+ @echo ' Building SPCA5XX driver for 2.5/2.6 kernel.'
+ @echo ' Remember: you must have read/write access to your kernel source tree.'
+! $(MAKE) -C $(KERNELDIR) SUBDIRS=$(PWD) CC=$(CC) modules
+
+ install:
+ mkdir -p $(MODULE_INSTALLDIR)
+--- 51,57 ----
+ default:
+ @echo ' Building SPCA5XX driver for 2.5/2.6 kernel.'
+ @echo ' Remember: you must have read/write access to your kernel source tree.'
+! $(MAKE) -C $(KERNELDIR) SUBDIRS=$(PWD) CC="$(CC)" modules
+
+ install:
+ mkdir -p $(MODULE_INSTALLDIR)
diff --git a/packages/spca5xx/spca5xx_20060202.bb b/packages/spca5xx/spca5xx_20060202.bb
new file mode 100644
index 0000000000..a5798f5b59
--- /dev/null
+++ b/packages/spca5xx/spca5xx_20060202.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "USB Webcam driver for spca5xx chipset family supporting \
+over 100 models of camera""
+PRIORITY = "optional"
+SECTION = "kernel/modules"
+MAINTAINER = "dyoung <dyoung8888@yahoo.com>"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://mxhaard.free.fr/spca50x/Download/spca5xx-20060202.tar.gz \
+ file://Makefile.patch;patch=1"
+
+S = "${WORKDIR}/spca5xx-20060202"
+
+inherit module
+
+do_compile () {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake 'KERNELDIR=${STAGING_KERNEL_DIR}' \
+ 'CC=${KERNEL_CC}' \
+ 'LD=${KERNEL_LD}'
+}
+
+do_install() {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
+ install -m 0644 *${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
+}
+