summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim 'timtim' Ellis <tim.ellis@foonas.org>2009-01-25 11:58:00 +0000
committerTim 'timtim' Ellis <tim.ellis@foonas.org>2009-01-25 11:58:00 +0000
commit2b89f59ae0899910fe2d4ce48afce790b039c88f (patch)
tree4e458df99eff41951abac995afb0e68a24969b10
parent99e4508e3378b608e3aa37ad4e8e9781540efce4 (diff)
parent62f71fd1fae011ae065d3033401a1dcb5fcad54e (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
-rwxr-xr-xcontrib/angstrom/build-feeds.sh1
-rwxr-xr-xcontrib/angstrom/sort.sh4
-rw-r--r--packages/busybox/busybox-1.13.2/slugos/defconfig22
-rw-r--r--packages/busybox/busybox_1.13.2.bb2
-rw-r--r--packages/gnash/gnash.inc9
-rw-r--r--packages/initscripts/initscripts-1.0/slugos/checkroot (renamed from packages/initscripts/initscripts-1.0/slugos/checkroot.sh)2
-rw-r--r--packages/initscripts/initscripts-1.0/slugos/domainname.sh2
-rw-r--r--packages/initscripts/initscripts-1.0/slugos/mountall.sh2
-rwxr-xr-xpackages/initscripts/initscripts-1.0/slugos/reboot2
-rw-r--r--packages/initscripts/initscripts-1.0/slugos/umountfs2
-rw-r--r--packages/initscripts/initscripts-1.0/slugos/umountnfs.sh2
-rw-r--r--packages/initscripts/initscripts-slugos_1.0.bb16
-rw-r--r--packages/iscsi-target/iscsi-target_0.4.17.bb4
-rw-r--r--packages/iscsi-target/iscsi-target_svn.bb4
-rw-r--r--packages/slugos-init/files/usb2
-rw-r--r--packages/slugos-init/slugos-init_5.0.bb7
16 files changed, 53 insertions, 30 deletions
diff --git a/contrib/angstrom/build-feeds.sh b/contrib/angstrom/build-feeds.sh
index 79cdb6917c..ab252db53d 100755
--- a/contrib/angstrom/build-feeds.sh
+++ b/contrib/angstrom/build-feeds.sh
@@ -86,6 +86,7 @@ do
claws-mail \
contacts \
cvs \
+ cwiid \
dates \
distcc \
dsniff \
diff --git a/contrib/angstrom/sort.sh b/contrib/angstrom/sort.sh
index 613e9bf99f..90d5dda9fd 100755
--- a/contrib/angstrom/sort.sh
+++ b/contrib/angstrom/sort.sh
@@ -48,7 +48,7 @@ case "$arch" in
"armv4t")
machines="ep93xx h6300 om-gta01 om-gta02 fic-gta01 fic-gta02" ;;
"armv5te")
- machines="dns323 mv2120 kuropro lspro tsx09 ts409 davinci-dvevm davinci-sffsdr neuros-osd neuros-osd2 gumstix-connex gumstix-verdex gumstix e680 a780 a1200 at91sam9263ek rokre6 rokre2 rokr-e2 akita c7x0 h2200 h3900 h4000 h5000 htcapache htctornado htcblueangel htcuniversal hx4700 nslu2le hx2000 ixp4xxle magician netbook-pro nokia770 palmt650 palmt680 palmld palmtx palmtt3 palmz72 qemuarm omap5912osk poodle spitz tosa" ;;
+ machines="n2100 dns323 mv2120 kuropro lspro tsx09 ts409 davinci-dvevm davinci-sffsdr neuros-osd neuros-osd2 gumstix-connex gumstix-verdex gumstix e680 a780 a1200 at91sam9263ek rokre6 rokre2 rokr-e2 akita c7x0 h2200 h3900 h4000 h5000 htcapache htctornado htcblueangel htcuniversal hx4700 nslu2le hx2000 ixp4xxle magician netbook-pro nokia770 palmt650 palmt680 palmld palmtx palmtt3 palmz72 qemuarm omap5912osk poodle spitz tosa" ;;
"armv5teb")
machines="ixp4xxbe nslu2be" ;;
"armv6-novfp")
@@ -77,7 +77,7 @@ case "$arch" in
"ppc405")
machines="dht-walnut" ;;
"ppc603e")
- machines="efika" ;;
+ machines="lsppchd lsppchg efika n1200" ;;
"ppce300c3")
machines="mpc8313e-rdb mpc8315e-rdb" ;;
"sparc")
diff --git a/packages/busybox/busybox-1.13.2/slugos/defconfig b/packages/busybox/busybox-1.13.2/slugos/defconfig
index dff07829af..67c7a98aae 100644
--- a/packages/busybox/busybox-1.13.2/slugos/defconfig
+++ b/packages/busybox/busybox-1.13.2/slugos/defconfig
@@ -427,13 +427,13 @@ CONFIG_DEFAULT_DEPMOD_FILE="modules.dep"
# CONFIG_MODPROBE_SMALL is not set
# CONFIG_FEATURE_MODPROBE_SMALL_OPTIONS_ON_CMDLINE is not set
# CONFIG_FEATURE_MODPROBE_SMALL_CHECK_ALREADY_LOADED is not set
-CONFIG_INSMOD=y
-CONFIG_RMMOD=y
-CONFIG_LSMOD=y
-CONFIG_FEATURE_LSMOD_PRETTY_2_6_OUTPUT=y
-CONFIG_MODPROBE=y
-CONFIG_FEATURE_MODPROBE_BLACKLIST=y
-CONFIG_DEPMOD=y
+# CONFIG_INSMOD is not set
+# CONFIG_RMMOD is not set
+# CONFIG_LSMOD is not set
+# CONFIG_FEATURE_LSMOD_PRETTY_2_6_OUTPUT is not set
+# CONFIG_MODPROBE is not set
+# CONFIG_FEATURE_MODPROBE_BLACKLIST is not set
+# CONFIG_DEPMOD is not set
#
# Options common to multiple modutils
@@ -444,14 +444,14 @@ CONFIG_DEPMOD=y
# CONFIG_FEATURE_INSMOD_LOADINKMEM is not set
# CONFIG_FEATURE_INSMOD_LOAD_MAP is not set
# CONFIG_FEATURE_INSMOD_LOAD_MAP_FULL is not set
-CONFIG_FEATURE_CHECK_TAINTED_MODULE=y
-CONFIG_FEATURE_MODUTILS_ALIAS=y
-CONFIG_FEATURE_MODUTILS_SYMBOLS=y
+# CONFIG_FEATURE_CHECK_TAINTED_MODULE is not set
+# CONFIG_FEATURE_MODUTILS_ALIAS is not set
+# CONFIG_FEATURE_MODUTILS_SYMBOLS is not set
#
# Linux System Utilities
#
-CONFIG_BLKID=y
+# CONFIG_BLKID is not set
CONFIG_DMESG=y
CONFIG_FEATURE_DMESG_PRETTY=y
# CONFIG_FBSET is not set
diff --git a/packages/busybox/busybox_1.13.2.bb b/packages/busybox/busybox_1.13.2.bb
index 1e4b09bae2..d316b16472 100644
--- a/packages/busybox/busybox_1.13.2.bb
+++ b/packages/busybox/busybox_1.13.2.bb
@@ -1,6 +1,6 @@
require busybox.inc
-PR = "r7"
+PR = "r8"
SRC_URI = "\
http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
diff --git a/packages/gnash/gnash.inc b/packages/gnash/gnash.inc
index f4c7c1338d..29308b6c0a 100644
--- a/packages/gnash/gnash.inc
+++ b/packages/gnash/gnash.inc
@@ -4,7 +4,7 @@ LICENSE = "GPL-2"
DEPENDS = "libtool gtk+ cairo libxml2 libsdl-mixer zlib boost jpeg pango curl freetype \
${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'ffmpeg libmad', d)}"
-PR = "r4"
+PR = "r5"
SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gnash/${PV}/gnash-${PV}.tar.bz2 \
"
@@ -23,12 +23,17 @@ EXTRA_OECONF = "--enable-gui=gtk \
${@base_conditional('ENTERPRISE_DISTRO', '1', '', '--enable-mad', d)} \
--enable-cairo \
--enable-plugin \
+ --enable-plugins \
+ --enable-npapi \
+ --with-npapi-plugindir=${libdir}/mozilla/plugins \
+ --enable-mit-shm \
--disable-cygnal \
--with-top-level=${STAGING_DIR_HOST}/usr \
"
-PACKAGES =+ " libgnashamf libgnashbackend libgnashbase libgnashgeo libgnashgui libgnashplayer libgnashserver "
+PACKAGES =+ " gnash-browser-plugin libgnashamf libgnashbackend libgnashbase libgnashgeo libgnashgui libgnashplayer libgnashserver "
+FILES_gnash-browser-plugin= "${libdir}/mozilla/plugins/*"
FILES_libgnashamf = "${libdir}/gnash/libgnashamf-${PV}.so"
FILES_libgnashbackend = "${libdir}/gnash/libgnashbackend-${PV}.so"
FILES_libgnashbase = "${libdir}/gnash/libgnashbase-${PV}.so"
diff --git a/packages/initscripts/initscripts-1.0/slugos/checkroot.sh b/packages/initscripts/initscripts-1.0/slugos/checkroot
index 3943f13427..31291cdc65 100644
--- a/packages/initscripts/initscripts-1.0/slugos/checkroot.sh
+++ b/packages/initscripts/initscripts-1.0/slugos/checkroot
@@ -1,4 +1,4 @@
-#
+#!/bin/sh
# checkroot.sh Check to root filesystem.
#
# Version: @(#)checkroot.sh 2.84 25-Jan-2002 miquels@cistron.nl
diff --git a/packages/initscripts/initscripts-1.0/slugos/domainname.sh b/packages/initscripts/initscripts-1.0/slugos/domainname.sh
index 7113467d8c..e12de0e130 100644
--- a/packages/initscripts/initscripts-1.0/slugos/domainname.sh
+++ b/packages/initscripts/initscripts-1.0/slugos/domainname.sh
@@ -1,4 +1,4 @@
-#
+#!/bin/sh
# domainname.sh Set the domainname.
#
test -r /etc/defaultdomain &&
diff --git a/packages/initscripts/initscripts-1.0/slugos/mountall.sh b/packages/initscripts/initscripts-1.0/slugos/mountall.sh
index 3a155d155b..1ae02df6a3 100644
--- a/packages/initscripts/initscripts-1.0/slugos/mountall.sh
+++ b/packages/initscripts/initscripts-1.0/slugos/mountall.sh
@@ -1,4 +1,4 @@
-#
+#!/bin/sh
# mountall.sh Mount all filesystems.
#
# Version: @(#)mountall.sh 2.83-2 01-Nov-2001 miquels@cistron.nl
diff --git a/packages/initscripts/initscripts-1.0/slugos/reboot b/packages/initscripts/initscripts-1.0/slugos/reboot
index cb0979f400..f98b87f033 100755
--- a/packages/initscripts/initscripts-1.0/slugos/reboot
+++ b/packages/initscripts/initscripts-1.0/slugos/reboot
@@ -1,4 +1,4 @@
-#! /bin/sh
+#!/bin/sh
#
# reboot Execute the reboot command.
#
diff --git a/packages/initscripts/initscripts-1.0/slugos/umountfs b/packages/initscripts/initscripts-1.0/slugos/umountfs
index d6f432dbda..5580d7bb47 100644
--- a/packages/initscripts/initscripts-1.0/slugos/umountfs
+++ b/packages/initscripts/initscripts-1.0/slugos/umountfs
@@ -1,4 +1,4 @@
-#! /bin/sh
+#!/bin/sh
#
# umountfs Turn off swap and unmount all local filesystems.
#
diff --git a/packages/initscripts/initscripts-1.0/slugos/umountnfs.sh b/packages/initscripts/initscripts-1.0/slugos/umountnfs.sh
index 994a919225..6ff83e50d7 100644
--- a/packages/initscripts/initscripts-1.0/slugos/umountnfs.sh
+++ b/packages/initscripts/initscripts-1.0/slugos/umountnfs.sh
@@ -1,4 +1,4 @@
-#! /bin/sh
+#!/bin/sh
#
# umountnfs.sh Unmount all network filesystems.
#
diff --git a/packages/initscripts/initscripts-slugos_1.0.bb b/packages/initscripts/initscripts-slugos_1.0.bb
index 41b1e97d9d..ba1b97e024 100644
--- a/packages/initscripts/initscripts-slugos_1.0.bb
+++ b/packages/initscripts/initscripts-slugos_1.0.bb
@@ -16,7 +16,7 @@ RDEPENDS = ""
# All other standard definitions inherited from initscripts
# Except the PR which is hacked here. The format used is
# a suffix
-PR := "${PR}.16"
+PR := "${PR}.17"
FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/${P}', '${FILE_DIRNAME}/initscripts-${PV}', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
@@ -26,18 +26,28 @@ SRC_URI += "file://alignment.sh"
SRC_URI += "file://domainname.sh"
SRC_URI += "file://devices.patch;patch=1"
SRC_URI += "file://bootclean.sh"
+SRC_URI += "file://checkroot"
-# Without this it is not possible to patch checkroot.sh
+# Without this it is not possible to patch checkroot
S = "${WORKDIR}"
do_install_append() {
# the image build command now installs this for slugos
rm ${D}${sysconfdir}/device_table
+ # Ugly - we need to get rid of the checkroot.sh
+ # that was installed by initscript-1.0.bb; the new
+ # rcS script will "source" files that end in .sh,
+ # and that messes up our checkroot.sh script (due
+ # to redirection issues. We need to use only our
+ # checkroot, without the ".sh" suffix.
+ rm -f ${D}${sysconfdir}/init.d/checkroot.sh
+
# slugos specific scripts
install -m 0755 ${WORKDIR}/alignment.sh ${D}${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/domainname.sh ${D}${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/bootclean.sh ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/checkroot ${D}${sysconfdir}/init.d
# Remove the do install links (this detects a change to the
# initscripts .bb file - it will cause a build failure here.)
@@ -104,7 +114,7 @@ do_install_append() {
# busybox hwclock.sh (slugos-init) starts here (08)
# slugos-init umountinitrd runs here (09)
- update-rc.d -r ${D} checkroot.sh start 10 S .
+ update-rc.d -r ${D} checkroot start 10 S .
# slugos buffer syslog starts here (11)
# sysconfsetup runs at S 12
# modutils.sh runs at S 20
diff --git a/packages/iscsi-target/iscsi-target_0.4.17.bb b/packages/iscsi-target/iscsi-target_0.4.17.bb
index 8acb945a71..deb09022d4 100644
--- a/packages/iscsi-target/iscsi-target_0.4.17.bb
+++ b/packages/iscsi-target/iscsi-target_0.4.17.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "iSCSI Enterprise Target is for building an iSCSI storage system on Linux"
HOMEPAGE = "http://iscsitarget.sourceforge.net/"
LICENSE = "GPL"
-PR = "r0"
+PR = "r1"
SRC_URI = "${SOURCEFORGE_MIRROR}/iscsitarget/iscsitarget-${PV}.tar.gz \
file://libs.patch;patch=1 \
@@ -10,7 +10,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/iscsitarget/iscsitarget-${PV}.tar.gz \
S = "${WORKDIR}/iscsitarget-${PV}"
DEPENDS = "openssl"
-RDEPENDS = "kernel-module-crc32c kernel-module-libcrc32c"
+RRECOMMENDS = "kernel-module-crc32c kernel-module-libcrc32c"
inherit module
diff --git a/packages/iscsi-target/iscsi-target_svn.bb b/packages/iscsi-target/iscsi-target_svn.bb
index 92d3c376d5..774674002e 100644
--- a/packages/iscsi-target/iscsi-target_svn.bb
+++ b/packages/iscsi-target/iscsi-target_svn.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "iSCSI Enterprise Target is for building an iSCSI storage system on Linux"
HOMEPAGE = "http://iscsitarget.sourceforge.net/"
LICENSE = "GPL"
-PR = "r12"
+PR = "r13"
DEFAULT_PREFERENCE = "-1"
@@ -12,7 +12,7 @@ SRC_URI = "svn://svn.berlios.de/iscsitarget/;module=trunk;rev=HEAD \
"
DEPENDS = " openssl"
-RDEPENDS = "kernel-module-crc32c kernel-module-libcrc32c"
+RRECOMMENDS = "kernel-module-crc32c kernel-module-libcrc32c"
S = "${WORKDIR}/trunk"
diff --git a/packages/slugos-init/files/usb b/packages/slugos-init/files/usb
new file mode 100644
index 0000000000..b641113137
--- /dev/null
+++ b/packages/slugos-init/files/usb
@@ -0,0 +1,2 @@
+install uhci-hcd /sbin/modprobe ehci-hcd ; /sbin/modprobe -i uhci-hcd
+install ohci-hcd /sbin/modprobe ehci-hcd ; /sbin/modprobe -i ohci-hcd
diff --git a/packages/slugos-init/slugos-init_5.0.bb b/packages/slugos-init/slugos-init_5.0.bb
index 822e252dee..e7a45a94aa 100644
--- a/packages/slugos-init/slugos-init_5.0.bb
+++ b/packages/slugos-init/slugos-init_5.0.bb
@@ -4,7 +4,7 @@ PRIORITY = "required"
LICENSE = "GPL"
DEPENDS = "base-files devio"
RDEPENDS = "busybox devio"
-PR = "r6"
+PR = "r8"
SRC_URI = "file://boot/flash \
file://boot/disk \
@@ -29,6 +29,7 @@ SRC_URI = "file://boot/flash \
file://leds \
file://turnup \
file://reflash \
+ file://usb \
"
SBINPROGS = ""
@@ -60,6 +61,7 @@ do_install() {
${D}${sysconfdir}/default \
${D}${sysconfdir}/init.d \
${D}${sysconfdir}/modutils \
+ ${D}${sysconfdir}/modprobe.d \
${D}${sysconfdir}/udev \
${D}${sbindir} \
${D}${base_sbindir} \
@@ -108,6 +110,9 @@ do_install() {
# Developer-only tools, tucked away
install -m 0755 reflash ${D}${sysconfdir}/default
+ # Modprobe configuration files
+ install -m 0644 usb ${D}${sysconfdir}/modprobe.d
+
set +ex
}