summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStelios Koroneos <skoroneos@digital-opsis.com>2007-02-20 09:39:55 +0000
committerStelios Koroneos <skoroneos@digital-opsis.com>2007-02-20 09:39:55 +0000
commit22c75405edaa4b83cb446be6aaefe2db10042e39 (patch)
tree3187de09ce30fa13fbc19b3a259067edf21c468b
parentf9a336149429ff9d1ad5a6298961db5414d45091 (diff)
packages/apache2/apache2-2.2.3: Fix wrong assuption about ptr length during configure
To be able to compile you need to add ac_cv_sizeof_long_p in the site file of your arch (if not allready there)
-rw-r--r--packages/apache2/apache2-2.2.3/configure-fix-cross-compile-ptr-check.patch17
-rw-r--r--packages/apache2/apache2_2.2.3.bb7
2 files changed, 21 insertions, 3 deletions
diff --git a/packages/apache2/apache2-2.2.3/configure-fix-cross-compile-ptr-check.patch b/packages/apache2/apache2-2.2.3/configure-fix-cross-compile-ptr-check.patch
new file mode 100644
index 0000000000..fab828ddc3
--- /dev/null
+++ b/packages/apache2/apache2-2.2.3/configure-fix-cross-compile-ptr-check.patch
@@ -0,0 +1,17 @@
+--- ./orig-configure 2007-02-20 11:05:12.000000000 +0200
++++ ./configure 2007-02-20 11:14:11.000000000 +0200
+@@ -6667,7 +6667,13 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ if test "$cross_compiling" = yes; then
+- ap_void_ptr_lt_long=yes
++
++ if test "$ac_cv_sizeof_long_p" = "$ac_cv_sizeof_void_p"; then
++ ap_void_ptr_lt_long=no
++ else
++ ap_void_ptr_lt_long=yes
++ fi
++
+ else
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
diff --git a/packages/apache2/apache2_2.2.3.bb b/packages/apache2/apache2_2.2.3.bb
index df043d0ebf..ddc4131dae 100644
--- a/packages/apache2/apache2_2.2.3.bb
+++ b/packages/apache2/apache2_2.2.3.bb
@@ -1,15 +1,16 @@
-DESCRIPTION = "The apache v2 web server"
SECTION = "net"
+DESCRIPTION = "The apache v2 web server"
DEPENDS = "apache2-native openssl expat pcre"
RDEPENDS += "openssl"
-PR = "r4"
+PR = "r5"
SRC_URI = "http://apache.mirrors.tds.net/httpd/httpd-2.2.3.tar.bz2 \
file://dftables-makefile-patch;patch=1 \
file://apr-sockets-patch;patch=1 \
file://configure-patch;patch=1 \
- file://server-makefile-patch;patch=1"
+ file://server-makefile-patch;patch=1 \
+ file://configure-fix-cross-compile-ptr-check.patch;patch=1"
#
# over-ride needed since apache unpacks into httpd