summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>2004-06-30 15:46:14 +0000
committerPhil Blundell <philb@gnu.org>2004-06-30 15:46:14 +0000
commit14ec5d990b7f9ad56b7ce4147eac4f9e5f9f4261 (patch)
tree09842fd0f4d33ef2f4ce12993ccbb1384ec2736a
parent7e3a33235013411c3624f8d206d7da773df8f4a4 (diff)
add zip-native to DEPENDS
BKrev: 40e2e046dc9shmc8tHIXRflt-0Mvbw
-rw-r--r--firefox/firefox_0.9.oe30
1 files changed, 30 insertions, 0 deletions
diff --git a/firefox/firefox_0.9.oe b/firefox/firefox_0.9.oe
index e69de29bb2..116e3ce5bb 100644
--- a/firefox/firefox_0.9.oe
+++ b/firefox/firefox_0.9.oe
@@ -0,0 +1,30 @@
+DEPENDS = "xt xi zip-native"
+
+SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/firefox-${PV}-source.tar.bz2 \
+ file://mozconfig \
+ file://xptcstubs.patch;patch=1"
+
+S = "${WORKDIR}/mozilla"
+
+FILES_${PN} += "${libdir}/firefox-${PV} ${datadir}/idl"
+
+# gcc-3.4 blows up in gtktext with -frename-registers on arm-linux
+CFLAGS := "${@'${CFLAGS}'.replace('-frename-registers', '')}"
+CXXFLAGS := "${@'${CXXFLAGS}'.replace('-frename-registers', '')}"
+
+export CROSS_COMPILE=1
+export HOST_LIBIDL_CONFIG="libIDL-config-2"
+export CONFIGURE_ARGS="--target=${TARGET_SYS} --host=${BUILD_SYS} --build=${BUILD_SYS} --prefix=${prefix}"
+
+do_configure() {
+ cp ${WORKDIR}/mozconfig .mozconfig
+}
+
+do_compile() {
+ make -f client.mk build_all
+}
+
+do_install() {
+ make DESTDIR="${D}" install
+}
+