summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2007-08-16 06:49:12 +0000
committerMichael Lauer <mickey@vanille-media.de>2007-08-16 06:49:12 +0000
commit12d1829e257feeec8cff59d83555a35782d47f67 (patch)
treef8e16d3b41b76f21c4a91eb10390b3c00c3d2b58
parent047e1a5d6161022f01df41b183903023dc18e25e (diff)
python-soappy: update to 0.11.6
-rw-r--r--packages/python/python-soappy/.mtn2git_empty (renamed from packages/python/python-soappy-0.11.3/.mtn2git_empty)0
-rw-r--r--packages/python/python-soappy/fix-future.patch54
-rw-r--r--packages/python/python-soappy/fpconst.py (renamed from packages/python/python-soappy-0.11.3/fpconst.py)0
-rw-r--r--packages/python/python-soappy_0.11.6.bb (renamed from packages/python/python-soappy_0.11.3.bb)6
4 files changed, 57 insertions, 3 deletions
diff --git a/packages/python/python-soappy-0.11.3/.mtn2git_empty b/packages/python/python-soappy/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/python/python-soappy-0.11.3/.mtn2git_empty
+++ b/packages/python/python-soappy/.mtn2git_empty
diff --git a/packages/python/python-soappy/fix-future.patch b/packages/python/python-soappy/fix-future.patch
new file mode 100644
index 0000000000..6c14e32c16
--- /dev/null
+++ b/packages/python/python-soappy/fix-future.patch
@@ -0,0 +1,54 @@
+Index: SOAPpy-0.11.6/SOAPpy/Client.py
+===================================================================
+--- SOAPpy-0.11.6.orig/SOAPpy/Client.py
++++ SOAPpy-0.11.6/SOAPpy/Client.py
+@@ -39,12 +39,11 @@
+ #
+ ################################################################################
+ """
++from __future__ import nested_scopes
+
+ ident = '$Id: Client.py,v 1.20 2004/04/10 04:22:52 irjudson Exp $'
+ from version import __version__
+
+-from __future__ import nested_scopes
+-
+ #import xml.sax
+ import urllib
+ from types import *
+Index: SOAPpy-0.11.6/SOAPpy/Types.py
+===================================================================
+--- SOAPpy-0.11.6.orig/SOAPpy/Types.py
++++ SOAPpy-0.11.6/SOAPpy/Types.py
+@@ -32,12 +32,11 @@
+ #
+ ################################################################################
+ """
++from __future__ import nested_scopes
+
+ ident = '$Id: Types.py,v 1.17 2004/09/11 03:03:33 warnes Exp $'
+ from version import __version__
+
+-from __future__ import nested_scopes
+-
+ import UserList
+ import base64
+ import cgi
+Index: SOAPpy-0.11.6/SOAPpy/Server.py
+===================================================================
+--- SOAPpy-0.11.6.orig/SOAPpy/Server.py
++++ SOAPpy-0.11.6/SOAPpy/Server.py
+@@ -39,12 +39,11 @@
+ #
+ ################################################################################
+ """
++from __future__ import nested_scopes
+
+ ident = '$Id: Server.py,v 1.20 2004/04/28 21:47:10 warnes Exp $'
+ from version import __version__
+
+-from __future__ import nested_scopes
+-
+ #import xml.sax
+ import re
+ import socket
diff --git a/packages/python/python-soappy-0.11.3/fpconst.py b/packages/python/python-soappy/fpconst.py
index a1f8f47e3a..a1f8f47e3a 100644
--- a/packages/python/python-soappy-0.11.3/fpconst.py
+++ b/packages/python/python-soappy/fpconst.py
diff --git a/packages/python/python-soappy_0.11.3.bb b/packages/python/python-soappy_0.11.6.bb
index 6ae59ac515..2f156acc06 100644
--- a/packages/python/python-soappy_0.11.3.bb
+++ b/packages/python/python-soappy_0.11.6.bb
@@ -1,18 +1,18 @@
DESCRIPTION = "Python SOAP Bindings"
SECTION = "devel/python"
+HOMEPAGE = "http://pywebsvcs.sourceforge.net/"
PRIORITY = "optional"
LICENSE = "BSD"
-RDEPENDS = "python-core python-xml python-fpconst"
+RDEPENDS = "python-xml python-fpconst"
SRCNAME = "SOAPpy"
SRC_URI = "${SOURCEFORGE_MIRROR}/pywebsvcs/${SRCNAME}-${PV}.tar.gz \
+ file://fix-future.patch;patch=1 \
file://fpconst.py"
S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit distutils
-# *cough*, yes this is a bit hackish.. but for now ;)
-
do_compile_prepend() {
install -m 0644 ${WORKDIR}/fpconst.py ${S}/SOAPpy/fpconst.py
}