summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-01-07 22:58:28 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-01-07 22:58:28 +0000
commit0c09d4e105a7bafcff253d29c33a0065d7fc8cb1 (patch)
treec91ca9154e16c3b5db12d844f9aa7e2920d99724
parent117c61e30edbc5cdae3e566b28c324123ca564bb (diff)
parent0c82949168aaee0b2dcfff621dab5abd5e5b0116 (diff)
merge of '4a4b64f21ff11ca4338f177d164f1dcaa692e856'
and '5a59e5215a20353d7f6bad5289ae0daa45122644'
-rw-r--r--conf/machine/htcblueangel.conf16
-rw-r--r--packages/fbreader/files/fbreader-0.7.4q_buildsys_oe.patch50
-rw-r--r--packages/mplayer/mplayer_0.0+1.0rc1.bb8
-rw-r--r--packages/xserver-common/files/xserver-imageon.patch14
-rw-r--r--packages/xserver-common/xserver-common_1.13.bb5
5 files changed, 80 insertions, 13 deletions
diff --git a/conf/machine/htcblueangel.conf b/conf/machine/htcblueangel.conf
index a9f3a77670..e92aee9972 100644
--- a/conf/machine/htcblueangel.conf
+++ b/conf/machine/htcblueangel.conf
@@ -23,13 +23,15 @@ PCMCIA_MANAGER = "pcmciautils"
PREFERRED_PROVIDER_xserver = "xserver-kdrive"
MACHINE_EXTRA_RDEPENDS = "acx-firmware"
-MACHINE_EXTRA_RRECOMMENDS = "blueangel_pcmcia \
- blueangel_audio \
- blueangel_rom \
- blueangel_kp \
- blueangel_battery \
- blueangel_leds \
- "
+MACHINE_EXTRA_RRECOMMENDS = "kernel-module-blueangel_pcmcia \
+ kernel-module-blueangel_audio \
+ kernel-module-blueangel_rom \
+ kernel-module-blueangel_kp \
+ kernel-module-blueangel_battery \
+ kernel-module-blueangel_leds \
+ kernel-module-himalaya_tsc2200 \
+ kernel-module-himalaya_ts3 \
+ kernel-module-asic3-mmc"
#
# Modules autoload and other boot properties
#
diff --git a/packages/fbreader/files/fbreader-0.7.4q_buildsys_oe.patch b/packages/fbreader/files/fbreader-0.7.4q_buildsys_oe.patch
new file mode 100644
index 0000000000..530edc7f18
--- /dev/null
+++ b/packages/fbreader/files/fbreader-0.7.4q_buildsys_oe.patch
@@ -0,0 +1,50 @@
+diff -ur fbreader-0.7.4q.org/makefiles/arch/openzaurus.mk fbreader-0.7.4q/makefiles/arch/openzaurus.mk
+--- fbreader-0.7.4q.org/makefiles/arch/openzaurus.mk 2006-12-05 10:47:51.000000000 +0000
++++ fbreader-0.7.4q/makefiles/arch/openzaurus.mk 2007-01-07 04:58:17.000000000 +0000
+@@ -15,7 +15,7 @@
+ RM = rm -rvf
+ RM_QUIET = rm -rf
+ QTINCLUDE = -I $(INCPATH)/qt2
+-GTKINCLUDE = -I$(LIBPATH)/glib-2.0/include -I$(LIBPATH)/gtk-2.0/include -I$(INCPATH)/glib-2.0 -I$(INCPATH)/gtk-2.0 -I$(INCPATH)/pango-1.0 -I$(INCPATH)/atk-1.0
++GTKINCLUDE = -I$(LIBPATH)/glib-2.0/include -I$(LIBPATH)/gtk-2.0/include -I$(INCPATH)/cairo -I$(INCPATH)/glib-2.0 -I$(INCPATH)/gtk-2.0 -I$(INCPATH)/pango-1.0 -I$(INCPATH)/atk-1.0
+ MOC = $(TOOLSPATH)/moc
+ CC = $(TOOLSPATH)/arm-linux-gcc
+ AR = $(TOOLSPATH)/arm-linux-ar rsu
+@@ -26,10 +26,10 @@
+ BZIP2LIBS = -lbz2
+
+ ifeq "$(UI_TYPE)" "opie"
+- UILIBS = -lqte -lqpe
++ UILIBS = -lqt-mt
+ else
+- UILIBS = -lgpewidget -lgtk-x11-2.0 -lgdk-x11-2.0 -lgdk_pixbuf-2.0
++ UILIBS = $(shell pkg-config --libs gtk+-2.0) -lgpewidget
+ endif
+
+-CFLAGS = -pipe -DOPIE_NO_DEBUG -DQT_NO_DEBUG -DQWS -fno-exceptions -fno-rtti -march=armv4 -mtune=xscale --param large-function-growth=2000 --param inline-unit-growth=200 -Wall -Wno-ctor-dtor-privacy -W -Winline
+-LDFLAGS = -Wl,-rpath,$(LIBDIR)
++CFLAGS = -pipe -DOPIE_NO_DEBUG -DQT_NO_DEBUG -DQWS -fno-exceptions -fno-rtti $(OE_CFLAGS)
++LDFLAGS = -Wl,-rpath,$(LIBDIR) -Wl,-rpath,$(LIBPATH)
+diff -ur fbreader-0.7.4q.org/makefiles/target.mk fbreader-0.7.4q/makefiles/target.mk
+--- fbreader-0.7.4q.org/makefiles/target.mk 2006-12-05 10:47:51.000000000 +0000
++++ fbreader-0.7.4q/makefiles/target.mk 2007-01-07 04:16:20.000000000 +0000
+@@ -1,6 +1,6 @@
+-#TARGET_ARCH = openzaurus
++TARGET_ARCH = openzaurus
+ #UI_TYPE = opie
+-#UI_TYPE = gpe
++UI_TYPE = gpe
+
+ #TARGET_ARCH = opensimpad-0.9.0
+ #UI_TYPE = opie
+@@ -11,8 +11,8 @@
+ #TARGET_ARCH = maemo
+ #UI_TYPE = maemo
+
+-TARGET_ARCH = desktop
+-UI_TYPE = gtk
++#TARGET_ARCH = desktop
++#UI_TYPE = gtk
+ #UI_TYPE = qt
+
+ #TARGET_ARCH = zaurus
diff --git a/packages/mplayer/mplayer_0.0+1.0rc1.bb b/packages/mplayer/mplayer_0.0+1.0rc1.bb
index 3a63413d7a..a55776fdb6 100644
--- a/packages/mplayer/mplayer_0.0+1.0rc1.bb
+++ b/packages/mplayer/mplayer_0.0+1.0rc1.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Open Source multimedia player."
SECTION = "multimedia"
PRIORITY = "optional"
HOMEPAGE = "http://www.mplayerhq.hu/"
-DEPENDS = "virtual/libsdl libmad zlib libpng jpeg liba52 freetype fontconfig alsa-lib lzo ncurses lame"
+DEPENDS = "virtual/libsdl libmad zlib libpng jpeg liba52 freetype fontconfig alsa-lib lzo ncurses lame libxv virtual/libx11"
RDEPENDS = "mplayer-common"
LICENSE = "GPL"
SRC_URI = "http://www1.mplayerhq.hu/MPlayer/releases/MPlayer-1.0rc1.tar.bz2 \
@@ -29,7 +29,7 @@ PACKAGE_ARCH_mencoder_collie = "collie"
RCONFLICTS_${PN} = "mplayer-atty"
RREPLACES_${PN} = "mplayer-atty"
-PR = "r4"
+PR = "r5"
PARALLEL_MAKE = ""
@@ -135,11 +135,11 @@ EXTRA_OECONF = " \
--disable-dvbhead \
--disable-mga \
--disable-xmga \
- --disable-xv \
+ --enable-xv \
--disable-xvmc \
--disable-vm \
--disable-xinerama \
- --disable-x11 \
+ --enable-x11 \
--enable-fbdev \
--disable-mlib \
--disable-3dfx \
diff --git a/packages/xserver-common/files/xserver-imageon.patch b/packages/xserver-common/files/xserver-imageon.patch
new file mode 100644
index 0000000000..6a0447a31f
--- /dev/null
+++ b/packages/xserver-common/files/xserver-imageon.patch
@@ -0,0 +1,14 @@
+Index: xserver-common-1.13/X11/Xserver
+===================================================================
+--- xserver-common-1.13.orig/X11/Xserver
++++ xserver-common-1.13/X11/Xserver
+@@ -17,6 +17,9 @@ fi
+ if [ -f /usr/bin/Xw100 ]; then
+ XSERVER=Xw100
+ fi
++if [ -f /usr/bin/Ximageon ]; then
++ XSERVER=Ximageon
++fi
+
+ . /etc/profile
+
diff --git a/packages/xserver-common/xserver-common_1.13.bb b/packages/xserver-common/xserver-common_1.13.bb
index d14cad725b..b051b5aea2 100644
--- a/packages/xserver-common/xserver-common_1.13.bb
+++ b/packages/xserver-common/xserver-common_1.13.bb
@@ -2,14 +2,15 @@ DESCRIPTION = "Common X11 scripts and support files"
LICENSE = "GPL"
SECTION = "x11"
RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo xtscal"
-PR = "r0"
+PR = "r1"
PACKAGE_ARCH = "all"
# we are using a gpe-style Makefile
inherit gpe
-SRC_URI_append = " file://setDPI.sh"
+SRC_URI_append = " file://setDPI.sh \
+ file://xserver-imageon.patch;patch=1"
do_install_append() {
install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"