summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..620acee
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,9 @@
+add_custom_target(
+ AzureLib ALL
+ DEPENDS ./azure-iot-sdk-c/cmake/iotsdk_linux/iothub_client/libiothub_client.so
+)
+
+add_custom_command(
+ OUTPUT ./azure-iot-sdk-c/cmake/iotsdk_linux/iothub_client/libiothub_client.so
+ COMMAND ./azure-iot-sdk-c/build_all/linux/build.sh --toolchain-file ./toolchain.cmake
+)