summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2018-04-10 14:44:56 -0500
committerJohn Klug <john.klug@multitech.com>2018-04-10 14:44:56 -0500
commit8f19a2fae43f9c35def0fc8e6f48315f1d13b144 (patch)
treebf37b169117130703cbdb448171a6c7788d0f39c /configure.ac
parent3c3a403e0e2c601f8610eff59ebc761fe3e4bab8 (diff)
downloadmts-io-8f19a2fae43f9c35def0fc8e6f48315f1d13b144.tar.gz
mts-io-8f19a2fae43f9c35def0fc8e6f48315f1d13b144.tar.bz2
mts-io-8f19a2fae43f9c35def0fc8e6f48315f1d13b144.zip
Add the autotools make for mts-util-lora2-reset
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 33 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..e5e16b0
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,33 @@
+AC_INIT([mts-io], [1.6.0])
+AC_CONFIG_SRCDIR([util/mts_util_lora2_reset.c])
+AM_INIT_AUTOMAKE
+AM_CONFIG_HEADER([config.h])
+
+AC_PROG_CC
+AC_PROG_CXX
+AC_PROG_INSTALL
+AC_PROG_MAKE_SET
+
+AC_HEADER_STDC
+
+AC_CHECK_HEADERS([ \
+errno.h \
+fcntl.h \
+getopt.h \
+stdint.h \
+stdio.h \
+stdlib.h \
+string.h \
+unistd.h \
+sys/ioctl.h \
+sys/types.h \
+sys/ioctl.h \
+linux/i2c.h \
+linux/i2c-dev.h \
+], [],AC_MSG_ERROR([
+required header missing]))
+
+AC_DEFINE([DEBUG], 0, [set to 1 to enable debug])
+
+AC_OUTPUT([Makefile util/Makefile])
+