summaryrefslogtreecommitdiff
path: root/recipes-bsp/multitech/mts-io-sysfs_0.2.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/multitech/mts-io-sysfs_0.2.4.bb')
-rw-r--r--recipes-bsp/multitech/mts-io-sysfs_0.2.4.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes-bsp/multitech/mts-io-sysfs_0.2.4.bb b/recipes-bsp/multitech/mts-io-sysfs_0.2.4.bb
new file mode 100644
index 0000000..a489468
--- /dev/null
+++ b/recipes-bsp/multitech/mts-io-sysfs_0.2.4.bb
@@ -0,0 +1,46 @@
+DESCRIPTION = "mts-io sysfs wrapper"
+HOMEPAGE = "http://www.multitech.net/"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+inherit update-rc.d
+
+DEPENDS = "libmts openssl"
+RDEPENDS_${PN} = "bash"
+PR = "r1"
+
+SRCREV = "${PV}"
+
+SRC_URI = "git://git.multitech.net/mts-io-sysfs.git;protocol=git;branch=master \
+ file://mts-io-sysfs.init"
+
+S = "${WORKDIR}/git"
+
+do_configure_append() {
+}
+
+do_compile() {
+ oe_runmake
+}
+
+
+fakeroot do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 ${S}/build/mts-io-sysfs ${D}${sbindir}/mts-io-sysfs
+ install -d 0755 ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/mts-io-sysfs.init ${D}${sysconfdir}/init.d/eeprom-config
+}
+
+
+INITSCRIPT_NAME = "eeprom-config"
+# Must start after MTS-IO to read the accessory cards.
+INITSCRIPT_PARAMS = "start 40 S ."
+
+FILES_${PN} += "${libdir}/mts-io-sysfs*"
+FILES_${PN} += "${sbindir}/mts-io-sysfs"
+
+# disable this on purpose for dev purposes
+do_rm_work() {
+ echo "skipping"
+}